Linux Fullscreen Crash and No Sound

We've posted an important announcement regarding the current situation and the future of the game: Announcement

  • Linux Fullscreen Crash and No Sound

    I'm using Ubuntu 14.10. I have a laptop that is connected to a monitor. The laptop lid is closed and I use the monitor with an external mouse and keyboard. The laptop screen is off. Whenever I try to play the game in fullscreen, it switches to only use the laptop screen, and turns the monitor off.

    Similar to this problem. As I said above, the laptop screen is off, but it is still detected in system display settings.


    Additionally, there is no sound. My volume is up all the way on my computer and on Rising World.

    The post was edited 1 time, last by Prime624 ().

  • Prime624 wrote:

    I'm using Ubuntu 14.10. I have a laptop that is connected to a monitor. The laptop lid is closed and I use the monitor with an external mouse and keyboard. The laptop screen is off. Whenever I try to play the game in fullscreen, it switches to only use the laptop screen, and turns the monitor off.

    Similar to this problem. I as said above, the laptop screen is off, but it is still detected in system display settings.

    I'm fine playing windowed.


    when you close the lid it will make the other screen your default screen kind of but the game does not know this it looks at video card setting and sees your laptop as the default so loads the game there
    heres a link to some info to change the delfault screen thetechrepo.com/main-articles/…other-linux-distributions


    :thumbsup: Rising Citys @ ip 74.118.138.151:4265 ServerName (Yahgiggles Rising Citys) :thumbsup:

    If at first your code does not work call it version 0.1 with the odd bug :S
  • yahgiggle wrote:

    when you close the lid it will make the other screen your default screen kind of but the game does not know this it looks at video card setting and sees your laptop as the default so loads the game there
    heres a link to some info to change the delfault screen thetechrepo.com/main-articles/…other-linux-distributions


    Wonderful! Thanks that worked. (Note to Linux users trying this in the future: the first time, after I set the primary screen, that I switched to fullscreen, it crashed like usual, but after that it works.) If I click the screen or hit the keyboard at all when the splash screen is up, it'll crash and makes it almost impossible to escape it's mouse control without hard shutting down, so I'll refrain from clicking the splash :D .

    Any ideas for the audio?

    EDIT: Also, it won't let me use RedShift in fullscreen. If I set it before, it will cancel it when it launches. If I run the command when Rising World is running (in fullscreen), it will crash.

    The post was edited 1 time, last by Prime624 ().

  • Prime624 wrote:

    There is no audio. My computer volume is all the way up and Rising World volume is all the way up.


    i take it you have sound with other stuff just not this game

    try this

    Put this line in to a text file: drivers = alsa



    name the file .alsoftrc

    and put it in your home directory. From now on it might work OK.

    if other applications don't work with sound anymore.

    Then change the line into: drivers = pulse,alsa

    you can also try this line drivers = pulse,alsa,oss,solaris,dsound,winmm,port,null,wave


    :thumbsup: Rising Citys @ ip 74.118.138.151:4265 ServerName (Yahgiggles Rising Citys) :thumbsup:

    If at first your code does not work call it version 0.1 with the odd bug :S