Recent update makes part of menu inaccessible

  • Recent update makes part of menu inaccessible

    Just started playing the new update as of today. Found an issue that prevents me from playing LAN mode with my family. All menus run off the right side and bottom of the screen. Originally on 1920 x 1080-ish resolution, tried several lower resolutions, only made it worse. Tried going to windowed mode, now I can't access the top and right of the menus, which means I can't reset it back to fullscreen. So I can't adjust anything now. Had to use the task manager to close the game.

    Oh, and yes, I verified my Video Drivers were up-to-date for my Sapphire Radeon R9 290X 4GB GDDR5 Dual DVI-D/HDMI/DP PCI-Express Graphics Card, running on my Alienware Area 51 PC, running Windows 10. Game was working fine two days ago, then downloaded the update a couple hours ago.

    Update: Issue extends into the game itself - I just noticed I can't see my health bar or the food/drink icons, and the "center" cross cursor is about 2/3 to the right of my screen and below center.

    Help!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von docredneck ()

  • If you are asking Windows to update the drivers, they might be checking only the Microsoft drivers included in the Win10 install. I don;t have a setup like yours (my computer is pretty old) but I cannot duplicate the issue even trying 1980x1080, as well as other resplutions between 1280x800 up to 2580x1600. If you are using Windows to update. you might see if a direct download from AMD of September beta drivers for Windows 10 (64-bit) fixes it?
    www2.ati.com/drivers/beta/amd-…n10-win8.1-win7-sep25.exe
    If rising world is OpenGL, then microsoft drivers usually only look for directX issues and rarely are updated for OpenGL issues, but the AMD download drivers should include updates for OpenGL games as well as DirectX games.

    Otherwise hang tight and I am surethe devs can assist once they get some of the other "patch day" issues fixed :D If you do not want to use a BETA driver then there are other Win10 drivers listed here:
    support.amd.com/en-us/download/
  • Hmm... Please try to disable fullscreen, then save the changes, then select a lower resolution. In windowed mode the screen should never be cut off, unless a resolution greater than your screen resolution is selected. If you can't adjust it ingame anymore, you can alternatively change the config.properties file in your game directory (steamversion: steam/steamapps/common/risingworld). Open it with a texteditor and change "graphic_resolution_x" and "graphic_resolution_y" to a lower resolution, e.g. 1280 and 720. Next, set "graphic_fullscreen" to false, save the changes, and try again. Alternatively you can just delete the file, that resets all settings.
  • @Brash - thanks but I used the AMD Catalyst Command Center to verify drivers are updated, not native windows.
    @red51 - editing the config.properties file manually to 1280 x 720 seems to have done the trick for now. Will experiment with slightly higher resolutions until I get the highest resolution the system can handle. Everything was fine Sunday, made no changes since then... Gremlins
    Native windows resolution was 1920 x 1080... verified. Found at 1600 x 900 start losing the top again (in windowed mode). Will keep tweaking, at least I can play at lower res.
    Thanks
  • docredneck schrieb:

    editing the config.properties file manually to 1280 x 720 seems to have done the trick for now. Will experiment with slightly higher resolutions until I get the highest resolution the system can handle. Everything was fine Sunday, made no changes since then... Gremlins
    Native windows resolution was 1920 x 1080... verified. Found at 1600 x 900 start losing the top again (in windowed mode). Will keep tweaking, at least I can play at lower res.
    Thanks

    Is 1920x1080 also set as your desktop resolution currently? I see there is a issue that the resolution does not get changed properly when selecting a resolution with the same width. In other words: eventually 1600x1200 was set previously (and the 1200 px are obviously greater than 1080 px), so changing it to 1600x900 does not change the windowsize (the resolution still stays at 1600x1200).
    Please try this: If 1920x1080 is your current desktop resolution, try to set 1920 as "graphic_resolution_x" and 1080 as "graphic_resolution_y" in the config.properties file. Make sure fullscreen is still turned off. Now start the game, and if it works, you can try to check the "undecorated" checkbox in the settings (but keep fullscreen mode disabled), this enabled an alternative fullscreen mode that should work ;)
  • Thanks, but no luck there. When I reset the graphics the whole window jumps down and right a bit, and the "undecorated" just removes the border, preventing me from re-centering the window. Anything above 1366 x 768 (directly modifying the config.properties file) just starts cropping off the top (since windowed), requiring me to use the task manager to close the game (to re-edit the config.properties to scale back the resolution). Full screen is off. Still have plenty of desktop around the window, but at least I can play. I confirmed native desktop is 1920x1080 (recommended).

    Thanks anyway. Maybe a future release will resolve it.
  • docredneck schrieb:

    Just started playing the new update as of today. Found an issue that prevents me from playing LAN mode with my family. All menus run off the right side and bottom of the screen. Originally on 1920 x 1080-ish resolution, tried several lower resolutions, only made it worse. Tried going to windowed mode, now I can't access the top and right of the menus, which means I can't reset it back to fullscreen. So I can't adjust anything now. Had to use the task manager to close the game.

    Oh, and yes, I verified my Video Drivers were up-to-date for my Sapphire Radeon R9 290X 4GB GDDR5 Dual DVI-D/HDMI/DP PCI-Express Graphics Card, running on my Alienware Area 51 PC, running Windows 10. Game was working fine two days ago, then downloaded the update a couple hours ago.

    Update: Issue extends into the game itself - I just noticed I can't see my health bar or the food/drink icons, and the "center" cross cursor is about 2/3 to the right of my screen and below center.

    Help!

    If it is windows 10 Do the following.
    Go to compatibility mode and select "this program does not display properly" and also Disable font scaling . Mine did the same thing and it fixed it for me .
  • Thanks for the idea, I couldn't find those options (looked under properties for risingworldx64.exe) but I think I found similar settings; Setting compatibility for Win 8 and checking the box for "Disable display scaling on high DPI settings" did fix it for me! I'm back to 1920 x 1080! Yay! So there must be a Win10 driver issue somewhere. It's always Microsoft's fault somewhere ;)

    I'm hoping this also resolves my recent rash of crashes. I've noticed a high frequency of "crash to desktop" if you use F2 underground, but lately started getting several per hour just walking around (traveling). I'll update if the compatibility mode resolves this as well,
    Thanks! :thumbsup: