Graphics - Not getting the full picture

Trello update: The last weeks we've been improving the terrain generation and we've also put some effort into making landscapes smoother in general (to avoid bumpy terrain). Apart from that, we've also been working on new building tools. You find more information on Trello, but also expect an announcement about the recent changes soon
  • Just installed the game, and when I start it up, it seems like I'm not seeing the top of the screen intended. However, I can't find a way to scroll the picture up.


    I suspect that it may have to do with my not using a conventional pc screen. I have hooked the graphics card (nVidia GT 640) via the standard port and a HDMI converter to my widescreen tv. I imagine widescreen solutions may produce unexpected fittings of the picture.


    However, even if I run it on a standard pc solution like 1024x768, I seem to have the issue. On the saves screen, for example, I can see the bottom part of a box seeming to contain my only save. But there seems to miss a top part with the name of the save etc.


    Maybe it's just me not having struck the right settings yet in my experiments. Any suggestions?

  • thats a bug that's been around since the last update, the only thing u can do for now is lower ur screen resolution until everything fits. My resolution is usually 1920xsomething but I had to go all the way down to 920xsomething. So just start working down. Hopefully it gets fixed in next update.

  • If you have Windows 10, please try this: Rightclick on the risingworld.exe in the game directory (Steamversion: Rightclick on RW in Steam -> Properties -> Local files -> Browse local files), go to "Properties", then "Compatibility", select compatibility mode for Windows 8 and check the "Disable display scaling on high DPI settings" box.

  • Drat, darn, and dang. How "tarsome" to have just purchased for gold coins of the realm a promising looking new game and not be able to play it properly.


    Guess it's all in the day's work for a game prospector delving into prereleases. I suppose I'll try out the remaining available resolutions, find out that they don't work either, and then wait for an update when things work.


    Thanks a bunch, though, for letting me know that it's the game. I'd prolly have wasted work days' of problem solving if you hadn't. :thumbsup:

  • Oh. Previous answer was for sagsave. Red51's reply appeared afterwards.


    I'll try your advice tomorrow. Sounds promising, but I'm busy for the rest of today, sorry. I'm really optimistic about it, tho' 8o

  • wow that actually worked, it was a bit tricky finding where to go but it worked, thanks red, I was suffering through with 920X whatever resolution, but now all is well. Mountrye if u do what red sed it fixes everything.

  • Yes, it worked for me, too. :) I do have Windows 10. (And Steam-version of the game).


    (The program file was called risingworldx64.exe -- which must just be the 64-bit version. I just want to mention that for the benefit of anybody who might want to try it, but be in doubt.)


    Thanks for the help! Next question... how to mark the thread as solved. ;)

  • PS: Perhaps I should mention that the action also did some other good. Changing resolution in-game, and switching to full-screen also works now. And a difference at some resolution between the visual placement of the mouse cursor, and where it actually worked on the screen, has also gone away now.

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!