Crash report

  • Thanks for the errorlog! It's unfortunately a rendering issue concerning OpenGL, it looks like you have already installed the latest driver (version 359.06)? This driver generation seems to have a rendering issue with the 860M series, at least there is a hotfix available for notebook graphics card. Since you have a desktop GTX 960, I guess it may be affected by this problem, too, but unfortunately no new driver is available yet.
    Basically there are two options:
    1. Either wait for a newer driver version, usually Nvidia does update the drivers very frequently
    2. Install a previous driver version
  • Just an update on crashing.
    after the latest update i still crash to desktop (Rising World has stopped working). I have updated video driver to latest update also. But now it doesnt write the hs_er_pid file or error log file to the rising world folder. I have debug enabled in the config file. not sure why its not writing to the folder now.
  • Well, the last log file (from 25th of December) was about a native crash related to SQL (something prevented the game from writing to the harddrive properly)... if debug is enabled, you can eventually have a look if a new log file is in the "Logs" subfolder (not the exe folder), eventually it may contain some useful information about whats causing the crash now.
  • finally got a hs_err_pid file to write when it crashed.I am just guessing but maybe it wasnt a java crash when it did it before, thats why it wasnt writing a hs_err_pid file for that crash??
    i really would love to figure out something i have tried everything i can think of even wiping the game from pc and reinstalling same results.
    Files
  • Hmm... you're getting some very spooky crashes, this time it's crashing when a basic native Windows function is called (by lwjgl). It's the first time I've seen this issue, it does not look like a lwjgl bug (you barely find anything related to this issue, it seems that one single person had a similar issue with Minecraft [which uses lwjgl, too], but if it's really a bug, more people would suffer from this crash). I guess it might be either caused by a driver issue (I doubt it's caused by the graphics driver, more likely by something else, e.g. chipset driver), or a erroneous Windows installation, or a hardware issue (eventually faulty RAM)... =O
    It appears that you're manually assigning more memory to the game? Maybe try to remove the "+memory" launch option from Rising World and see if the issue still persists. If that does not help, make sure your chipset driver is up-to-date, also install the latest Windows update.
  • I removed the +memory and still crashed with no hs_err_pid file. updated chipset drivers still crashed with no hs_err_pid file. windows is always up to date. I got the game in June and was able to play without crashing till about October or November, with no hardware changes. Maybe it is a hardware issue, but i dont have any problems with the 30+ other games i have.
  • Eventually you can try to disable geometry instancing (this was a major change in October), though I doubt it's a rendering issue (but who knows). To do that, go to your game directory, open the "config.properties" file with a texteditor and set "graphic_instancing" to false. Now save the file, and start the game again. Does it still crash? If so, please provide a new hs_err_pid.
  • well i did a clean startup with only microsoft services running and still crashed. HaHaha im so lost on this issue at this point. Thanks for all the suggestions Red51, if you have any other suggestions let me know. I guess im not suppose to play this game at this point in time.
  • Unfortunately I'm running out of ideas... =O I'm really sorry :( I haven't seen those crashes before (first it was a graphics driver dll, then the sqlite.dll, finally the default Windows kernelbase.dll, so quite spooky), so it must be a very specific issue... Do you eventually have any special additional hardware installed? Or do you use multiple monitors? In this case you could eventually try to use a single monitor only and see if the issue still persists.

    What antivirus program (or additional security software) do you use?