Ankündigung Bugfix 2014-12-16: Multiplayer issues fixed

Das nächste Update wird am Mittwoch, dem 26. September 2018 gegen Abend verfügbar sein. Sorry für die große Verzögerung!

  • Bugfix 2014-12-16: Multiplayer issues fixed

    Hi folks,

    A new update (version 0.5.1.2) is available! Finally the multiplayer related issues should be fixed now :) But please check it out, we need your feedback if multiplayer works now or if there are still any problems. We will fix any further issues as soon as possible.

    You also need to update your dedicated servers.

    This update also does a change to the serverbrowser, it should no longer have a long delay when clicking on "Multiplayer" or when refreshing the serverlist. Apart from that, we did some smaller changes and bugfixes, see the full changelog:

    __________________________________________________
    Bugfix 2014-12-16:
    • [Change] Serverbrowser updates serverlist now using multiple threads (should cause no delays now)
    • [Change] Now you automatically return to multiplayer menu when connecting to a server goes wrong
    • [Change] Reduced healthpoints of animals
    • [Change] Increased opening speed of scoreboard (when pressing tab)
    • [Bugfix] Fixed multiplayer "connection error" bug (need feedback!)
    • [Bugfix] Fixed erroneous LUA events (PlayerEnterChunk and PlayerEnterWorldpart)
    • [Bugfix] Max players setting (multiplayer) should work now correctly
    • [Bugfix] Serverlist no longer stops updating when a server is not reachable
    • [Bugfix] Fixed illegal state error which occurred sometimes in multiplayer
    • [Bugfix] Fixed some NPC related issues (causing different problems)
  • red51 schrieb:

    Hi folks,

    A new update (version 0.5.1.2) is available! Finally the multiplayer related issues should be fixed now :) But please check it out, we need your feedback if multiplayer works now or if there are still any problems. We will fix any further issues as soon as possible.

    You also need to update your dedicated servers.

    This update also does a change to the serverbrowser, it should no longer have a long delay when clicking on "Multiplayer" or when refreshing the serverlist. Apart from that, we did some smaller changes and bugfixes, see the full changelog:

    __________________________________________________
    Bugfix 2014-12-16:
    • [Change] Serverbrowser updates serverlist now using multiple threads (should cause no delays now)
    • [Change] Now you automatically return to multiplayer menu when connecting to a server goes wrong
    • [Change] Reduced healthpoints of animals
    • [Change] Increased opening speed of scoreboard (when pressing tab)
    • [Bugfix] Fixed multiplayer "connection error" bug (need feedback!)
    • [Bugfix] Fixed erroneous LUA events (PlayerEnterChunk and PlayerEnterWorldpart)
    • [Bugfix] Max players setting (multiplayer) should work now correctly
    • [Bugfix] Serverlist no longer stops updating when a server is not reachable
    • [Bugfix] Fixed illegal state error which occurred sometimes in multiplayer
    • [Bugfix] Fixed some NPC related issues (causing different problems)


    thanks so much! :D also my friend with mac version had all low settings was running fine, then she went fullscreen and i helped her follow steps just deleted the config.properties folder and installed it again so it all works but for some reason her settings are on low again and since deleting that file its really slow again even though settings are on low was fine before deleting that file.

    now i cant join servers at all even though i couldnt join :P are they outdated still?


    @red51 now it should be fixed would you be able to join my private server to test if it works now? :)

    ok just tried joining someones server that is not highlighted red so im able to join.. and it just closes my game down <> pastebin.com/RFx69BgJ

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Degalbro ()

  • You should wait for @lucien.schuenke for Mac related issues ;)

    Yes, most servers are outdated yet.

    There was a mini bug causing the game to crash when doubleclick on a server, I made a really stupid mistake. It's fixed now, just restart Steam to redownload the update (if using standalone: delete any .jar file in one of those folders).

    Sure I can try connecting, tell me your IP or your servername ^^
  • red51 schrieb:

    You should wait for @lucien.schuenke for Mac related issues ;)

    Yes, most servers are outdated yet.

    There was a mini bug causing the game to crash when doubleclick on a server, I made a really stupid mistake. It's fixed now, just restart Steam to redownload the update (if using standalone: delete any .jar file in one of those folders).

    Sure I can try connecting, tell me your IP or your servername ^^


    sent to inbox :) <> dont think it sent to you, but here 123.211.138.61:4255
  • Degalbro schrieb:

    red51 schrieb:

    You should wait for @lucien.schuenke for Mac related issues ;)

    Yes, most servers are outdated yet.

    There was a mini bug causing the game to crash when doubleclick on a server, I made a really stupid mistake. It's fixed now, just restart Steam to redownload the update (if using standalone: delete any .jar file in one of those folders).

    Sure I can try connecting, tell me your IP or your servername ^^


    sent to inbox :) <> dont think it sent to you, but here 123.211.138.61:4255

    Please Contact me via steam steamcommunity.com/id/lucienn3/

    bleckman schrieb:

    thank you, now can people UPDATE their servers?

    Yes they can :)
  • Still get errors, example I was chopping tree's down, must have chopped 9 or 10 down in a row before the first connection issue. All the tree's was been chopped down fine then the last tree to fall exploded after I chopped it up for small logs I couldn't remove the stump so headed back to where people had started a small town and the game froze or so it seemed. I could pan around but my character remained facing the way I was heading before the game froze. I could flick between items in the inventory but the item in my hand would remain what the same as what it had been the moment the game froze. F2 didn't work either, then an error message came up and I lost connection on my second try on the server all was going well then while terraforming the landscape for my house the same thinhg happened but rather than freeze I got the error message stating connection had been lost.
  • Roy, when i chop trees down really fast in single player, i believe that happens, gotta load the level again, i do that online, i lose my connection, because im chopping in creative mode and picking them up as they fall to the ground really fast, thats what happens to me, i just have to relog back in...

    Thank you for the update guys, the multiplayer works, i can join the servers...
  • Ok so if I avoid trying pick the logs up fast this problem should be less likely to happen or perhaps increase the length of time it takes for it to happen? Still a bug though and perhaps when that gets fixed we will see much less connection issue's.

    Not sure about it been a connection issue on my end as I place a lot of multiplayer games (some of which are like F1 2014 where there is no dedicated server) and I have never had a connection problem in any of those games.
  • Roy schrieb:

    Ok so if I avoid trying pick the logs up fast this problem should be less likely to happen or perhaps increase the length of time it takes for it to happen? Still a bug though and perhaps when that gets fixed we will see much less connection issue's.

    Not sure about it been a connection issue on my end as I place a lot of multiplayer games (some of which are like F1 2014 where there is no dedicated server) and I have never had a connection problem in any of those games.


    I've made a note of the issue with @red51 - hopefully some bug testing can get done and we'll see if this is a bug.
  • I played a few hours last night. I was only able to see maybe 6 servers (there may have just been only 6). I didn't really see many issue at all though most servers were just running a few people in them. I did fall through the world a few times but I don't know if that is a network issue or a known bug. Anyways for the most part it seemed pretty stable. Good job.
  • When I go try to join a server, I can join but after so long of playing in a server I loose connection and sometimes when trying to join that same server, I get that error. If I leave it for a few minutes I can join without problem, its strange and its a 50/50 as to if I get that error or not. Some days I can join the same server without any problems after loosing connection other days though I have that error come up and seems there is no pattern for it happening. I never run anything in the background so its nothing interfering with the game, I use java 64 bit but can't see that been the problem and I have the latest java 64 bit update.