Ankündigung Changelog 17.10.2016: Vollständiger Release der Plugin API

    • so leid es mit tut weiterer fehlerbericht die tiere buggen sich die wände hoch am gebäude / senkrechte wände , sogar bis aufs dach, **das pferd auf dem flur ist mal garnichts gegen die kuh, ziege, schwein auf dem dach**. was mir aufgefallen ist das es in dem bereich wo die hochbuggen für mich nur möglich ist mich bewust zubewegen wenn ich mit f2 in den flugmodus gehe ansonsten zucke und hampel ich auf einer stelle und beim versuch die richtung zu wechseln bin ich nur am ruckeln. wenn ich dann ausloggen möchte um das spiel zu reeloggen dann tut sich nix, erst ein alt/tab bringt mich auf den desktop so das ich unter windoof da schliessen kann.

      ps.: da muss bitte auf alle fälle was gemacht werden, ich kann '51' nicht so lange alleine lassen.

      was ich dabei garnich verstehen kann das lief heute nacht von 1-5 uhr ca als ich die zweite runde ins bett bin einwandfrei

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von famyko ()

    • famyko schrieb:

      es hat sich doch ein fehler irgendwie eingeschlichen , beim multiplayer ist das jetzt so für mich wenn ich von a nach b teleportiere dann baut sich die welt irgendwie nicht mehr auf
      Hmm... vielleicht wäre ein Serverlog ganz hilfreich. Ist das lediglich beim Teleportieren?

      famyko schrieb:

      mit dem licht war es jetzt x stunden gut gerade ist mir dann aufgefallen das der fehler im multiplayer wieder da ist in dem bereich sind drei lampen zweimal die quadratische und einmal die rote warnleuchte. der fehler ist aber nur noch zu sehen wenn auf dem server nacht ist
      Das ist schade, dass der Fehler wieder auftrat. Grundsätzlich ist das in einigen Fällen tatsächlich möglich, besonders dann, wenn einzelne Chunks zu lange zum Laden brauchen. Also so lange, dass der Nachbarchunk schon längst aufgebaut ist, aber nichts von den Lichtern nebenan mitbekommen hat (dafür muss ein Chunk aber wirklich spürbar schneller aufgebaut sein als der Nachbar).

      hkurzawa schrieb:

      Es hat sich aber eine kleine Verwechslung eingeschlichen. Die Sounds beim Schließen der Holz- und Metalltruhen sind vertauscht Metalltruhen klingen hölzern und Holztruhen klingen metallisch.
      Danke für den Hinweis, das wird korrigiert :)

      TutMeistensNix schrieb:

      Erst bekomme ich eine Steam Seite die mir sagt das ich nun Steam verlasse und dann sehe ich nur:
      Oh, habe den Link dummerweise aus der Steam-Ankündigung kopiert, Steam wandelt das ja in seine eigenen Links (à la "Sie verlassen nun Steam") um. Es funktioniert auf jeden Fall, wenn du manuell javadoc.rising-world.net in den Browser eingibst. Habe die Links aber jetzt auch korrigiert ^^

      famyko schrieb:

      so leid es mit tut weiterer fehlerbericht die tiere buggen sich die wände hoch am gebäude / senkrechte wände , sogar bis aufs dach,
      Wurden an diesen Stellen evtl. umfangreiche Terrainmodifikationen vorgenommen? Also bspw. ganze Berge geebnet? Das kann weiterhin Probleme bereiten (da Tiere weiterhin noch eine sehr einfache Wegfindung haben), dies wird aber spätestens mit dem Dungeons Update geändert ;)
    • @red51 auf den serverlog habe ich kein zugriff da müste @lenko oder einer der anderen admins weiterhelfen ich geb das weiter,

      zu 2. ob die chunks sich unterschiedlich aufgebaut haben kann ich nicht sagen der fehler ist jetzt einmal aufgetreten das kann immer mal zum hängerchen kommen also nicht wirklich dramatisch.

      zu 3 da wo die tiere sich so verhalten und man selber die bewegung wie ein robot darsteller unter starkstrom macht, ist fast die einzige stelle wo ich nicht erdmassen bewegt habe. in der ecke bau nur ich und weiss darum ziemlich genau was da gemacht wurde,aber das phänomen ist irgendwie auf dem ganzen hessenstrolche server derzeit wie mir berichtet wurde,
      bis zum dungeon update können wir leider nicht warten so ist das bauen da fast bzw ist unmöglich man wird ja dauernd an nicht erkennbaren stellen festgehalten vom spiel. wäre schön wenn da ne lösung für gefunden werden könnte :)

      steam raparatur habe ich auf verdacht auch schon vorweg gemacht er sagt eine fehlerhafte datei aber lädt null byte runter ka. also wird datte nich an meiner einer liegen.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von famyko ()

    • famyko schrieb:

      @red51 auf den serverlog habe ich kein zugriff da müste @lenko oder einer der anderen admins weiterhelfen ich geb das weiter,
      Der Serverlog sieht soweit eigentlich i.O. aus. Tritt das Problem mit dem Aufbauen denn nur beim Teleportieren auf, also beim normalen Fortbewegen nicht?

      famyko schrieb:

      bis zum dungeon update können wir leider nicht warten so ist das bauen da fast bzw ist unmöglich man wird ja dauernd an nicht erkennbaren stellen festgehalten vom spiel. wäre schön wenn da ne lösung für gefunden werden könnte
      Achso, das war jetzt eher auf die Tiere bezogen ^^ Das Feststecken hingegen ist natürlich ein anderes Thema. Hier wäre ggf. auch ein clientseitiger Log hilfreich, am besten in der "config.properties" Datei den Wert "game_debug_console" auf true setzen, anschließend das Spiel starten und auf den Server verbinden. Ein bisschen rumlaufen, bis das besagte Problem aufgetreten ist. Dann am besten zum zweiten Fenster wechseln, welches im Hintergrund mitläuft (die Debug-Konsole), den Inhalt kopieren, und entweder hier posten oder auf pastebin.com
    • famyko schrieb:

      @red51 es hat sich doch ein fehler irgendwie eingeschlichen , beim multiplayer ist das jetzt so für mich wenn ich von a nach b teleportiere dann baut sich die welt irgendwie nicht mehr auf. position alles ist da nur die welt lädt eben nicht irgendwie . erst ein reelog ins hauptmenü bringt mich dann zurück in die eigentliche welt, als laie würd ich mal vermuten da hänge ich in der cloud
      das problem hab ich auch mit ner ganz neuen welt, es ladet ganz langsam und baut sich auch sehr langsam auf was vorher net war, aber trotzdem gutes update ;)
      Miacat`s Lets Play`s von Rising World auf Youtube. mehr... :rolleyes: :rolleyes: :whistling: ;)

    • also ich habe den log mit dem fehler aber den kann ich hier nicht posten, das sind mehr als 10k zeichen da fängt das forum an zu meckern mit dem anderen dingen kenne ich mich nich aus

      @red51 so habe die log bei dem link hochgeladen mein accountname da ist auch famyko die log heissen rising world debug log ka ob du die da findest ich habe von dem pastebin keine ahnung

      derzeit ist steam aber auch down in der fehlermeldung von steam heist es fehler in der steam api ka ob das zusammenhängt
      fehlercode 250
      keine kommunikatoinmit der steam api möglich. eventuell ist dieser steam-sevice momentan offline, bitte versuche es später erneut

      so steam geht wieder jetzt habe ich auch den log hochgeladen wo sich die welt nicht aufbaut

      Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von famyko ()

    • Lady_whynot schrieb:

      Wir stellen auf unserem Server fest, dass Bäume die ein Spieler gefällt hat, ein anderer nicht kleinhacken kann. Den Stumpf können beide entfernen.
      Das stimmt. Das ist ein Bug und wird in Kürze behoben :)

      Miacat schrieb:

      das problem hab ich auch mit ner ganz neuen welt, es ladet ganz langsam und baut sich auch sehr langsam auf was vorher net war, aber trotzdem gutes update
      Im Singleplayer? Handelt es sich um normale Fortbewegung (Gehen, Fliegen) oder nur beim Teleportieren?

      famyko schrieb:

      @red51 so habe die log bei dem link hochgeladen mein accountname da ist auch famyko die log heissen rising world debug log ka ob du die da findest ich habe von dem pastebin keine ahnung
      Danke, aber bitte poste noch den Link zu dem Pastebin Eintrag (sonst kann ich darauf nicht zugreifen). Einen Account musst du dir für Pastebin übrigens nicht anlegen, einfach Text ins Textfeld einfügen und "Submit" drücken. Alternativ kannst du den Log auch einfach in eine Textdatei packen und hier hochladen ;)

      famyko schrieb:

      derzeit ist steam aber auch down in der fehlermeldung von steam heist es fehler in der steam api ka ob das zusammenhängt
      Die Steam-Server waren vorhin für einige Zeit offline (irgendwann zwischen 0 und 2 Uhr)

      Deirdre schrieb:

      Werden die Minischweinchen größer oder bleiben sie so klein?
      Nein, die Minischweinchen bleiben so klein ^^ Um "wachsende" Tiere zu bekommen (bzw. Tierzucht) müssten wir etwas weiter ausholen. Das kommt definitiv noch, aber die Minischweinchen bleiben Minischweinchen
    • hkurzawa schrieb:

      Ich habe ein kleines Problem. In letzter Zeit kommt es häufig vor, das ich auf der Stelle bleibe und beim Laufen nicht vorwärts komme. D.H. auf der Stelle laufen.
      das gleiche problem ist bei uns auch wir haben red schon die log dateien geschickt, ich weiss nicht ob du das auch hinbekommst @red51 eine log datei zu schicken aber das würde sicherlich helfen, weiter oben ist ein post von red wo er erklärt wie man das machen würde :)
    • Wer momentan Probleme beim teleporten hat, bitte einfach etwas Geduld mit bringen. Wenn alles eingelesen ist läuft alles normal. Beim späteren teleporten zur gleichen Stelle sollte es etwas besser gehen.

      Red51 wurde von uns informiert und hat einige log bekommen.

      ==Hessenstrolche==

      Teamspeak 3: 185.239.238.125:9987 / Rising World Server:185.239.238.125:4255
      Homepage / Discord / FB-Gruppe
    • Ein Update ist nun verfügbar, welches eigentlich die meisten der genannten Probleme beheben sollte ;) Server müssen ebenfalls aktualisiert werden. Wenn weiterhin Probleme bestehen, sagt bitte Bescheid.

      _____________________________
      Bugfix 19.10.2016:
      • [Geändert] Sound für Minischweinchen angepasst
      • [Behoben] Behoben, dass Bäume nicht richtig entfernt wurden
      • [Behoben] Behoben, dass sich die Welt nach dem Teleportieren nur sehr langsam aufbaut
      • [Behoben] Fehlende Blaupausen Vorschaubilder korrigiert
      • [Behoben] Fehlende Texte bei "GuiLabel" Elementen behoben
      • [Behoben] Problem behoben, dass Schafe manchmal nicht geschoren werden konnten
      • [Behoben] Einige Soundprobleme behoben
      • [Behoben] Crash behoben, wenn Modelle ohne Kollision über die API erzeugt wurden
      • [Behoben] JDK Pfad "plugin_jdk_path" in Config um Plugins während Laufzeit zu kompilieren wird nun korrekt verwendet
      • [Behoben] Spawnposition der Baumstammstücke angepasst, wenn der Stumpf entfernt wird
      • [Behoben] Probleme mit Plugins im Multiplayer behoben, wenn Spieler disconnected und reconnected ist