Game won't launch on mac after newest update

We've posted an important announcement regarding the current situation and the future of the game: Announcement

  • Game won't launch on mac after newest update

    Hi,

    I haven't played after the update on 21st April until today, and the game won't launch. When clicking Play on Steam, pop up appears saying "Preparing to launch ...etc" and then it disappears. On Steam window Library section, next to Rising World on my games list, I can see the word "Running" and "Syncing" quickly appear and disappear and after that nothing happens. No other windows pop up. Tried to uninstall and re-install, didn't work. Operating system is up to date.

    //specs
    MacOS Sierra, version 10.12.4 (16E195)
    2,6 GHz Intel Core i7
    Radeon Pro 450 2048 MB
    Intel HD Graphics 530 1536 MB

    Thank you in advance! ^^
  • Sorry for my late response! :/ Do you still run into the same issue? In this case please try to verify the integrity of the game cache: support.steampowered.com/kb_article.php?ref=2037-QEUH-3335
    There are also a few programs which may interfere with Steam, e.g. "Little Snitch", "Peer Guardian" and "Norton/Symantec Internet Security". If one of these programs is running in the background, maybe try to disable it.

    If it still does not work you may try to use the old Mac launcher instead. To do that, rightclick on RW in Steam -> Properties -> Betas -> select "hotfix - old exe" and try to run the game again (once the download is ready). Does it work then?