Another DDoS attack?

  • red51 schrieb:

    There was another DDoS attack yesterday, but it was over around 10-11 hours ago. Right now there should be no more login issues. If you cannot join a server, I'd recommend to restart the game. If it still does not work, please let us know
    I am having no problems at all now, HOWEVER, 2 of my friends who play on my server are still showing it as offline. I've tried every recommendation I can think of for them
  • cintrikz schrieb:

    still having login issues on multiple accounts. did a power cycle on all hardware still showing offline.
    Have you been able to login previously? The hive should be running, and there is no attack going on right now... Do you use the Steam version, or the standalone?

    bellablu schrieb:

    I am having no problems at all now, HOWEVER, 2 of my friends who play on my server are still showing it as offline. I've tried every recommendation I can think of for them
    Does this mean your friends have an "Offline" icon in the top right corner of the screen (in the main menu), or can't they find/join the server?
  • red51 schrieb:

    cintrikz schrieb:

    still having login issues on multiple accounts. did a power cycle on all hardware still showing offline.
    Have you been able to login previously? The hive should be running, and there is no attack going on right now... Do you use the Steam version, or the standalone?

    bellablu schrieb:

    I am having no problems at all now, HOWEVER, 2 of my friends who play on my server are still showing it as offline. I've tried every recommendation I can think of for them
    Does this mean your friends have an "Offline" icon in the top right corner of the screen (in the main menu), or can't they find/join the server?
    both of us are using steam install games. playing yesterday with the new click the steam name and join the game was working good till attack. since then offline top right corner for both of us we are also in the same room here. everything seems to be working games, steam, ect. just deleted RW went in and removed the folder and reinstalled. still says offline after reinstall.
  • also, after reinstall and starting the game through steam it has a square ? and says unknownplayer a desktop with a red line and broken. after couple seconds comes up OFFLINE top right corner. pull out the steam friends window slideout on the right says hes playing a game i can click and join, just offline.
  • cintrikz schrieb:

    also, after reinstall and starting the game through steam it has a square ? and says unknownplayer a desktop with a red line and broken. after couple seconds comes up OFFLINE top right corner. pull out the steam friends window slideout on the right says hes playing a game i can click and join, just offline.
    If you want to just play P2P (i.e. if a friend hosts a game or vice-versa), you don't need a hive connection at all. The "offline" state (in the top right corner) is only relevant when playing on public multiplayer servers (which have hive verification enabled).
    If your client isn't able to establish a connection to the hive server, you can set your username manually in the "config.properties" file ("game_username") in your game directory (rightclick on rw in steam -> properties -> local files -> browse local files), do you don't have to play as "UnknownPlayer".

    What antivirus program do you use exactly? Maybe try to restart your computer and/or the router.
  • red51 schrieb:

    cintrikz schrieb:

    also, after reinstall and starting the game through steam it has a square ? and says unknownplayer a desktop with a red line and broken. after couple seconds comes up OFFLINE top right corner. pull out the steam friends window slideout on the right says hes playing a game i can click and join, just offline.
    If you want to just play P2P (i.e. if a friend hosts a game or vice-versa), you don't need a hive connection at all. The "offline" state (in the top right corner) is only relevant when playing on public multiplayer servers (which have hive verification enabled).
    If your client isn't able to establish a connection to the hive server, you can set your username manually in the "config.properties" file ("game_username") in your game directory (rightclick on rw in steam -> properties -> local files -> browse local files), do you don't have to play as "UnknownPlayer".

    What antivirus program do you use exactly? Maybe try to restart your computer and/or the router.
    no antivirus, voidlinux. changed name and its changed in game but still broken. yes we where playing offline but he wanted to join a server but we cant. no authentication possible.
  • red51 schrieb:

    To be on the safe side, we restarted the hive server now. If your IP was blocked or filtered out for some reason, this should no longer be the case now. Please try to run the game again, does it still run in offline mode?
    i restarted my computer and tried it went green. i checked my sons laptop with windows 10 and it was offline after i restarted his. i restarted mine and it says offline again... can i be getting bannded for having multiple steam clients attached from the same ip here? (both purchased off steam, i have 170+ hours and he just got his copy two days ago.)
  • @cintrikz: Hmm... one thing you could try is to post a debug log. To do that, open the config.properties file in your game directory and set "game_debug_console" to true. Save the file, and run the game again. Once you're in the main menu, quit the game, and go into the "Logs" folder in your game directory. Please upload or post the latest logfile here (or alternatively send it via email to support@jiw-games.net ) ;)

    Btw, having multiple steam clients on the same IP is no problem^^

    @Red_Baron: There is a relatively high amount of incoming connections right now, but it doesn't look like another attack... the hive seems to be fine atm... are you still unable to login?
  • red51 schrieb:

    @cintrikz: Hmm... one thing you could try is to post a debug log. To do that, open the config.properties file in your game directory and set "game_debug_console" to true. Save the file, and run the game again. Once you're in the main menu, quit the game, and go into the "Logs" folder in your game directory. Please upload or post the latest logfile here (or alternatively send it via email to support@jiw-games.net ) ;)

    Btw, having multiple steam clients on the same IP is no problem^^

    @Red_Baron: There is a relatively high amount of incoming connections right now, but it doesn't look like another attack... the hive seems to be fine atm... are you still unable to login?
    okay thanks very much for your time and help. i will look into it more tomorrow and if still a problem i will email the debug log. have to get the kids to bed now. thanks again!
  • I'm having this same issue. "You've been kicked from the server, no authentication available". For about the past hour and a half now. I can't get into any servers. I've looked into all the other suggestions I've found (firewall, AV, etc.)