Probleme unter Linux mit dem Steamclienten

  • Probleme unter Linux mit dem Steamclienten

    Hallo @red51

    Ich benutze LinuxMint 1.83, ich werde mal schaun was ich für Libs Steam bei mir benutzt, sollte aber eigentlich aktuell sein, da diese eigentlich normal bei jedem Start aktualisiert werden, jedenfalls sollte es sein. Im Spiel selbst hab ich soweit keine Probleme, erst wenn ich auf den Desktop wechsele geht der PC in die Knie und der RAM / CPU schiessen hoch. Maus lässt sich kaum bewegen.
    Könnte natürlich auch an den GrafikTreiber liegen, obwohl die von Nvidia meist immer gut performiert ist. Werde mir das ganze nochmal am WE mir ansehen ;D
  • Achso, d.h. also dass diese Probleme lediglich beim Wechsel auf den Desktop auftreten und nicht im normalen Spielbetrieb? In dem Fall könntest du evtl. einmal in die config.properties Datei im Spielverzeichnis (Rechtsklick auf RW in Steam -> Eigenschaften -> Lokale Dateien -> Lokale Dateien durchsuchen) schauen was bei game_pause_on_lost_focus gesetzt ist ;) Wenn es auf true steht, ändere es bitte auf false, ansonsten wenns schon auf false ist, ändere es bitte auf true. Im Zweifelsfall könntest du ansonsten auch bei der Standalone in die config schauen, welcher Wert dort eingestellt ist. Speichere dann die Änderungen, und starte das Spiel erneut. Tritt das Problem weiterhin auf?
  • ja stimmt, das Problem hatte ich ja auich bei der Standalone .. ok werde ich mal schaun ;D

    danke dir ;D

    Nachtrag: Da ich in einem anderen Thread was von RW und kleines Team las. Ich bin bei RW dabei, seit es auf Steam erschienen ist. Bin per Zufall entdeckt, das RW von einen sehr kleinen Team entwickelt wird, finde ich persönlich gar nicht so schlimm. Das eine oder andere hab ich schon mal geflucht über die langen Pausen zwischen den Updates. Trotzdem ist mir das Game ans Herz gewachsen, muss ich echt so sagen, es gibt kein Game, vielleicht ausser Minecraft, was ich immer wieder gerne spiele. Und der Content ist gar nicht so wenig, nur man muss sich RW annehmen, sonst wird es nichts.

    Es gibt halt Spiele, da kann die Entwicklung jahre dauern, da ist es einem eigentlich egal wie lange es dauert. Auch so ein Spiel ist übrigens auch 7Days to Die, das auch einige Jahre entwickelt wird. Ich kenne es seit der Alpha 5 oder 6.

    So mehr wollte ich gar nicht dazu schreiben und möchte hier auch kein Diskussion anregen.
  • Eigentlich sind immer noch dieselben Probleme wie oben beschrieben, das ausschalten des Focus hat leider nichts gebracht. FPS ist auch gut im Spiel, nur halt wenn ich auf dem Desktop wechsel, dann bekomme ich probleme. Die CPU Last geht nach oben und wenn ich es richtig gesehen hab auch der RAM läuft sich voll, aber das muss ich nochmal genauer nachschaun. Kann natürlich auch an Steam selbst liegen, da haben sie ja vor paar Tagen einen neue Version von ihrem Clienten rausgehauen, nur ob das was unter Linux bringt weiss ich nicht, weil unter Windows habe ich da keine Probleme.
  • red51 schrieb:

    Mit der Standalone treten diese Probleme nicht auf? Probiere am besten mal folgendes: Kopiere die config.properties aus dem Standalone-Verzeichnis einfach mal in das Steam Verzeichnis des Spiels, und starte anschließend das Spiel :) Treten die Probleme weiterhin auf?Ich
    ich hab die Datei mal kopiert, scheinbar sind die Probleme nun verschwunden, hab die Dateien mal verglichen, da sind wohl in der Standalone einige Grafikfunktionen ausgeschaltet, vielleicht kamen deshalb die Probleme. Na jedenfalls ist dieses problem gelöst ;D

    Danke für dein Support ;D

    Nachtrag: Zu früh gefreut, ich bin im Game und wechsel auf den Desktop und es bricht wieder alles zusammen, kann kaum die Maus bewegen und music im hintergrund fängt auch an stottern. Ich weiss ist bisschen seltsam vielleicht, aber könnte es mit dem FMod zusammenhängen ? Weil als ich die Audioeinstellungen vorgenommen hab, da gabs erst wieder probleme. Davor war alles gut, da stand bei Soundkarte auf interne Soundkarte.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Bogus ()

  • Ich denke nicht, dass es mit FMod zusammenhängt, auszuschließen sind solche Sachen aber besonders unter Linux natürlich nicht. Du könntest ggf. einmal die "config.properties" Datei der Steamversion einmal hier hochladen (und ggf. auch die der Standalone). Spielst du im Vollbildmodus, oder ist die "Rahmenlos" Option aktiv? Falls du im Vollbildmodus spielst, könntest du ggf. einmal probieren, den Vollbild zu deaktivieren, die Auflösung an die Desktop Auflösung anzupassen, und ein Häkchen bei "Rahmenlos" zu setzen. Wenn das nicht hilft, das Problem aber nur unter Steam auftritt, könnte es evtl. auch helfen, das Steam Overlay auszuschalten (Rechtsklick auf RW in Steam -> Eigenschaften)
  • Ok, hab mal auf Fenstermodus gemacht, konnte aber die Fenstergrösse nicht verändern, hatte auch auf Rahmenlos gesetzt. Ich lad mal die beiden Configs hoch, vielleicht findest du ja was ;D

    config.properties <--- Standalone

    config.properties <---- steam

    Das mit dem Overlay hat auch nichts genützt

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Bogus ()

  • Benutzer online 1

    1 Besucher