Posts by Cleptius

A big new update is now available, introducing biomes, caves and much more!
Latest hotfix: 0.7.0.3 (2024-02-21)

    @Zabka ich hatte die Version 1.2... und leider funktioniert ihr Downloadlink nicht.
    Und wenn ich dieses Script von ihnen verwende:


    https://github.com/RisingWorld/admin-tools


    Der Server startet zwar aber beendet sich sofort mit dieser Fehlermeldung:


    C:\Steam\RisingWorld\scripts
    SEVERE: Fatal error occurred!
    org.luaj.vm2.LuaError: load C:\Steam\RisingWorld\scripts\admin-tools-master/script.lua: org.luaj.vm2.LuaError: C:\Steam\RisingWorld\scripts\admin-tools-master/script.lua:317: '<eos>' expected
    at org.luaj.vm2.LuaValue.error(Unknown Source)
    at org.luaj.vm2.Globals.loadfile(Unknown Source)
    at lua.LuaScript.<init>(SourceFile:51)
    at lua.ScriptManager.loadScripts(SourceFile:35)
    at server.Main.c(SourceFile:334)
    at server.Main.initApplication(SourceFile:185)
    at commons.JIWApplication.initialize(SourceFile:82)
    at com.jme3.system.NullContext.initInThread(NullContext.java:84)
    at com.jme3.system.NullContext.run(NullContext.java:127)
    at java.lang.Thread.run(Unknown Source)


    Stopping 7 kernel adapters...


    Worin liegt da mein Fehler?


    MfG und Danke.

    Mahlzeit erstmal,


    zuerst einmal ich bin leider nen völliger LUA noob :(
    ich hatte mir nen Server erstellt und er läuft bereits. Nun hab ich das Problem wenn ich Zscript einbinden will startet der Server komplett normal, sobald ich mich verbinde läd er nicht mehr weiter.
    In den Logs gibt es dann folgende Fehlermeldung:


    !result.next
    CREATEPLAYER: Cleptius
    LOADPLAYER: Cleptius
    org.luaj.vm2.LuaError: @C:\Steam\RisingWorld\scripts\RW Zcript/script.lua:455 attempt to call nil
    at org.luaj.vm2.LuaValue.checkmetatag(Unknown Source)
    at org.luaj.vm2.LuaValue.callmt(Unknown Source)
    at org.luaj.vm2.LuaValue.invoke(Unknown Source)
    at org.luaj.vm2.LuaClosure.execute(Unknown Source)
    at org.luaj.vm2.LuaClosure.onInvoke(Unknown Source)
    at org.luaj.vm2.LuaClosure.invoke(Unknown Source)
    at lua.ScriptEventList.triggerEvent(SourceFile:20)
    at lua.ScriptEventManager.triggerEvent(SourceFile:32)
    at x.c.a(SourceFile:554)
    at x.c.messageReceived(SourceFile:89)
    at de.jiw.network.kernel.KernelAdapter.dispatch(KernelAdapter.java:164)
    at de.jiw.network.kernel.KernelAdapter.createAndDispatch(KernelAdapter.java:189)
    at de.jiw.network.kernel.KernelAdapter.run(KernelAdapter.java:230)
    Server DisconnectMessage


    Was muss ich machen damit ich das Script zum laufen bekomme?


    Danke schon mal im voraus! ^^