Can't connect to my local server : Steamworks is not initialized.

  • Hello,

    I try use my new unity local server :

    Rising World Dedicated Server Version 0.4.8 (5) 2022-07-31 10:43
    Linux 5.10 Debian GNU/Linux 11 64bit (Desktop)
    AMD Ryzen 5 3400G with Radeon Vega Graphics, 8 Cores, 3843 MHz
    PC 15974 MB RAM
    Commit: 4ed04269815a2483771fcce527232b84e4ffcf85
    Branch: master JobID: 9039

    I have a problem when the player try to connect : I have the following error in logs :

    [SteamAuth] EBeginAuthSessionResult (76------------81): k_EBeginAuthSessionResultGameMismatch
    [ERROR] InvalidOperationException: Steamworks is not initialized.
    Steamworks.InteropHelp.TestIfAvailableClient () (at <00000000000000000000000000000000>:0)
    Steamworks.SteamUtils.GetAppID () (at <00000000000000000000000000000000>:0)
    RisingWorld.Server.Platforms.SteamServerSDK.SteamServer.AuthenticatePlayer (JIW.Network.Core.Server.AbstractConnection client, RisingWorld.Common.Platforms.SDK sdkType, System.String playerUID, System.String playerName, System.Byte[] authData, System.Action`3[T1,T2,T3] onComplete) (at <00000000000000000000000000000000>:0)
    RisingWorld.Server.Network.Listeners.ServerPlayerListener+<>c__DisplayClass3_0.<PlayerAuthRequestReceived>b__0 () (at <00000000000000000000000000000000>:0)
    RisingWorld.Common.JIWApplication.Update () (at <00000000000000000000000000000000>:0)

    Where can this error come from? Is there a component I forgot to configure?

    Thank you,


  • This error indicates that the Steam API was not yet initialized when the client connected... maybe that client tried to join the server while it was still starting (it usually takes a few seconds until the server is "ready")?

    Do you always get the same error when a player tries to connect? Maybe post the full server log here (or alternatively send it via PM to me), it will probably contain more information about what's going on :)

  • Thanks for the log! It looks like this happens when launching the server through the Steam client: Steam seems to overwrite the app ID in this case (using the server app ID, although the game app ID is required), resulting in such an issue... the last update was supposed to fix that by changing the app ID environment variable, but apparently that didn't work... we'll fix that with the next update! Thanks for bringing this to our attention!

    In the meantime, you can fix this issue by launching the server directly from the server directory on your hard drive instead of launching it through the Steam client ;) If that still doesn't work, please let me know!

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!