Client Suddenly Won't Run

  • Today I opened Steam and tried to load RW. Steam said "updating", which seemed odd since I already have the most recent update. I checked 30 minutes later, and it was still at 0% updated. So I went to the steam beta options for the game, switched it back to the Java Version. Steam started to download that content, then I switched it back to the beta version. Steam then downloaded the entire game. After that, I was able to run the game, and log onto a server. I played for a while without issue, but it seemed that /showareas wasn't working, so I tried to log off and back in. The server (Wild Frontiers in case it matters) loaded to 10 percent, then I got an unhandled exception. I tried to click report error and the game crashed completely. I loaded it again, and had the exact same error. This time I copied the text, it is pasted below. Currently I toggled the beta setting again, and it is re-downloading the whole game again. Also, I didn't try to load single player, but the error message suggests it's multiplayer issue.

    Hoping for some resolution so I can play again! Thanks in advance.

    Windows 10 (10.0.19045) 64bit (Desktop) Direct3D 11.0 [level 11.1]

    AMD Ryzen 7 1700X Eight-Core Processor , 16 Cores, 3394 MHz

    System Product Name (System manufacturer) 16310 MB RAM

    NVIDIA GeForce GTX 1070, 8081 MB VRAM, 2023-04-25,

    Commit: 78509c3d92f76f63a54da3734a0071513bca81ef

    Branch: master JobID: 13315


    NullReferenceException - Object reference not set to an instance of an object.

    at RisingWorld.Content.Network.ClientPlayerListener.PlayerSyncReceived (JIW.Network.Core.Common.IPacket packet) [0x00000] in <00000000000000000000000000000000>:0

    at JIW.Network.Core.Client.AbstractNetworkClient.Update (System.Single tpf) [0x00000] in <00000000000000000000000000000000>:0

    at RisingWorld.Content.Network.NetworkManager.OnUpdate (System.Single tpf) [0x00000] in <00000000000000000000000000000000>:0

    at RisingWorld.Common.JIWApplication.Update () [0x00000] in <00000000000000000000000000000000>:0

  • Update: I reinstalled with no issues, so I think it was a hardware issue (probably my aging SSD). As for /showareas not working, I realized that I need to type it in the console now


  • Thanks for the log and the report (we received it) :)

    Actually this is unfortunately indeed a bug :silenced: It only happens in multiplayer and is related to other players using vehicles :/ We'll fix that with the next update, but if this keeps happening, we'll try to prepare a hotfix for that in the meantime!

  • Ah, I see. I just tried to run it again and got the same error. I tried "verify game files" in steam, that didn't help. Suppose I'll reinstall again for now....

  • red51

    Added the Label English

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!