Server not showing up on list

  • Steam or Standalone?
    Singleplayer or multiplayer?
    Error message?
    Operating system


    I'm trying to set up a multiplayer server for myself and a friend and have followed the instructions to download the dedicated server from SteamCMD as well as to run the server itself. I should say here that I have never run a server like this before and am unfamiliar with a lot of the stuff being mentioned. However, I was able to successfully get the server downloaded from SteamCMD and have set up port forwarding on my router. I did this by setting up the default port as 2455 and allowed ports 2454 through 2459 on my port forwarding from my router. I also gave the server a name on the server properties file by opening it with notepad. When I run the win_startupscript, it looks like it is connected and has a message saying "Steam Servers Connected" with a long number and IP address. However, when I log into the game client and look at the multiplayer servers listed, I don't see my server listed.

    Any thoughts on what I could have missed? Also, I appreciate any patience others have for me as I try to understand the terminology being used as I was completely new to things like port forwarding, steamcmd, etc. before starting this.

  • If you run the server on your local machine and it does not show up in the server browser, this usually happens if either a wrong ip is set for the server, or if something went wrong with port forwarding. Make sure to keep the server_ip field in the file blank (or more precisely, only put your public ip there if you're not behind a router) - then the server binds to all addresses.

    If the field is already blank, you can check if port forwarding actually worked on this website:

    Just run the server, then enter the port in question on the website. If you've set up port 2455 as server_port in the properties file, the server automatically uses port 2454 for http queries (which are crucial for the server to show up in the list), so make sure to check this particular port.

    If the tool tells you the port is closed, either the port forwarding didn't work, or something else is blocking the connection (antivirus program, firewall etc) :thinking:

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    • :)
    • ;)
    • :(
    • :P
    • ^^
    • :D
    • :verysad:
    • ;(
    • X(
    • :*
    • :|
    • :crazy:
    • :lol:
    • :dizzy:
    • =O
    • <X
    • ||
    • :thinking:
    • :wacko:
    • :/
    • 8)
    • :wat:
    • :huh:
    • :silenced:
    • :wow:
    • 8|
    • :angry:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :hushed:
    • :nerd:
    • :saint:
    • :drooling:
    • :love:
    • :monocle:
    • :poo:
    • :party:
    • :drunk:
    • <3
    • :!:
    • :?:
    The maximum number of attachments: 10
    Maximum File Size: 1 MB
    Allowed extensions: 7z, avi, bmp, dds, gif, jpeg, jpg, json, log, lua, mp3, mp4, ogg, pdf, permissions, png, properties, rar, txt, xml, zip

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!