Existing Linux Server update, help me please

We've posted an important announcement regarding the current situation and the future of the game: Announcement

  • Existing Linux Server update, help me please

    Short and simple:

    Epic Insomniacs server
    Downloaded updated server files.
    Saved World and Scripts and server.properties in a backup.
    Threw the new server files in the "server directory".

    ran the linux startup script which results in a "servername started"

    but there is no screen session for it.

    Checked the log and have this:

    Source Code

    1. ​Rising World - 0.5.3.5 - Dedicated Server
    2. Linux 2.6.32-042stab102.9 Java 1.8.0_31
    3. 23.02.2015 10:39
    4. Items initialized!
    5. Plants initialized!
    6. NPCs initialized!
    7. Initialize Static Classes...
    8. Constructions initialized!
    9. Objects initialized!
    10. Picking initialized!
    11. Food-Definitions initialized!
    12. Crafting-Definitions initialized!
    13. Feb 23, 2015 10:40:00 PM s.g a
    14. INFO: Register BuildDestroyPermission: object.plank
    15. Feb 23, 2015 10:40:00 PM s.g a
    16. INFO: Register BuildDestroyPermission: ores.copper
    17. Feb 23, 2015 10:40:00 PM s.g a
    18. INFO: Register BuildDestroyPermission: world.dirt
    19. Feb 23, 2015 10:40:00 PM s.g a
    20. INFO: Register BuildDestroyPermission: world.stone
    21. Feb 23, 2015 10:40:00 PM s.g c
    22. INFO: Register MainPermission: permission.changespawn
    23. Feb 23, 2015 10:40:00 PM server.Main handleError
    24. SEVERE: Fatal error occurred!
    25. java.lang.IllegalArgumentException: No enum constant n.k.b.Normal
    26. at java.lang.Enum.valueOf(Enum.java:238)
    27. at n.k$b.valueOf(SourceFile:79)
    28. at server.Main.c(SourceFile:249)
    29. at server.Main.initApplication(SourceFile:143)
    30. at commons.JIWApplication.initialize(SourceFile:81)
    31. at com.jme3.system.NullContext.initInThread(NullContext.java:84)
    32. at com.jme3.system.NullContext.run(NullContext.java:127)
    33. at java.lang.Thread.run(Thread.java:745)
    Display All


    I've wiped it all out, and started from scratch (copying in my backed up world and scripts).. same errors.
    I've wiped it all out, and started from scratch (vanilla, invoked a new world, no scripts).. same erros.



    Please help me *nix masters, I'm at a loss here. List of things to double check, dependencies to check? Any help at all would be greatly appreciated.
    Epic Insomniacs Rising World!

    Come have some fun @ 62.213.195.243:4255 or find us in the server list:
    [420] Epic Insomniacs Rising World Server

  • red51 wrote:

    Something seems to be wrong with the server setting server_world_type. Is there maybe an escape character or a space after the "Normal"? Alternatively try to delete this whole line from the server.properties file and start the server again.



    That was is red, can't thank you enough.

    I actually nano'd my server.properties and went down the list backspacing and entering to take all those spaces out but I missed that 1.

    Thank you again!!!
    Epic Insomniacs Rising World!

    Come have some fun @ 62.213.195.243:4255 or find us in the server list:
    [420] Epic Insomniacs Rising World Server