problem end convert ( resolved)

A new status update as well as a first preview video of the new version are now available!
  • hi all team


    is problem end convert


    6.1.7. a 6.2


    mysql
    windows
    convert lod 5750/7714
    convert lod 5751/7714
    convert lod 5752/7714
    convert lod 5753/7714
    convert lod 5754/7714
    convert lod 5755/7714
    convert lod 5756/7714
    convert lod 5757/7714
    convert lod 5758/7714
    convert lod 5759/7714
    convert lod 5760/7714
    convert lod 5761/7714
    convert lod 5762/7714
    convert lod 5763/7714
    Worldpart generating...
    Biomepart generating...
    11.11.2015 17:51 server.Main
    SEVERE: Fatal error occurred!
    java.lang.OutOfMemoryError: GC overhead limit exceeded
    at o.l.a(SourceFile:700)
    at o.l.a(SourceFile:736)
    at o.l.a(SourceFile:374)
    at o.l.a(SourceFile:433)
    at o.l.a(SourceFile:195)
    at o.l.a(SourceFile:411)
    at o.l.a(SourceFile:395)
    at o.l.a(SourceFile:450)
    at o.e.<init>(SourceFile:58)
    at server.util.E.<init>(SourceFile:22)
    at server.util.t.a(SourceFile:239)
    at server.util.j.a(SourceFile:1880)
    at server.util.a.a(SourceFile:109)
    at server.b.a(SourceFile:1100)
    at server.b.a(SourceFile:1040)
    at server.b.a(SourceFile:880)
    at server.Main.c(SourceFile:317)
    at server.Main.initApplication(SourceFile:191)
    at commons.JIWApplication.initialize(SourceFile:82)
    at com.jme3.system.NullContext.initInThread(NullContext.java:86)
    at com.jme3.system.NullContext.run(NullContext.java:129)
    at java.lang.Thread.run(Unknown Source)


    Fatal error occurred!
    java.lang.OutOfMemoryError: GC overhead limit exceeded
    at o.l.a(SourceFile:700)
    at o.l.a(SourceFile:736)
    at o.l.a(SourceFile:374)
    at o.l.a(SourceFile:433)
    at o.l.a(SourceFile:195)
    at o.l.a(SourceFile:411)
    at o.l.a(SourceFile:395)
    at o.l.a(SourceFile:450)
    at o.e.<init>(SourceFile:58)
    at server.util.E.<init>(SourceFile:22)
    at server.util.t.a(SourceFile:239)
    at server.util.j.a(SourceFile:1880)
    at server.util.a.a(SourceFile:109)
    at server.b.a(SourceFile:1100)
    at server.b.a(SourceFile:1040)
    at server.b.a(SourceFile:880)
    at server.Main.c(SourceFile:317)
    at server.Main.initApplication(SourceFile:191)
    at commons.JIWApplication.initialize(SourceFile:82)
    at com.jme3.system.NullContext.initInThread(NullContext.java:86)
    at com.jme3.system.NullContext.run(NullContext.java:129)
    at java.lang.Thread.run(Unknown Source)


    Uncaught exception thrown in Thread[jME3 Headless Main,5,main]
    11.11.2015 17:51 server.b
    SEVERE: Error while saving all chunks (forced)!

  • Hmm.. 8gb should be more than sufficient for that amount of data. Please download this server version, unfortunately it won't solve the issue most likely, but it provides useful server information (eventually we can see what's going on then): download.rising-world.net/nightly/20151112/server.zip


    Once the new server is installed, please try to convert the map again. Please upload the latest log again once it's crashed

  • Thanks for the log! It's indeed a memory issue, the server can only allocate 259 MB =O How do you assign the 8 GB exactly? The Java version might also be a problem in this case: Only a 32 bit Java version is installed, so you cannot use more than 2-3 GB for the server. If you have a 64 bit OS, please download and install the 64 bit Java version: http://javadl.sun.com/webapps/…ad/AutoDL?BundleId=111689

  • Unfortunately you can't use the server_memory setting in the server.properties file on Windows. Instead, you have to assign the memory directly. You can run the server by executing the server.jar via command java -Xmx8g -jar server.jar (for 8 GB, for example)


    Alternatively edit the "win_startscript.bat" with a texteditor and put the Xmx parameter into it accordingly:

    Code
    @Echo off
    java -Xmx8g -jar server.jar

    Edited 2 times, last by red51: Sorry, confused the parameters, now the example should be correct :D ().

  • Please see above, the server.properties value unfortunately does not work on Windows... You have to provide the desired amount of memory as an argument.
    To see if it works, you can have a look at the top of the command prompt or the log file after you started the server, the second line shows the total amount of memory which is assigned to the server ;)

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!