[Linux] Fullscreen Display Mode issue

Trello update: We've added some basic phyiscs / gravity for objects and also started working on a proper sky
  • Game Version : 0.8.2.4 Alpha
    Platform : Steam Linux
    Kernel : 4.4.0-77
    Graphics : nVidia GK110B GTX 780Ti 3Gb
    Driver : 375.39-0ubuntu0.16.04.1


    Hello folks,


    I am having an issue with the Linux version of Rising World and my Mint 18.1 desktop in that the game will not allow me to play fullscreen at my native 2560x1440 desktop resolution in a way I would expect.


    When I select the native 2560x1440 resolution, turn vsync on (though it makes no difference when it is off) and tick fullscreen I receive the following error message... "Unable to find fullscreen display mode matching settings. Game will disable fullscreen mode now and enable undecorated mode. If this does not work properly, please contact our support or visit our forums.". The game then exits to desktop.


    When I next enter the game the display certainly does appear to be 2560x1440 fullscreen apart from the fact that my Mint toolbar on the bottom of the screen is still visible and the game portion of the screen is scaled slightly to keep the toolbar clearly visible.



    Do you have any suggestions for how I can deal with this issue or is it working as intended?

    Caselabs S8 : Intel 7700K 5.0GHz 1.30V / 32Gb DDR4 3000 / ASUS 780 Ti 3Gb 1274 boost, 7800 mem / Samsung 850 Pro 256Gb, 2x Samsung 840 Pro 256Gb / Dell U2715H 27" 2560x1440 / Corsair AX860I / APC SMT1000I / Linux Mint 18.1 64-bit

  • Hmm... are you maybe using a tv instead of a monitor, or do you have a dual monitor setup? If the resolution is bigger than it's supposed to be (e.g. you select your desktop resolution, but the game window is much bigger than your screen) it's usually caused by DPI related display scaling. Maybe you can try this to disable this behaviour for RW: https://askubuntu.com/question…and-change-the-screen-dpi


    About the fullscreen issue: this happens if the game is unable to find a proper display mode (combination of resolution, refreshrate and color depth). The game uses xrandr by default to get the supported display modes. This issue is probably related to the DPI scaling as well...
    However, if the fullscreen mode does not work properly, you can alternatively try to use the "Undecorated" mode instead. To do that, adapt the resolution to your desktop resolution, disable fullscreen mode and check the "Undecorated" box (this provides an alternative fullscreen mode).

  • I am using the Dell 2560x1440 monitor in my forum signature. I don't have any other displays connected. I will certainly have a look at the DPI settings on the machine but it is a fairly normal Mint install that I have not fiddled with.


    Would you expect the "Undecorated" fullscreen mode to still show the bottom toolbar?

    Caselabs S8 : Intel 7700K 5.0GHz 1.30V / 32Gb DDR4 3000 / ASUS 780 Ti 3Gb 1274 boost, 7800 mem / Samsung 850 Pro 256Gb, 2x Samsung 840 Pro 256Gb / Dell U2715H 27" 2560x1440 / Corsair AX860I / APC SMT1000I / Linux Mint 18.1 64-bit

  • You were quite right. By default the Mint toolbar is set to "Always Show Panel".


    To address this in Mint Cinnamon, right-click on the bottom task bar, select Panel Settings, look at the Auto-hide Panel and change Always Show Panel to either "Auto hide Panel" or "Intelligently hide panel".

    Caselabs S8 : Intel 7700K 5.0GHz 1.30V / 32Gb DDR4 3000 / ASUS 780 Ti 3Gb 1274 boost, 7800 mem / Samsung 850 Pro 256Gb, 2x Samsung 840 Pro 256Gb / Dell U2715H 27" 2560x1440 / Corsair AX860I / APC SMT1000I / Linux Mint 18.1 64-bit

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    • :)
    • ;)
    • :(
    • :P
    • ^^
    • :D
    • :verysad:
    • ;(
    • X(
    • :*
    • :|
    • :crazy:
    • :lol:
    • :dizzy:
    • =O
    • <X
    • ||
    • :thinking:
    • :wacko:
    • :/
    • 8)
    • :wat:
    • :huh:
    • :silenced:
    • :wow:
    • 8|
    • :angry:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :hushed:
    • :nerd:
    • :saint:
    • :drooling:
    • :love:
    • :monocle:
    • :poo:
    • :party:
    • :drunk:
    • <3
    • :!:
    • :?:
    The maximum number of attachments: 10
    Maximum File Size: 1 MB
    Allowed extensions: 7z, avi, bmp, dds, gif, jpeg, jpg, log, lua, mp3, mp4, ogg, pdf, permissions, png, properties, rar, txt, xml, zip

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!