Steam: Game Mismatch

18.03.2019: Ein neuer Hotfix (0.9.5.4) ist nun verfügbar! Multiplayer Server müssen entsprechend geupdated werden

  • Steam: Game Mismatch

    Hi

    I am experiencing the same error (I think) on my server, but I don't speak German well enough to figure out what to do.
    Tried with google translate but didn't quite work. The thread is marked as done though...

    Can anyone help?

    This is what I found in the server log...


    com.codedisaster.steamworks.SteamException: GameMismatch
    at server.i.a(SourceFile:182)
    at G.f.a(SourceFile:203)
    at G.f.messageReceived(SourceFile:128)
    at de.jiw.network.server.core.ServerTcpChannel.onMessageReceived(ServerTcpChannel.java:99)
    at de.jiw.network.server.core.AbstractServerChannel.dispatchTCP(AbstractServerChannel.java:62)
    at de.jiw.network.server.session.TcpSessionHandler.channelRead0(TcpSessionHandler.java:79)
    at de.jiw.network.server.session.TcpSessionHandler.channelRead0(TcpSessionHandler.java:15)
    at io.netty.channel.SimpleChannelInboundHandler.channelRead(SimpleChannelInboundHandler.java:105)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:362)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:348)
    at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:340)
    at io.netty.handler.codec.ByteToMessageDecoder.fireChannelRead(ByteToMessageDecoder.java:310)
    at io.netty.handler.codec.ByteToMessageDecoder.channelRead(ByteToMessageDecoder.java:284)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:362)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:348)
    at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:340)
    at io.netty.handler.codec.ByteToMessageDecoder.fireChannelRead(ByteToMessageDecoder.java:310)
    at io.netty.handler.codec.ByteToMessageDecoder.channelRead(ByteToMessageDecoder.java:284)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:362)
    at io.netty.channel.AbstractChannelHandlerContext.access$600(AbstractChannelHandlerContext.java:38)
    at io.netty.channel.AbstractChannelHandlerContext$7.run(AbstractChannelHandlerContext.java:353)
    at io.netty.util.concurrent.DefaultEventExecutor.run(DefaultEventExecutor.java:66)
    at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858)
    at io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:138)
    at java.lang.Thread.run(Thread.java:748)
    CLIENT 5 CHANGE STATE: Connected -> Disconnecting
    CLIENT 5 CHANGE STATE: Disconnecting -> Disconnected
    REMOVE: de.jiw.network.server.session.ClientConnection@1b2e6d8 - 5 -
    0
    2019/01/07 12:22 PM G.f
  • okay :)

    Not sure this is what you are asking but:

    I am on a mac myself
    I use the steam client to open the game gui and connect through 'connect to IP' (since the server doesnt show on the serverlist).

    It used to work without problems, but I used a server 'update steam' script that the company hosting the server provided, to get it to feature on the serverlist. and Instead I now can't log on. Possibly others cant either, there has not been any activity since as far as I can see, and we are 3 people on regularly.

    I can connect to the server, it is active and I can ping it, but it fails during authentication.

    It is possible I just set something up wrong, but I have no idea where.
    It is the first time I have run the script, but I have made changes to the server and been online several times in the last week or so without any problems.
    Before running the script I was in-world to make sure everything worked well after installing a plugin, and everything seemed fine.
    So I am pretty sure something happened when running that script making it impossible to log on, I just don't know where to look.

    I googled and found a couple of other threads in this forum, where the german one was the only one that had any real info, so thought it was my best hope :)

    I have contacted the server hosting company as well, but they seem to be at a loss (so far at least).

    So crossing my fingers hoping you can give me a hint!
  • So I tried to figure out if its a windows or a linux server, and I can't find it anywhere. I don't remember getting a choice, just ordered a rising world server from vilayer. I will ask them.

    Did some further looking around.
    Seems the server name was changed to something else when running the script.
    Also when I use the rcon port, I get a different GUI error. Here it says the game versions don't match, which aligns well with the exception.

    Found a version file where the main version is the same as the one I seem to be running, it says 0.9.4.2 in the server file and 0.9.4.2_39 on my game version.

    Also, it has been confirmed that others players get the same error when attempting to log on.
  • Okay hopefully last post tonight.

    Apparently the update steam script should simply download the newest game files from steam.

    I thought I was running the latest version, so how that could cause problems is unclear right now, but maybe I am wrong.
    Why the server hasn't been visible on steam for a week is still unclear.
    It doesn't overwrite my files, I am still admin for instance, so how the server name then got changed/cut off......
  • Sorry for the late response! One thing that could result in a GameMismatch exception would be a wrong app id that's provided to the server. There should be a text file called "steam_appid" in the server directory, please open it with a text editor and make sure it contains the app id of the game (324080).


    Maybe you can send me your server ip + port (if you don't want to post it here, just send me a PM)?