Server won't startup?

We've posted a status update with some first screenshots of the new terrain generation. There is also a new update available for the Java version!

  • Server won't startup?

    Hello all,

    Hoping someone can help me. My server is hosted on GTXgaming and they had server maintenance earlier today. Now it seems my server won't startup anymore and it gives me an error log.

    Does anyone know what this means and how to fix it?

    ------------------2019/02/21 09:42 PM server.e
    SEVERE: Error while starting the server: java.net.BindException: Cannot assign requested address: bindjava.net.BindException: Cannot assign requested address: bind at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:128) at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:558) at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1283) at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:501) at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:486) at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:989) at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:254) at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:364) at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:163) at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:403) at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:463) at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858) at io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:138) at java.lang.Thread.run(Unknown Source)Unable to start networkserver. Program will exit...
    ------------------

    Thank you for the help.
    Files
    Owner of Green Valleys Server – All Are Welcome
  • This message indicates that there is already another process using this address / port. Maybe it's just an "old" RW server instance which is still running in the background? Try to restart the server and see if you still get this error. If restarting the server doesn't help, you have to contact your hoster about this issue...