Adding to group via console not working

  • Adding to group via console not working

    Hello everyone,


    I have a server setup but I can't get the permissions to work.
    I have set admin for myself via "setplayergroup Priestid admin" and that works.
    But if I type somebody's name to be added to the Guest group or Resident group I would get the message "group 'resident' not found"


    In one of the log files in the Logs folder I found the following errors:

    WARNING: Error while loading default server permissions
    while scanning a simple key in 'string', line 14, column 5: maxupload:20 ^could not find expected ':' in 'string', line 15, column 5: dimension: 1024 ^
    <Java output>

    Found 4 files in groups folder
    2019/03/06 06:00 PM I.g
    INFO: Group "admin" permissions loaded successfully!
    2019/03/06 06:00 PM I.g
    SEVERE: Error while loading group architect.permissions
    while parsing a block mapping in 'string', line 1, column 1: group: (Architect) ^expected <block end>, but found BlockSequenceStart in 'string', line 18, column 3: - itemgive ^
    <Java output>
    <the contents of the architect.permissions file>


    2019/03/06 06:00 PM I.g
    INFO: Group "guest" permissions loaded successfully!
    2019/03/06 06:00 PM I.g
    SEVERE: Error while loading group resident.permissions
    mapping values are not allowed here in 'string', line 16, column 7: allow: ^
    <Java output>
    <the contents of the resident.permissions file>



    Did I made a (syntax) error in the permissions or server.properties and the permissions files?
    Files
  • Not too sure myself but 2 things I have noticed.

    Here attached is one of our groups, I noticed that you have bracketed names (name) everywhere which is not necessary in the first line of the file as it should be looking for the internal name you are calling it.
    Also you may want to put resident and other groups, show admin tag, to false.
    Files
    • numi.jpg

      (56.67 kB, downloaded 8 times, last: )


    Join us on Asgard! Discord - discord.gg/cHj63WX | IP - 185.249.196.18:4100

  • Thank you for the pointers Stager83.
    Changed the naming in the permissions files and removed the ( )

    From the architect I changed:

    Source Code

    1. commands:
    2. allow:
    3. - itemgive
    4. - *
    5. world:
    6. allow:
    7. - *

    to

    Source Code

    1. commands:
    2. allow:
    3. - itemgive
    4. - *
    5. world:
    6. allow:
    7. - *
    I'll restart the server and see how it turns out.
  • As @Stager83 mentioned, spacing is indeed very important. If there is a wrong spacing or indenting, the permission file cannot be loaded.

    According to the log output, the default, architect and resident permissions could not be loaded.
    In the default.permissions, the "chatcolor" in the first line is wrong, and there is a space missing in line 14 (between "maxupload:" and "20") ;)

    In the resident.permissions file, the "allow" in line 16 does not belong there (more precisely, it looks like the "commands" block is missing).

    Fixing the wrong indenting of "- itemgive" in the architect.permissions as described in your last post should indeed fix this permission. Although there is no need for the "- itemgive" line if the next line contains a wildcard (*): the asterisk basically means "all commands", so in this case, it allows all commands. If you want to disable all commands but the "itemgive" command, you could write the "deny" block first containing a wildcard, followed by the "allow" block only containing the "itemgive" entry:

    Source Code

    1. commands:
    2. deny:
    3. - *
    4. allow:
    5. - itemgive
  • Thank you for the replies, i have redone them all slowly from the server help permissions in the forums they are working now which is great, I have another few issue's which is that when i log onto the server i need to add the permissions groups again also in the default.permission i have set general fly: true on, in the guest.permissions i have set general fly: false, resident.permissions general fly: true and architect.permission general fly: true but the 2 groups i want to allow flying they cannot
    thanks again