Fatal Error log...

  • Windows 10 (x64) 10.0 Java: 1.8.0_111 amd64 -H:4096 -D:3072 (Steam)
    Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz, GL704GW, 16233 MB (4207 MB Heap)
    NVIDIA GeForce RTX 2070 20190717000000.000000-000
    Intel(R) UHD Graphics 630 20190207000000.000000-000
    Uncaught exception thrown in Thread[jME3 Main,5,main]
    java.lang.OutOfMemoryError: Direct buffer memory
    at java.nio.Bits.reserveMemory(Unknown Source)
    at java.nio.DirectByteBuffer.<init>(Unknown Source)
    at java.nio.ByteBuffer.allocateDirect(Unknown Source)
    at com.jme3.util.ReflectionAllocator.allocate(ReflectionAllocator.java:174)
    at com.jme3.util.BufferUtils.createFloatBuffer(BufferUtils.java:875)
    at com.jme3.scene.VertexBuffer.createBuffer(VertexBuffer.java:999)
    at i.a.a(SourceFile:165)
    at i.a.a(SourceFile:28)
    at aF.c.a(SourceFile:406)
    at aF.c.a(SourceFile:117)
    at ad.c.a(SourceFile:68)
    at K.b.b(SourceFile:322)
    at K.a.onClick(SourceFile:218)
    at de.jiw.gui.elements.ClickableLabel.onMouseButtonEvent(ClickableLabel.java:130)
    at de.jiw.gui.core.Screen.onMouseButtonEvent(Screen.java:1721)
    at com.jme3.input.InputManager.processQueue(InputManager.java:833)
    at com.jme3.input.InputManager.update(InputManager.java:909)
    at commons.JIWApplication.update(SourceFile:313)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:151)
    at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:198)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:232)
    at java.lang.Thread.run(Unknown Source)

    seems everytime Steam does an update worth talking about I wind up with a fatal error within a day or two. Ce la vie

  • Thanks for the error log! Unfortunately the game runs out of memory, which can happen on some multiplayer servers which have lots of buildings and/or plugins. However, your system has plenty of RAM available, and you can assign more RAM to the game manually to fix the problem. To do that, rightclick on Rising World in your Steam library -> Properties -> Set Launch Options -> enter +memory 6000 7000 (the space between the numbers is important) and confirm, now start Rising World. That should do the trick :)

  • Thanks Red. This happened when I am trying to look at a blueprint. We are not using any plug ins and there are only 2 of us on the server. While we do a lot of building, we move on when we are happy with a village. We are only working on a single building at this time and it is no where as ambitious as some of our other projects. Oh well. Thanks again for the input

    • :)
    • ;)
    • :(
    • :P
    • ^^
    • :D
    • :verysad:
    • ;(
    • X(
    • :*
    • :|
    • :crazy:
    • :lol:
    • :dizzy:
    • =O
    • <X
    • ||
    • :thinking:
    • :wacko:
    • :/
    • 8)
    • :wat:
    • :huh:
    • :silenced:
    • :wow:
    • 8|
    • :angry:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :hushed:
    • :nerd:
    • :saint:
    • :drooling:
    • :love:
    • :monocle:
    • :poo:
    • :party:
    • :drunk:
    • <3
    • :!:
    • :?:
    The maximum number of attachments: 10
    Maximum File Size: 1 MB
    Allowed extensions: 7z, avi, bmp, dds, gif, jpeg, jpg, log, lua, ogg, pdf, permissions, png, properties, rar, txt, xml, zip

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!