Dedicated Server on linux need help!

  • Hi All!
    I created a server with rising world on debain 9 x64 linux, installed it through an automatic script from gsmarena. The server starts, but it is not visible in the list of servers from the game client ... But you can connect to it through the command connect + IP address. I use standard ports and opened on my router 4254-4259 tcp + udp.
    What could be the problem? help advice

  • Can you maybe post the IP here (or alternatively send it via PM to me)? If the server is running I can check if the master server can find this server :)
    Where is the server missing exactly? In the Steam client, or the ingame server list?


    Server_lan_mod-false, as I understand it, this option enables visibility on the local network or on the Internet?

    That's just a setting for Steam and should only be set to true if you just want to play via LAN. So "false" is indeed the correct setting here ;)

  • Can you maybe post the IP here (or alternatively send it via PM to me)? If the server is running I can check if the master server can find this server :)
    Where is the server missing exactly? In the Steam client, or the ingame server list?


    That's just a setting for Steam and should only be set to true if you just want to play via LAN. So "false" is indeed the correct setting here ;)

    the server is not visible in the steam client, the list of servers ..

  • Thanks for the screenshot ;) It looks like the server is bound to the local ip (192.168.x.x). If you want the server to show up in the server list, you have to bind it to your public/internet ip instead (see the "server_ip" setting in the server.properties file). Alternatively you can leave the "server_ip" field blank, then the server binds to all addresses.

  • Thanks for the screenshot ;) It looks like the server is bound to the local ip (192.168.x.x). If you want the server to show up in the server list, you have to bind it to your public/internet ip instead (see the "server_ip" setting in the server.properties file). Alternatively you can leave the "server_ip" field blank, then the server binds to all addresses.

    yes, I did just that, statically registered an IP address, both in OS settings and in server.properties. If the server_ip field is left blank, then the following error will occur during server debug (see screenshot)

    if you specify all ip in server.properties, debuging stops in the next step

    -> java.net.BindException: Unable to assign the requested address (translate to eng)

  • The 2nd message indicates that Steam is unable to bind to that ip... which indicates the server (or at least Steam) isn't able to "see" this ip... is that the actual public IP of the server, or does the server perform some sort of IP translation (NAT)? Can you upload a full server log (or alternatively send it via PM to me)?

  • The 2nd message indicates that Steam is unable to bind to that ip... which indicates the server (or at least Steam) isn't able to "see" this ip... is that the actual public IP of the server, or does the server perform some sort of IP translation (NAT)? Can you upload a full server log (or alternatively send it via PM to me)?

    this is a public ip, on the same ip I have my web site, the address is not behind the nat server...
    debug.log server:
    debug_log.txt

  • Hmm... It still looks like "server_ip" in the server.properties file is set to the local ip (192.168.x.x)... did you set "server_ip" to your public ip (212.33.255.19)?

    I tried differently, yes - in a debug a log is issued when server ip = local ip

    Code
    server_ip=192.168.1.8
    server_query_ip=212.33.255.19

    if you swap ip

    Code
    server_ip=212.33.255.19
    server_query_ip=192.168.1.8

    then debug gives the following error, and it is impossible to connect to the server from the client even through a direct connection, specifying the server ip address
    debug_log.txt

  • Basically there is no need to change the server_query_ip, so it's recommended to keep the default value 0. Alternatively you can set it to the same value as your server_ip (your public ip, i.e. 212.33.x.x).
    Never use your local IP (192.168.x.x) anywhere in the server properties, unless you want to play via LAN only ;)

  • Basically there is no need to change the server_query_ip, so it's recommended to keep the default value 0. Alternatively you can set it to the same value as your server_ip (your public ip, i.e. 212.33.x.x).
    Never use your local IP (192.168.x.x) anywhere in the server properties, unless you want to play via LAN only ;)

    ок =) I did as follows:


    Code
    server_ip=212.33.255.19
    server_query_ip=

    but got an error: SEVERE: Error while starting the server: java.net.BindException: Unable to assign requested address (see full debug)
    I searched on the Internet what this error is associated with and found out that some ports that the server uses are busy ... This is strange because I don’t use any of the specified java ports .. What else could be the problem?
    debug_log.txt

  • Hey, sorry for the late response, I missed your post unfortunately :( However, please set the values as described in my previous post. It's important to set server_query_ip either to 0 (default setting), or your server ip (the public ip, i.e. 212.33.x.x), that should do the trick

  • Hey, sorry for the late response, I missed your post unfortunately :( However, please set the values as described in my previous post. It's important to set server_query_ip either to 0 (default setting), or your server ip (the public ip, i.e. 212.33.x.x), that should do the trick

    Hi! During this long time I have already tried various options, including this one that you have just proposed. I entered the values server_query_ip=0\0.0.0.0\my real IP as server_ip. When debugging the server, the same error is always displayed in java, as in the log above (post 13). I tried to stop all servers on my hyper-v, since the error is related to a busy port, but all to no avail ... And to the current day, I have not been able to start my server due to the same error:


    P.S. Regarding a long answer, no big deal, I also have a blockage at work, the deployment of different game servers is my hobby, thanks for your help in this! ;)

  • I entered the values server_query_ip=0\0.0.0.0\my real IP as server_ip

    The best thing is to keep the default value 0, alternatively just remove that line completely from the server.properties file (it will be recreated with the default value then). However, the message Невозможно назначить запрошенный адрес does not seem to be related to the query_ip, instead it indicates that the actual server could not bind to the server_ip. This either happens if the port + ip is already in use, or if the entered ip is wrong (or alternatively if the server cannot "see" the public ip). In this case you can keep the field blank, then the server binds to all addresses.


    If the issue persists after setting server_query_ip back to 0 and changing the server_ip field to your public ip (212.33.x.x), or alternativey leaving it blank, please post a full server log here (the latest one from the "logs" subfolder) ;)

  • The best thing is to keep the default value 0, alternatively just remove that line completely from the server.properties file (it will be recreated with the default value then). However, the message Невозможно назначить запрошенный адрес does not seem to be related to the query_ip, instead it indicates that the actual server could not bind to the server_ip. This either happens if the port + ip is already in use, or if the entered ip is wrong (or alternatively if the server cannot "see" the public ip). In this case you can keep the field blank, then the server binds to all addresses.
    If the issue persists after setting server_query_ip back to 0 and changing the server_ip field to your public ip (212.33.x.x), or alternativey leaving it blank, please post a full server log here (the latest one from the "logs" subfolder) ;)

    Hi! Good news. I completely reinstalled the server (including the OS itself) and it gives the best results!
    In server.properties I put the values server_ip=0 and server_query_ip=0, and I get the following message from debugging (see the log in the attachment)
    log.txt
    But as I understand it, this is not the end, and the server is still not visible in the server game sheet =(
    P.S. if I put any other parameter values in server_ip or server_query_ip I get a java error, as in previous attempts..
    log1.txt
    hmm...... I do not know what I did, but it worked! The server is visible in the list of servers and you can connect to it from the Internet! I left the parameters server_ip=0 and server_query_ip=0 and so it worked!
    Full REinstall server, including operating system, and setting parameters values server_ip=0 and server_query_ip=0 - solved my problem, thanks for the help!

  • I can confirm that the server is visible in the server list now :thumbup:

    Yup! while I’m studying the server’s capabilities, in the future I plan to install scripts or mods, but still, the server is working and this is a fact.
    By the way, problems arose with him, possibly due to the fact that he is behind NAT server.
    I also disabled ipv6, maybe this also somehow affected. I am writing it this way so maybe someone will have the same problem, let this tame be just as useful!
    thanks again for your help and good luck in developing this great game!

    • :)
    • ;)
    • :(
    • :P
    • ^^
    • :D
    • :verysad:
    • ;(
    • X(
    • :*
    • :|
    • :crazy:
    • :lol:
    • :dizzy:
    • =O
    • <X
    • ||
    • :thinking:
    • :wacko:
    • :/
    • 8)
    • :wat:
    • :huh:
    • :silenced:
    • :wow:
    • 8|
    • :angry:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :hushed:
    • :nerd:
    • :saint:
    • :drooling:
    • :love:
    • :monocle:
    • :poo:
    • :party:
    • :drunk:
    • <3
    • :!:
    • :?:
    The maximum number of attachments: 10
    Maximum File Size: 1 MB
    Allowed extensions: 7z, avi, bmp, dds, gif, jpeg, jpg, log, lua, ogg, pdf, permissions, png, properties, rar, txt, xml, zip

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!