java errors

  • Getting some Java errors today, had a couple of them. error details shown below, not sure how to attach or upload the actual error logs ?

    java.util.ArrayList$Itr.checkForComodification(Unknown Source)
    java.util.ArrayList$ Source)
    com.jme3.system.lwjgl.LwjglDisplay.runLoop( Source)

  • I've been running as administrator from day1 as from experience seems to help minimise any network problems.
    Looking in RW folder I've around 18 error logs all appear to be the same error. they've occurred between 10th and yesterday.
    Have done a breakdown by date, more to remind me of what my pattern of play has been;-
    03/1 Purchased game.
    10/1 8 logs. I was finishing first mansion had a full inventory. Had being using console to order base material ore and treelog, had heeded your advice about not using item index >100 (eg item blocks 64 100) . I cleared a load out in the game by dropping inventory and emptying a chest.
    12/1 1 logs Using the same world ran ok previous day after inventory house cleaning.
    13/1 1 log
    14/1 1 log
    23/1 2 log
    24/1 2 logs New World
    25/1 1 log
    26/1 2 logs New World.
    total 18

    Basically have been playing the same world between the 10~23. 24~26 have started two new worlds.
    I had thought that the initial errors might be around using the console and might be connected with Steam useful tips post #5. However in the last few days the same error has been recurring in new games that have not been running or developed as much as the previous world, certainly inventory hasn't been as large.

    I can't reproduce it. I just get a black screen and that's it. The game doesn't seem to have crashed rather it closes. When I reload I'm in the last position I was in and error log has been created, so a crash landing rather than a crash. :0

    PS Is there any further detail on how to do this


    It can be fixed by editing the worldfile and deleting your inventory manually, but precaution is better than aftercare ;) We will make this command safer in the next versions

    From the above "Steam useful tips post #5" link above.

  • Hope I'm not tempting fate but have continued playing my latest world all day today, no issues. What I have done that is different is quit regularly so the sessions have been shorter than previously. certainly the 10/1 when most of the issues occurred and the 25 & 26th were busy days, with longer sessions. that's about the only thing I can pinpoint.

  • Sorry lead you astray slightly. There are two error classes. The 1st 8 occurring on the 10th Jan relate to an array out of bounds error as shown below. The second group for the 12th onward are the



    originally posted. will happily forward you them if needed, just advise me of an address.

  • Alright. The concurrentModException should be fixed in the next version (we'll see^^). About the indexOutOfBoundsException: It would be helpful if there is a way to reproduce the error. It seems to happen when having a block equipped and aiming at a very specific spot of your house

  • That'll be good.


    It seems to happen when having a block equipped and aiming at a very specific spot of your house

    I'm sorry I don't quite understand what you mean by a block equipped.

    I've continued to play the same world, building mainly with planks and beams. I've continued as previously quitting and backing up saved file. Good news is no further crashes. I have however had an increased amount of stickies, that is components planks or beams that can't be removed, causing me to revert to previous backup.

  • Oh I meant when you hold a block in your hands^^ But when the crash did no longer occur that's even better ^^
    When you can't remove construction elements, try to do it from a different angle. If that still does not work, you unfortunately have to wait until we have fixed the hit detection for construction elements (but we will do it soon)

  • Ah yes, thinking about it as you describe I believe your right. Seem to remember just being about to press the right mouse button and bang.
    Yes I have a routine now with these stuck items. As you say different angles sometimes works, I've also fund quit and reload have worked. If all else fails regular backups and restore.

    Yes the hit detection seems a little quirky at times. One of the funniest things occurred yesterday. I was building a wooden floor on the 1st floor of a new building. Some of the floor planks were uneven so I got the old pick out to remove them, good news floor planks removed, bad news also removed a chest, sawmill and furnace, which were zapped in the workshop below. :) Can understand the furnace as the top is only just under the 1st floor, but the pick axe swing from the floor above to the other two items seems a little long.

    I've noticed sometimes when switching from flying mode to ground movement mode, the perspective seems off occasionally, it's as if my character is taller than normal. I wonder if there's something in this that causes longer reach and maybe the unexpected results to items as above.

    This shows the saw bench and chest restored after the plank removal, from the floor above, originally these items were slightly closer to the window at the rear but of course the respective heights, distance from the pick axe head on the floor above was the same.

  • Started a new world this AM

    This crash occurred when selecting blocks in block maker menu. Just selected a variant when it happened.

    When loading the game after this error I can't access the benches, the selection icon comes up but pressing the f key does nothing. I deleted the workbench and built another, but I couldn't enter crafting on the newly placed object either.

  • Same error this AM.

    Forget the issue about accessing benches, I guess it was around flying mode being engaged when the error occurred first time. My feet were obviously on the ground this time and so could access benches.
    Apologies for previous for blind panic :rolleyes:

  • Just got my 1st Out of Memory error. Gameplay was slightly different to normal. Have by and large been ordering logs and stone via console while heavily into building. This time went out to manually get material, went on an extended wander, ok I got lost :). Have done this previously and noticed a big increase in the size of db saved file (in parent directory.), I assume this is normal as a larger portion of the world is exposed, but not had the out of memory error.

  • How much memory do you have and what are your graphic settings ingame (especially view distance and detail distance)?
    About the DB file size: Usually it should not grow very much when exploring the world. Generally the file size should be relatively small (only few MB). Only exception: When you use custom images ;)

  • Hi,
    Rams 8Gb. Have attached top of errorlog giving graphics details. I think the memory outage is caused by me, I remember after reading your comment on settings above, I'd played around with the view and detail distances and not put them back. What is the optimum do you reckon ?

    File size is still in Kb but early game was 33kb now is 158kb, not a massive size and no big deal but was surprised to see a sudden increase in size
    I'm mainly building and getting timber and stone. I've been exiting and backing up save files periodically.
    Records for this world are:-
    Size is in KBs. for Main world file in the parent directory.
    11/1/2015 33
    22/1 54
    24/1 57
    7/2 58
    7/2 77
    9/2 158

    In the second backup on the 7/2 I had been exploring the world a bit more.
    9/2 is the current save. which is quite a jump from the previous sizes.
    As I say it's not an issue just a point of interest.
    22/1/15 54

  • I'd recommend to decrease the detail distance a little bit, the detail distance has a much greater impact on performance and memory usage than the view distance ;)
    The file size seems to be fine then, the more you explore, and the more you change in the world (i.e. digging, building, cutting trees, picking up flowers etc.), the more is going to be saved in the worldfile ^^

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!