Errors on startup

  • Gettings this on startup after i add the ip adress that i have. It runs when i leave it blank but i want people to be able to connect. Any ideas ? thanks. <3


  • New error..

  • java.net.BindException: Cannot assign requested address: bind


    This error indicates that the server could not bind to the IP/Port, either the port is already in use (maybe another RW server running on the same port?), or there is a misconfiguration in the Windows host file (Windows\System32\Drivers\etc\hosts), or the IP you put into the "server.properties" is invalid.


    does the game support 2012 r2?


    Yes of course ;)


    New error..


    One thing that can be problematic is your current Java version. Only the 32 bit version is installed, if you use a 64 bit operating system, make sure you also install the 64 bit Java version.
    What IP did you enter in the "server_ip" field? When running the server on your local machine, try to leave the "server_ip" field blank

  • I can let you on my teamviewer if u wana have a look.


    New error again....
    I am leaving IP blank, the only thing i edited in the properties was the name of the server.


    Code
    C:\Program Files (x86)\Steam\steamapps\common\RisingWorldDedicatedServer\scripts
    HTTP Server bind to IP: 0.0.0.0:4254
    WORLDPART 0 0 STORED TO CACHE
    05/12/2016 08:59 PM server.MainINFO: Server successfully authenticated!
    05/12/2016 08:59 PM server.MainSEVERE: API error occurred during server authentication:
    {"API-ERROR":"401"}
    *************** NEW THREAD LOCAL ALLOCATION ***************


    Hosts is unedited


    Java latest version 64 bit is installed.


    Full logs here..

  • New error again....
    I am leaving IP blank, the only thing i edited in the properties was the name of the server.


    Is it possible to join the server? Or are you still stuck in the loading screen?
    Usually the API error indicates that the Http Port (to query the server) is blocked (it's the serverport-1, so by default 4254).


    Hosts is unedited


    Ok, hostfile should be fine ^^

  • I can not join the server no, it is stuck on the connecting and then it just says failed to join.


    I left the server on over night just to see if i got other errors, see and behold i figured there was some kind of delay on them.
    This is still after not having done any changes since last post, simply let it stay on. What does this mean?


    http://pastebin.com/qaXbp1qj

  • This message indicates that your server was not able to contact the masterserver. It sends a ping periodically, and if it does not get a response in time this "error" occurs. In your case it's nothing to worry about, since this is only problematic if it occurs 10 times in a row (according to the log, this error occurred all few hours).


    What kind of server do you have? Is it a rented dedicated server, or is it just a separate computer in your household?

  • Did you forward your ports? The game requires the server port + the 3 adjacent ports to be forwarded (by default 4255, 4256, 4257 and 4258, TCP and UDP). If you want to get rid of the API error and/or want your server to appear in the serverlist, you also need to forward the http port (serverport-1, so by default 4254).

  • that's

    You forward it in your router


    unfourunatly., i Can't see anything that resembles "RISING WORLD" on my router, i tried making a static IP and lost my internert conection, so i might forget the wjhole server thing,
    Me and Servers Don't get along any way, tried to set up a DNS server at work, NO LUCK, oh well

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!