Crash when opening Crafting

  • I tried to discover the game tonight, but cannot open the crafting interface. See errorlog below :
    Linux 3.13.0-106-generic Java: 1.8.0_91 amd64 -H:3072 -D:3072 (Steam)

    I tried to change the drivers for the graphic hardware on my computer, but with other drivers, the game wouldn't even launch.
    I'm on Linux Ubuntu 14.04.

  • Actually there is a bug since the latest update which occurs sporadically (especially when accessing the crafting menu), but it usually it comes with a different error message. Your error would usually indicate that there is a driver incompatibility, but in this case it might be caused by the same bug. Does the game always crash when accessing the crafting menu? What graphics card do you have exactly? Maybe wait for the next hotfix (it will be available within the next days), and if the crash still occurs after the update, please let us know ;)

  • I launched the game several times and the problem happens every time I click on "Crafting". The graphic card is a MSI GeForce GT730.
    I will wait for the next update, thanks for the info.

  • I'm having the same Error every-time i go into crafting. I'm using AMD A10-6800K Richland 4.1 GHz
    Linux 4.4.0-57-generic Java: 1.8.0_91 amd64 -H:3072 -D:2048 (Steam)
    Error occurred during application-update (25)
    com.jme3.renderer.RendererException: Cannot recompile shader source
    at com.jme3.renderer.opengl.GLRenderer.updateShaderSourceData(
    at com.jme3.renderer.opengl.GLRenderer.updateShaderData(
    at com.jme3.renderer.opengl.GLRenderer.setShader(
    at com.jme3.material.logic.DefaultTechniqueDefLogic.render(
    at com.jme3.material.Technique.render(
    at com.jme3.material.Material.render(
    at com.jme3.material.Material.render(
    at commons.c.renderGeometry(SourceFile:516)
    at com.jme3.renderer.queue.RenderQueue.renderGeometryList(
    at com.jme3.renderer.queue.RenderQueue.renderQueue(
    at commons.c.renderViewPortQueues(SourceFile:569)
    at commons.c.flushQueue(SourceFile:464)
    at commons.c.renderViewPort(SourceFile:652)
    at de.jiw.gui.elements.GeometryElement.updateTickEvent(
    at E.t.updateTickEvent(SourceFile:387)
    at de.jiw.gui.core.Element.transferUpdateTick(
    at de.jiw.gui.core.Element.transferUpdateTick(
    at de.jiw.gui.core.Element.transferUpdateTick(
    at de.jiw.gui.core.Element.transferUpdateTick(
    at de.jiw.gui.core.Screen.update(
    at com.jme3.scene.Spatial.runControlUpdate(
    at com.jme3.scene.Spatial.updateLogicalState(
    at com.jme3.scene.Node.updateLogicalState(
    at com.jme3.scene.Node.updateLogicalState(
    at commons.JIWApplication.update(SourceFile:326)

  • Unfortunately, today's update didn't resolve the problem. Error log is :

  • @TarValanion: Thanks for the error log! That's apparently a different error, looks like a shader issue. What graphics card do you use exactly? Maybe provide a full log, to do that, go to the game directory, open the file with a texteditor and set "game_debug_console" to true. Now save the file, and run the game again. Play until it crashes, then go to the game directory into the Logs subfolder and upload the latest log file here :)

  • Thanks a lot for the full log, that was very helpful! I prepared a new version which may fix this issue, please give it a try. To enable it, rightclick on Rising World in your Steam lib -> Properties -> Betas -> select "linux - shader fix" (no code required), and try to start the game again. Does it work now?

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!