Springende Balken

From now on, we will use this info box to inform you about noteable updates on our Trello-Roadmap!

Trello update: We've recently implemented grass and now finalized the occlusion renderer to prevent grass from passing through objects. In addition to that, snowfall now also affects meadows
  • Jetzt ist es wieder da das bei der Rotation die Bretter oder Balken wieder rausspringen. Egal was man eingibt, setconstructionrotation oder Rotation legacy. Ist auf dem Bild deutlich zu sehen. Auch beim Beenden eines Shat drückt man doch die Eingabetaste, sofort schaltet sich der Magnet ein, das ist sehr störend. Das habe ich schon vor längerer Zeit bemengelt, ist aber nicht weg. Kann man da was machen red51?

  • Die Rotation hat sich meiner Meinung nach nicht verschlechtert, die Balken und Bretter sprangen vorher bei gewissen
    Drehbewegungen auch schon raus. Säulen drehen geht schon lange nicht mehr.


    Allerdings schaltet sich die Magnetfunktion bzw. Backspace = Rückstellung öfter ein,
    ohne dass diese Tasten gedrückt wurden.

  • Das die Magnetfunktion beim Absenden einer Chatnachricht aktiviert/deaktiviert wird ist tatsächlich ungewollt, das wird mit dem nächsten Hotfix behoben. Das Verhalten der Bauteile an sich sollte sich hingegen nicht sonderlich verändert haben, zwar stehen nun weitere Rotationsmodi zur Verfügung, aber das Verhalten sollte dasselbe sein (zumindest nach den letzten Hotfixes). Für das "Rausspringen" ist sicherlich die Kollisionsprüfung der Bauteile verantwortlich, ggf. kann ich testweise für den nächsten Hotfix einen Befehl reinpacken, mit welchem die Kollision ein- und ausgeschaltet werden kann.


    Mittelfristig wird das Bausystem ansonsten aber auch überarbeitet, dann sollten einerseits die ganzen Einstellungen, die momentan nur über Konsole veränderbar sind (rotation, setr, setp etc), auch per GUI einstellbar sein (natürlich bleiben die Konsolenbefehle aber weiterhin aktiv), andererseits sollten in dem Zuge auch neue Funktionen dazukommen und einige Fehler ausgemerzt werden ;)

  • Die Rotation hat sich meiner Meinung nach nicht verschlechtert, die Balken und Bretter sprangen vorher bei gewissen
    Drehbewegungen auch schon raus. Säulen drehen geht schon lange nicht mehr.


    Allerdings schaltet sich die Magnetfunktion bzw. Backspace = Rückstellung öfter ein,
    ohne dass diese Tasten gedrückt wurden.

    Hallöchen Deirdre !
    Das die Balken und Bretter vorher auch schon raussprangen ist richtig, aber das ist schon lange her. Monate lang hatte die Rotation einwandfrei funktioniert, ich konnte die verschiedensten runden Sachen bauen ohne Probleme und ich baue viele runde Sachen. Na mal sehen ob es jetzt besser ist.

  • Seit dem letzten Update kannst du "constructioncollision" (oder kurz "cc") in die Konsole eingeben während das Platziertool aktiv ist. Das deaktiviert die Kollision der Bauteile, d.h. das Bauteil wird nicht mehr durch andere Bauteile blockiert oder verschoben. Damit sollte das "Rausspringen" eigentlich nicht mehr auftreten ;)

  • Seit dem letzten Update kannst du "constructioncollision" (oder kurz "cc") in die Konsole eingeben während das Platziertool aktiv ist. Das deaktiviert die Kollision der Bauteile, d.h. das Bauteil wird nicht mehr durch andere Bauteile blockiert oder verschoben. Damit sollte das "Rausspringen" eigentlich nicht mehr auftreten ;)


    <danke red51, werde ich morgen gleich ausprobieren.

    Hallo red51 !


    Dein Vorschlag Constructioncollision in die Konsole eingeben konnte ich nicht ausprobieren weil Bretter und Balken halb im Boden verschwanden als wenn ich das Gitter eingeschaltet hätte. Wenn ich setr 1 in die Konsole eingebe, danach cc und dann mit der Rotation beginne kommt folgendes raus. Wenn ich dann von dem Teil siehe Bild 3258 ein Blueprint mache und ihn setze fehlen Bretter siehe Bild 4524. Kann man da noch etwas verbessern?

  • Ich habe da auch mal ein wenig herumprobiert, mit und ohne cc. Wenn die Teile zum Teil im Boden verschwinden, ein anderes
    Raster benutzen. Das war aber eigentlich schon immer so.


    Das Blaupausensetzen eines Kreises macht mitunter schon seit längerem Probleme, dass Teile verschwinden.
    Ich vermute mal das hängt irgendwie mit der Himmelsachse zusammen. Vielleicht auch ob man den Blaupause auf dem Boden gedreht hatte und versucht sie hochkant zu stellen. Bei waagrechten Kreisen hatte ich bisher eigentlich keine Probleme.
    Mit CC hat das sicherlich gar nichts zu tun, da es ja vorher auch schon so war.
    Man könnte die Holzteile auch bereits vor dem Kopieren andocken, so dass das Verschwinden dann irrelant wäre.
    Ich drehe Kreise auch nicht mit setr 1, es sei denn ich möchte Monsterkreise erstellen. ^^




    Ich habe auch mal ein paar Bilder gemacht.


    Das linke ist ohne CC, das rechte mit, in dieser Größe also machbar.



    Fehler entstehen in der Ausrichtung N/S und S/N. Wechelt man die Achse funktioniert das Drehen ohne Probleme, das war aber auch schon immer so, hat sich auch nicht geändert.



    Die Achsenausrichtung ist maßgebend. >
    In dieser Ausrichtung wird mit Bild auf/Bild ab-Tasten gedreht. Vielleicht ist das ja relevant.




    In dieser Richtung keine Probleme, E/W auch keine.
    Hier dreht man mit den den Pfeil auf/Pfeil ab-Tasten




    Die Säulen springen beim Drehen hier munter weg, dieses Verhalten hat sich auch nicht geändert.



    Ionische Säulen sind aber weiterhin machbar, manchmal springen sie nach oben, so dass die Säule doppelt so groß wird. Ein klein wenig Feintuning wäre da noch nötig. ^^



    Alles in allem habe ich außer bei den Säulen keine wirkliche Verbesserung festgestellt, man kann schneller drehen, ohne dass
    der Balken rausspringt. Vielleicht zeigen die Bilder ja auch den Knackpunkt etwas näher. :D



    Bei Kreisen auf dem Boden konnte ich keine Probleme feststellen.



    Könnte auch mit der Verwendung von Balken und Brettern zusammenhänge. Ich drehe eigentlich mit Balken, da man bei größeren Teilen sowieso mit Balken andockt.

  • Hallo Deirdre !


    Das es schon früher so war ist richtig, dann gab es ein Update und alles war o.k. Dann habe ich unzählige Autos, wo wagrechte und auch senkrechte Teile angefertigt werden mussten, gebaut das ging alles ohne Probleme. Nach dem letzten großen Update fing es wieder an. Baue ich runde teile wie Räder baue ich diese an einer Wand, bei Teilen die später wagerecht verbaut werden mache ich das auf dem Boden und das nur damit ich den Blueprint nicht drehen muss. Ich weiß nicht wann Du die Bilder gemacht hast, aber nach dem großen Update 0.8.1 gab es diese Probleme nicht. Wenn ich runde Teile brauche die eine glatte Oberfläche haben müssen geht es nur mit setr 1. Nehme ich einen Balken um einen Kreis herzustellen springen einige Balken weg also cc eingeben und es klappt teilweise, bin ich dann fertig setze alle eingaben zurück dann beginnt das neue Problem. Den Balken oder das Brett das ich ansetzen möchte verschwindet halb als hätte ich (G) Raster gedrückt, also Neustart und von neuem beginnen. Das ist nervig und müsste abgestellt werden.

  • Wenn ich runde Teile brauche die eine glatte Oberfläche haben müssen geht es nur mit setr 1

    Nein. Kommt auf die Größe des Kreises an. Für Bögen usw. ist es nicht notwendig.


    Eine glatte Oberfläche erreicht du auch mit setr 3, es kommt eigentlich darauf an, dass die Lücken geschlossen sind, natürlich auch auf die Größe des Kreises, das ist schon klar.



    Nehme ich einen Balken um einen Kreis herzustellen springen einige Balken weg

    Dann liegt es am Raster, und an der Ausrichtung, bzw. Blickrichtung bei senkrechtem Drehen. Ich drehe mittlerweile nur noch mit
    Balken, bei mir springt nix weg. Ich nehme aber die oben gezeigten Himmelsrichtungen auch nicht mehr.
    Ok bei kleinem Fiddelkram würde ich auch Bretter nehmen. ^^


    Den Balken oder das Brett das ich ansetzen möchte verschwindet halb als hätte ich (G) Raster gedrückt, also Neustart und von neuem beginnen. Das ist nervig und müsste abgestellt werden.

    Das hatte ich auch vor dem Hotfix, dachte das wäre jetzt abgestellt worden. :)


    Meine Screens sind alle von heute Nachmittag.



    Wie oben bereits erwähnt, gehen die Säulen mit CC besser, jedenfalls bis zu einer kleinen Größe und mit Übung. ;)
    Hängt natürlich auch etwas mit Standposition und Größe der Balken zusammen.

  • Hallöchen Deirdre


    Nochmal zu der Einstellung setr 1, nur diese und nicht setr 3, kann genommen werden um glatte Oberflächen zu bekommen. Mit runde Teile meine ich keine Kreise oder Bögen sondern Rohre, Achen und Schubstangen. Hier ein Bild wo genau zu sehen ist wie der Balken in dem Stein eindringt obwohl ich weder das Raster eingeschaltet habe und auch nicht cc in die Konsole eingegeben habe. Links im Bild ist genau zu sehen wie der Balken durchgeht obwohl ich ihn nur aufsetzen wollte. Das Aufsetzen ist mitunter notwendig um die Länge zu verändern und wenn man ihn dann kürzt verschwindet er vollkommen ist außen nicht mehr zu sehen nur noch innen, aber da wollte ich ihn aber nicht haben. Das alles war bishen behoben und ist erst jetzt wieder aufgetreten. Eventuell liegt es am Server was ich aber nicht weis. Meiner Meinung nach sollte sich red51 noch einmal darum kümmern und versuchen das abtzustellen. Trotzdem danke für deinem versuch mir zu helfen.

  • Seit dem neuesten Update ist es möglich, Bauelemente auch dann zu drehen, wenn sie mit STRG fixiert wurden. Dazu muss einfach STRG gedrückt gehalten werden, dann kann mit den Pfeiltasten (wie gewohnt) das Bauteil gedreht werden. Damit sollten eigentlich keine Probleme wie "Rausspringen" auftreten ;) Natürlich muss man etwas vorsichtig sein, da ein kurzer Druck auf STRG die Fixier-Funktion ja auch ein- und ausschaltet.


    @zwerk7: Dass bei "cc" die Bauteile halb im Boden versinken ist übrigens normal. Mit dem Befehl wird die Kollision gänzlich ausgeschaltet, sodass sich der Mittelpunkt des Bauteils an die entsprechende Position bewegt.

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!