Permission file problem with size command

  • @red51 we are trying to add the new size command to our allowed commands in our permissions files and we cannot get it to work :/ tried both just "size" and "setsize" and it still gives an "insufficient permission error"

    here is the part of the perm file, all other allowed commands work like that.

  • Sorry for the late response! Unfortunately the permission files only cover some of the commands (basically only commands which involve the client and server). I've updated the permissions topic to cover all new commands which were added in the meantime ;) Permission system

    The "size" command is part of the creative mode permissions. You can set it with the freescaling key:

    - freescaling

    However, basically the size command is always available and cannot be restricted. Only if a size greater or smaller than the max/min size is set, the player has to be in creative mode (and the freescaling permission needs to be true) ;)

  • So we tried with a woodbeam in hand and "size 1 1 1" in the console (1 1 1 will create a block sized beam which is doable under normal circumstances by just resizing with Shift + arrow keys) and it still gives an insufficient permission error to all players but admins (or people with - freescaling allowed). Unless size 1 1 1 is not a normal size for beams I assume this is not your intended behaviour for this command :/

    Thus it seems that the only way that players can use the size command is with the extended range by allowing - freescaling in the perm file.

  • I assume this is not your intended behaviour for this command

    Oh indeed, thanks for letting me know! There was apparently something wrong when checking the block size (since construction element sizes are handled differently internally, a size of 1 was considered as a size of 0.01, which was too small). This issue will be fixed with the next update :)

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!