Console on Linux client

We've posted an important announcement regarding the current situation and the future of the game: Announcement

  • Console on Linux client

    Hi all,
    I can't get the command console to work in the linux client.
    The default keybind was F12 (config.properties). Nothing happened hitting that. it blocked the Steam screenshotter tho.
    I also tried the typical keys ^,`,~ but the console won't appear.
    I rebound it to F10,P and so on by editing the config.properties file and always restarted the game. But none worked for me.



    Is it a known issue or can I fix it somehow? I would really like to try out the creative mode :)


    regards
  • i tried all special chars i got on my keyboard now (also slash/backslash). Console didn't show up.

    Got a german keyboardlayout btw.

    If the keybind from the config.properties isn't used why it blocked the steamscreenshotter once it was binded to F12?
    The screenshotter now works since i changed it to KEY_F10.

    Is there some other way to enter commands?
  • Spooky... If you have a german keyboard, then it's really the ^ key (above tab). Alternatively, you can try ö or ü.
    I can't tell you why steam screenshot function did not work, but the config key has no influence on it. Currently the key from the config is not used at all, and even before, when the defaultkey was indeed F12, people hat the problem that they took screenshots when opening the console (that's the reason why we changed the default key) ^^

    Unfortunately the console is the only way to enter commands... I don't know if it has something to do with Linux. What about other Linux users, has anybody these problems too?
  • Hi red,
    I found out what happened here. I had the same problem with an other game years ago. the fix was to rebind the key in the gameconfig.
    In this case rebinding doesn't work so I set my keyboardlayout to US and the console shows up instantly by hitting '^'.
    On the german layout, the `-key is what the console is bind on, it looks like. Maybe there is a problem with this special char since it's used to be a keycombination (Shift+´).

    Switching the keyboard layout is a pretty easy workaround for now.

    (# setxkbmap <langcode> )

    Thanks red51 for your support.
    This game is awesome, keep up the good work!

    regards