Game crash at 10% on loading screen

We've posted an important announcement regarding the current situation and the future of the game: Announcement

  • Game crash at 10% on loading screen

    Some time ago I played the game several times but at the moment I cant get it running. It crashes during the loading process of an existing map and while loading after creating a new one.

    What did I already try:
    Updating nvidia drivers
    Updating Java
    Assigning graphic card to risingworldx64.exe and java
    Modifying all game graphics settings
    Validating game files via steam
    Reinstalling rising world
    Starting risingworldx64.exe and steam in administrator mode
    Setting exception rule for risingworldx64.exe in bitdefender

    While crashing I receive an windows message "rising world launcher does not work anymore". Afterwards the loading screen of rising world is gone. Unfortunately I do not receive any error log file, I cant find one in the game folder, even after several crashes.

    My SW/HW are:
    Nvidia Geforce GTX 970M
    8 GB RAM
    Intel Core i7-4720
    bitdefender internet security
    Windows 8.1

    Any idea what I could try in order to get rising world running?

    Thanx in advance
  • Hi, usually a "...stopped working" message indicates that a native crash occurred. In most cases this happens when using outdated graphics drivers. Please have a look if there is a file called "errorlog" or "hs_err_pid" in your game directory (to get there, rightclick on RW in your Steam lib -> properties -> local files -> browse local files). If there is such a file, please upload it here (or post the content here) :)
  • Thank you for your reply. In the game directory I find some files, but unfortunately no errorlog or hs_err_pid. I therefore cant post anything else here and hope, you can still help me. The driver of my nvidia card is up to date, as well as the driver of my intel grafic chip 4600. Although I think, since I assigned my graphic card to risingworldx64.exe and java.exe the latter should not be necessary.
    Do you have any other ideas?

    Thank you in advance for your support!
  • You can check out which graphics adapter is used by going to the settings, then you can see the name of the current graphics adapter in the lower right corner. If the game uses the integrated Intel adapter, that's most likely the reason for the crash.

    Did you download the latest graphics driver from the NVIDIA homepage?

    What happens if you try to join a public multiplayer server, does the game still crash?

    Maybe you can try to enable the debug console. To do that, open the "" file in your game directory with a text editor and set "game_debug_console" to true, then save the file, and run the game again. Try to load a world, and once the game crashes, go to the "Logs" subfolder in your game directory. There should be a new log file now, please upload this file here (then you can set the flag to false again btw) ;)
  • thanks for your reply and sorry for not being on a couple of days. I just tried your suggestions.

    under settings I can see, that my Nvidia is used, so integrated intel should not be troubling.

    Joining a public multiplayer server worked without problems, no crash!

    I also set game_debug_console to true and started the game. While loading a world i get a crash with for me no useful hint in the log-File. But maybe for you there are ome hints hidden?

    Thanx in advance for helping!
    • 1528635929.log

      (22.58 kB, downloaded 4 times, last: )
  • Thanks for the log files! Since you're able to join multiplayer servers, it's probably not related to the graphics card or memory or something like that... according to the log, there are some Lua scripts in use apparently? Although it seems like they were not loaded properly... please try to remove the "scripts" folder from your game directory (or rename it to "_scripts") and try to load/create a world again. Does it work then?
  • Thank you for your next hint. I renamed the scripts folder and started a world. Unfortunately I again experienced a crash after 5% loading. I must say that I do not know what those Lua scripts do there. I did not put them there intentionally. I believed they are from the install process of Rising world!?
    I again post the most recent log file.
    • 1529155652.log

      (21.15 kB, downloaded 1 times, last: )
  • that is, what windows says on the crash (in the event protocol). Not very helpful I fear, but maybe it contains something of importance!? Unfortuntely in german...

    Name der fehlerhaften Anwendung: risingworldx64.exe, Version:, Zeitstempel: 0x5a768926
    Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.3.9600.18938, Zeitstempel: 0x5a7ddf0a
    Ausnahmecode: 0xc0000005
    Fehleroffset: 0x0000000000008eac
    ID des fehlerhaften Prozesses: 0x22ec
    Startzeit der fehlerhaften Anwendung: 0x01d40576ca748776
    Pfad der fehlerhaften Anwendung: D:\Steam\steamapps\common\RisingWorld\risingworldx64.exe
    Pfad des fehlerhaften Moduls: C:\Windows\system32\KERNELBASE.dll
    Berichtskennung: 19a69a12-716a-11e8-8705-80fa5b130cd9
    Vollständiger Name des fehlerhaften Pakets:
    Anwendungs-ID, die relativ zum fehlerhaften Paket ist:
  • Sorry for the late response! If the crash still occurs without using Lua scripts, it might be related to the jdbc driver (native crash while creating the world database). I've prepared a beta branch with the latest jdbc drivers, to download it, rightclick on RW in Steam -> Properties -> Betas -> select jdbc - sqlite-jdbc-3.23.1. I'd also recommend to delete all worlds (unless there is a working world which was created previously). Once the download it completed, try to run the game and create a new world. Does the issue still persist?
  • Thank you for your response and for helping. I activated the beta version and run the game again. While creating a new world I unfortunately end up with the some result: after some percentages I see a crash. :(
    I tried to delete all the world, but I do not see them on the ingame list. If I just delete them from the world folder they are back after restarting the game. Even if I deinstall the game completely (including all local data), the worlds are back after installing and restarting the game (but without being listed in the ingame list). I assume they are recreated from some steam cloud data... But in the end this does not bother me that much.

    After reinstalling the script folder is empty. Do you still find any Lua script entries in the new log file, I could not find them...

    Thank you very much for your time and patience.
    • 1529700217.log

      (34.77 kB, downloaded 2 times, last: )
  • Lothoratal wrote:

    I tried to delete all the world, but I do not see them on the ingame list. If I just delete them from the world folder they are back after restarting the game
    Hmm... that's strange 8| Make sure the game is not running while deleting the worlds manually. Probably it's better to remove the whole "Worlds" folder in your game directory. Is the "jdbc" beta branch still active? Sometimes Steam has trouble downloading all files, maybe make sure the correct files of the beta branch are downloaded by verifying the game files (rightclick on RW in Steam -> Local Files -> "Verify integrity of game files"), then start the game ;)

    If the crash still occurs after removing the worlds folder manually and verifying the game files (I guess there is probably still no errorlog or hs_err_pid?), maybe post a report file here (to do that, open the ingame console by pressing ^ or ` while the main menu is loaded and type "report", then a file called "report" shows up in your game directory).
  • OK, I did as you said: the jdbc beta branch is still active and the entry in my steam library is still called "Rising World [jdbc]". I also checked game files integrity, everthing was fine. Unfortunately the crash still persists and still I cant find any errorlogs. But I created a report file following your instructions. And here it is...
  • Thanks for the report file, everything seems to be ok there... another thing you could try is to run the dedicated server and see if that works. You find the dedicated server in your Steam lib (under "Tools"), just install and run it. Does the server start, or does it also crash while creating a world?

    If the server works, the issue might be somehow related to the game directory.
  • Thank you again for your reply. I installed the dedicated server and it could be started without any crash.

    Hmm, would could be wrong with hte game directory? I am still puzzled about the fact, that connecting to multiplayerserver works fine, only starting or creating a single world leads to a crash...

    Any more hints or ideas are very much appreciated!
  • Unfortunately it's difficult to say what's going on there exactly... the crash in the KERNELBASE.dll indicates that a basic Windows operation went wrong or that there was a conflict with a driver or other programs. Since the crash only occurred in singleplayer, it sounded like the JDBC driver could be responsible for that, but since the dedicated server works fine (and updating to the latest JDBC driver didn't help), this seems to be unlikely...

    Actually there are lots of other people out there experiencing the same issue for other games or programs. It sounds like there is a local issue with the KERNELBASE.dll file... Is your Windows up-to-date? Maybe you can try to run the Windows Update Troubleshooter which fixes issues caused by broken Windows updates:…ows-update-troubleshooter

    If that doesn't help, you can try to register the KERNELBASE.dll again. To do that, open the Command Prompt as Administrator (search for cmd, then rightclick on it -> Run as Administrator). Type regsvr32 KERNELBASE.dll, then close the Window and restart your computer.

    If the issue still persist, there might be an issue with your user profile (at least there are some reports of user profile corruption causing these crashes). You could try to create a new user profile temporarily and run the game with this new profile. Do you still run into the same crash?

    A workaround for this issue might be to use the dedicated server to play on a world locally. If you start a server, can you actually join it (go to "Multiplayer" -> "Connect to IP" -> enter localhost)? If that works, could be more or less a replacement for the singleplayer mode (not very convenient, but at least it works)...

    As a last resort you could try out the standalone version of the game. To get it, create an account on our homepage (if you don't have an account) and send us an email containing your username to :)
  • Thanks for all your help. Unfortunately I could not fix the problem. I checked windows update, tried to reregister Kernelbase.dll (I got some error on this), I created a new user...
    But the workaround is fine. I started the server, join it and found some nice place to start creating a settlement. Fruits, coal, copper all around. I think I will start enjoying the game by using the dedicated server instead of further searching for the bug in my system.

    Thanks a lot for helping and for developing such a great game!