SEVERE: NpcHit: ServersidePlayer

We've posted a status update with some first screenshots of the new terrain generation. There is also a new update available for the Java version!

  • SEVERE: NpcHit: ServersidePlayer

    Hi,

    I got a whole bunch of SEVERE events on the console output which coincided with the server stopping people from connecting (Stuck on connecting... screen). Any ideas? :/


    Source Code

    1. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    2. 2019/03/30 09:52 PM G.f
    3. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    4. 2019/03/30 09:52 PM G.f
    5. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    6. 2019/03/30 09:52 PM G.f
    7. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    8. 2019/03/30 09:52 PM G.f
    9. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    10. 2019/03/30 09:52 PM G.f
    11. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    12. 2019/03/30 09:52 PM G.f
    13. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    14. 2019/03/30 09:52 PM G.f
    15. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    16. 2019/03/30 09:53 PM G.f
    17. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    18. 2019/03/30 09:53 PM G.f
    19. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    20. 2019/03/30 09:53 PM G.f
    21. SEVERE: NpcHit: ServersidePlayer (ID: 78) or ServersideNpc (ID: 105,988) not found!
    Display All
    play: server.medievalrealms.co.uk website: medievalrealms.co.uk discord: discord.medievalrealms.co.uk
  • Sorry for the late response! This issue seems to be related to some desync, although it shouldn't be a big problem (the "SEVERE" keyword is indeed misleading here). However, we released a mini update which should fix this issue ;)
    Nevertheless, this doesn't seem to be related to any "stuck while connecting" issues. Do you still get stuck after a restart? Could you maybe send me the whole server log?