Dedicated server Fail to start Linux

The animal update is now finally available for the new version!
  • When I try to start the server using the script I get the following error

    :~/Downloads/server$ sh ./
    ./ 13: ./ Syntax error: "(" unexpected

    If I try to start the server straight from the jar file I get the following:

    I have followed the instructions at UPDATED: Linux Dedicated Server Startup Guide

    what do I need to do to get this running? I'm using java 8 on an ubuntu 14.10 system.

  • Server bind to IP: *.*.*.*:4255

    It would seem that the IP in the can't be used by the server. I accidently stumpled upon this yesterday when I tried assigning an IP to one of our game servers that was located on another machine. Exact same error as Cannot assign requested address

  • SEVERE: Unable to determine mac address: java.lang.NullPointerException

    Can you post your (at least the part where you define IP and port)?

    Looks like it has problems binding to the interface/ip.

    Also if you want to use the startscript try: # bash ./ start <Name>
    That doesn't explain the syntax error in line 13 tho. Have you modified it?

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!