Something odd with permissions

A big new update is now available, introducing biomes, caves and much more!
Latest hotfix: 0.7.0.3 (2024-02-21)
  • player xxx is an admin. Player yyy is also an admin. After a restart of the server,player xxx logs into the server and above his head is [ADMIN] xxx. Player yyy then logs in and has [ADMIN] xxx above their head. If the server is now restarted and player yyy logs in first they now have [ADMIN] yyy above their head and when player xxx logs in the same thing happens, [ADMIN] yyy is shown.


    There is still a problem with console commands when inside of a protected area. gm 1 will work but most other console commands won't work. To get them to work you need to leave the protected area. This is while in the owner's group with everything turned on.

  • player xxx is an admin. Player yyy is also an admin. After a restart of the server,player xxx logs into the server and above his head is [ADMIN] xxx. Player yyy then logs in and has [ADMIN] xxx above their head. If the server is now restarted and player yyy logs in first they now have [ADMIN] yyy above their head and when player xxx logs in the same thing happens, [ADMIN] yyy is shown.

    There is indeed a bug with nametags of players getting messed up :wat: Thanks for bringing this to our attention, this will be fixed with the next hotfix :)


    There is still a problem with console commands when inside of a protected area. gm 1 will work but most other console commands won't work. To get them to work you need to leave the protected area. This is while in the owner's group with everything turned on.

    Actually commands are currently excluded from area permissions, so they're only controlled by the group permissions. The idea was that most commands (e.g. ban, kick, makeadmin etc) are very specific and affect the whole server... there are a few commands though which could be useful inside an area (e.g. heal)... we could change it so areas could also control command permissions ;)

  • I see how you were going about the permissions thing but shouldn't admin rights override any other permissions? I understand for regular players, having it set this way but I would think admin rights should take president over all of it. In any case it is workable, now admins just have to make sure they are not in a protected area when using the console. It would be good if the commands could be controlled by the area permission but that would mean that admins would have to have a special group in the area permissions group, to be set every time an area is made, for all admins. I still think making admin privileges override all other settings would be best for admins. For the normal player it is set up fine like it is.

  • The upcoming hotfix will at least enable area permissions to override command settings ;) There is also another incoming change that an area only overrides the keys which are actually specific in the area permission file.


    I still think making admin privileges override all other settings would be best for admins

    If you're an actual server admin (i.e. your UID is added to the "Admins" list in the server.properties), then your permissions should not be affected by areas... at least by default area groups :thinking:

  • Changes to the default.json file will not take effect. The server.properties file settings only change the Server Mode and Server Name. I redid many different manipulations with the permission group, not one combination does not give the players creativity, only the admins in the server.properties file.


    Please, if someone has configured Creative mode on a dedicated server (a permission group and it works), please upload z7 here to the forum in this thread. We will be very grateful to you.

  • Changes to the default.json file will not take effect. The server.properties file settings only change the Server Mode and Server Name. I redid many different manipulations with the permission group, not one combination does not give the players creativity, only the admins in the server.properties file.

    In order to be able to use the "gm" command, the "changegamemode" permission (under "general") needs to be set to true. Like this:

    JSON
    "general": {
    "changegamemode": true
    }


    In addition to that, you can also define which creative mode tools should be accessible to the player. They're located under "creative":


    Make sure the resulting file is valid JSON. You could either put that into the default.json permission (if you want it to affect all players), or create a separate group for creative mode players. I've attached a permission file which solely enables creative mode (with all tools except the area tools - that one should only be allowed for the admin). Put that file into the "groups" folder in the "permissions" directory, then assign players via the "spg" command (e.g. "spg galochka creative") ;)

  • If you're an actual server admin (i.e. your UID is added to the "Admins" list in the server.properties), then your permissions should not be affected by areas... at least by default area groups :thinking:

    This is the problem, The areas are affecting the ability of admin to use console commands inside the protected areas. I see there has been a hotfix so I will let you know if the console problem is fixed.


    Thank you for fixing that!!! The console now works as expected for admin.

  • In order to be able to use the "gm" command, the "changegamemode" permission (under "general") needs to be set to true. Like this:

    JSON
    "general": {
    "changegamemode": true
    }


    In addition to that, you can also define which creative mode tools should be accessible to the player. They're located under "creative":


    Make sure the resulting file is valid JSON. You could either put that into the default.json permission (if you want it to affect all players), or create a separate group for creative mode players. I've attached a permission file which solely enables creative mode (with all tools except the area tools - that one should only be allowed for the admin). Put that file into the "groups" folder in the "permissions" directory, then assign players via the "spg" command (e.g. "spg galochka creative") ;)

    Thank you Red for 7s, but I have several files identical to yours, I have been working with them for several years since Java. Thanks for the "code check" link, yes, I have been using similar services since the Java version.

    Yes, in the group "by default" all permissions were given, except for ban, kick, etc. (as part of the experiment).


    To the point. Another question: ^^

    Looks like I somewhere on the forum missed the information that the area works only for admins, and that the server somehow retains the old settings (but the server behaves this way).:thinking:


    I am inclined to believe that somewhere in the settings some kind of saving (copy) is enabled, which somehow works on the server. Is it possible?


    I used the Admin group to create the Builder group and accordingly changed the color of the group to green, after deleting the Builder group (because it does not work, there is no protection for the area), the Admin group is green on the server, and in the permissions it is red (I’m not garbage inside the server I keep, all files that are not up-to-date are stored on a separate storage medium or deleted).



    It was:

    Group "Builder"

    "chat": true,

    "chatcolor": "# FF0000",

    "chatemojis": true,

    "chatnamecolor": "# 00b300", <= GREEEN Color

    "chatnameprefix": "",

    "chatprefix": "",

    "chatrichtext": false,

    "group": "Builder",

    "groupcolor": "# 00b300",

    "nametagcolor": "# 00b300",

    "nametagprefix": "",

    "nametagprefixcolor": "# 00b300",

    "nametagsuffix": "",

    "nametagsuffixcolor": "# 00b300",

    "showadmintag": true,

    "showdistance": true,

    "showinplayerlist": true,

    "shownametag": true


    Now:

    "info": {

    "chat": true,

    "chatcolor": "# FF0000", <= Red Color.

    "chatemojis": true,

    "chatnamecolor": "# FF0000",

    "chatnameprefix": "ADMIN",

    "chatprefix": "ADMIN",

    "chatrichtext": false,

    "group": "ADMIN",

    "groupcolor": "# FF0000",

    "nametagcolor": "# FF0000",

    "nametagprefix": "ADMIN",

    "nametagprefixcolor": "# FF0000",

    "nametagsuffix": "[ADMIN]",

    "nametagsuffixcolor": "# FF0000",

    "showadmintag": true,

    "showdistance": true,

    "showinplayerlist": true,

    "shownametag": true

    The Builder group does not exist inside the server (I have it on my computer). And the Admins on the server are green.


    I come back to the question.

    It may be that some type of "cloud" saving is enabled in the settings. Is it possible?

  • Looks like I somewhere on the forum missed the information that the area works only for admins, and that the server somehow retains the old settings (but the server behaves this way). :thinking:
    I am inclined to believe that somewhere in the settings some kind of saving (copy) is enabled, which somehow works on the server. Is it possible?

    Hmm... could you elaborate on that? If you refer to the area creative mode tool, this can be fully controlled via permissions, but it's recommended to make it only available to admins (otherwise players could abuse this feature).

    What do you mean exactly with "saving"?


    I used the Admin group to create the Builder group and accordingly changed the color of the group to green, after deleting the Builder group (because it does not work, there is no protection for the area), the Admin group is green on the server, and in the permissions it is red (I’m not garbage inside the server I keep, all files that are not up-to-date are stored on a separate storage medium or deleted).

    Was it only the color that was incorrect? Otherwise maybe you could send me the permission files in question, then I can take a closer look at it ;)


    It may be that some type of "cloud" saving is enabled in the settings. Is it possible?

    There is unfortunately no cloud saving available for the dedicated server :/

  • As I mentioned in the first post, the name tags above our admin's heads stay green and will not change but on further investigation I find all the color settings in permissions to be acting up, as @Galachka is noting. I have set all the color settings to several different colors and nothing seems to happen.

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!