Windows 11 - Cannot launch Rising World client - Java version (Unity version will work fine)

  • Hi red51

    Windows 11 Pro -- all latest updates on a clean new PC build.

    i5 12600K (latest Alder Lake CPU - 12gen)

    Asrock Z690 Pro RS with latest bios (mobo)

    Samsung 980 Pro 1TB M.2 NVME

    32GB RAM (DDR4 3200)

    GTX 1660 Ti (w/ latest Nvidia Driver 511.23)

    Unity version works fine.

    Java version will attempt to launch then Java coughs up the attached error logs (1st log using built in java).

    Installed latest version of Java thinking it may be a problem with the older packaged java in game. No dice (see 2nd log).

    Looks like a compatibility issue with Windows 11 (still works on my older Win 10 pc). Anyone here able to run RW Java version in Windows 11??

    *NOTE* Alder Lake (gen 12 Intel CPUs) did have an issue with some games but have since been fixed by Intel (DRM issues with certain games), so I am not sure if this may be related. Here is a link to the old article about this issue:…drm-game-list-workaround/

    Just wanted you to be aware.


  • Hmm... that's strange :thinking: The game couldn't load some definitions from the definitions.db file... maybe the file is corrupted (in this case you could try to verify the game files through Steam).

    But this could also be an issue with the temp folder: By default SQLite puts some temporary files in the Windows temp folder (AppData/Local/Temp), maybe that's causing problems on Windows 11?

    You could try this: Create a new file called "args.txt" in your game directory (where the exe is located) and add this line to it: Files (x86)/Steam/steamapps/common/RisingWorld/cache

    Maybe you could also try to run the game as administrator.

    If that doesn't help, it could be worth a try to use the latest JDBC drivers, which can be found here:…/sqlite-jdbc-

    Just download the jar, then rename it to sqlite-jdbc.jar and put it in the lib folder in the game directory (and replace the existing file with it).

    Please let me know if that works :)

  • I already tried running as administrator and verifying files via steam. I'll try your other two suggestions and get back to you. thanks!

    "The past is history, the future a mystery, but today is a gift, which is why we call it the Present."

  • win 11 home fully updated

    all drivers updated

    i5 7th gen cpu (not supported by win 11 )

    GTX 1050

    32 gig ram

    2 gig video ram

    Am not having any problems with java version other then my internet sucks.

    single player runs fine

    multi player is working but loading slow dew to internet

    seem to be having problems with the java server not wanting to start. Updating java to see if it helps.

    server starts fine in the unity version.

  • OK, I was able to get this resolved. Unfortunately I do not know specifically what it was. Went through and disabled all non essential Windows 11 functions I prefer not to have, and tweaked my UEFI/BIOS some after updating to latest. Updated the Samsung 800 pro firmware and setup OP (Over provisioning). I didn't have a chance to try your last two suggestions ( red51 ), I figured I'd try launching 1st thing this morning after my work last night and it worked. I'll let you know if I can identify what caused it. I appreciate your input!

    "The past is history, the future a mystery, but today is a gift, which is why we call it the Present."

    Edited once, last by Juggernaut ().

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!