Das Ziehen auf eine Ebene beschränken

A big new update is now available, introducing biomes, caves and much more!
Latest hotfix: 0.7.0.3 (2024-02-21)
  • Es gibt in den Einstellungen die Möglichkeit eine Reihe oder mehrere zum Ziehen auszuwählen (Platzieren von Bauteilen oder so ähnlich).

    Gäbe es da vielleicht eine zusätzliche Möglichkeit, dass das Platzieren für eine Fläche möglich ist, aber die Ebene auf eine zu beschränken, eventuell mit einer Zusatzeinstellung?

    Beim schnellen Ziehen von Blöcken oder sonstigem kommen dann ebenfalls mehere Ebenen zusammen, ohne dass das gewollt ist. Das führt unweigerlich zu Performanceproblemen, da ein Untergrund sich auf eine Reihe von Blöcken beschränken sollte, und nicht auf mehrere Etagen von Blöcken übereinander. Ich persönlich ziehe meistens mit einer Reihe um das zu vermeiden, allerdings dauert das Ganze länger.

    (Ich sage Ziehen. Das bezieht sich auf Platzieren von Blöcken oder auch Bauteilen in Reihen).

  • Du kannst in den Einstellungen festlegen, wieviele Ebenen bzw. Richtungen beim Ziehen verwendet werden sollen (Verschiedenes -> Bauen -> "Gleichzeitige Richtungen beim Platzieren"). Wenn das zB auf 1 gestellt ist, dann verhält sich das Ziehen wie in der Java Version (also immer nur eine Reihe). Bei 2 (Standardwert) können die Blöcke in zwei Richtungen gleichzeitig gezogen werden, bei 3 hingegen kommt noch eine 3. Richtung dazu (wobei diese Einstellung eher weniger zu empfehlen ist) ^^


    Ist die Einstellung bei dir evtl. auf 3 gestellt? Ansonsten bin ich mir nicht ganz sicher, wie eine zusätzliche Ebeneneinstellung genau aussehen sollte? :thinking:

  • Ich meinte noch eine zusätzliche Einstellun, die Ebenen vorgibt vielleicht. Wenn ich im Moment eine Fläche von 8x8 Blöcken ziehe, kann bei mir gleichzeitig das Ganze auch nach unten gezogen werden, obwohl die Einstellung nur auf 2 gestellt ist = Würfel.

    Von der Einstellung her wäre das eigentlich gar nicht möglich, oder? :thinking:


    Ich habe mehrfach einen größeren Bodenbereich mit Blöcken gezogen (Einstellung nur 2) und später festgestellt, dass das Ganze ebenfalls 2 oder 3 Reihen nach unten weiter geht. :(

  • Ich muss zugeben, das kenn ich auch nur zu gut. Habs grad ausprobiert, bei den normalen Blöcken 1x1x1 passiert das nicht. Da gehen nur 2 Richtungen, wie auch in den Einstellungen (gerade geprüft) vorgegeben.
    Aber wenn man die Größe des Bauteils ändert, ich habs auf eine Platte geschrumpft, dann kann man das auf einmal in 3 Richtungen ziehen. Teils ist damit auch mein Absturz-Problem verbunden von dem ich zuvor schon berichtet hatte.

    Keine Ahnung warum ich das bisher nicht gemeldet hatte :D

  • Hier mal ein Beispiel. Die 3er Reihen übereinander habe ich schon entfernt. Das sind normale Blöcke 1 x 1 x 1 groß, da passiert es auch.

    Bei der Standard Größe ging es bei mir nicht. Evtl hängt es damit zusammen ob man die Größe vorher man geändert hat. Müsste ich mal probieren

  • Ok, hab es eben ausprobiert. Wenn ich ein Bauteil an ein anderes andocke ist die Größe des Blocks egal. Trotz anderer Einstellungen lässt sich das angedockte Bauteil immer in 3 Richtungen ziehen.


    Das Problem lässt sich beheben, wenn man in den Einstellungen die entsprechende Einstellung erst auf 3, dann auf 2 wieder ändert. Danach passiert das nicht mehr.


    red51 - ich denke das Problem liegt in den Einstellungen. Auch "schnelles Abbauen" muss man immer wieder neu aktivieren, auch wenn in den Einstellungen der Schieber schon auf "ein" steht.

  • Ich konnte das Problem tatsächlich reproduzieren :wat: Das sollte im nächsten Update behoben sein (zusammen mit der Absturz- und Performance-Problematik wenn viele Bauteile in Reihe gezogen werden) ;)


    Mit der Einstellung scheint das aber nicht zusammenzuhängen, ich glaube, dass das Zufall ist, dass es beim Umstellen von 2 auf 3 und umgekehrt funktioniert? :thinking: Sonst muss ich mir das nochmal genauer angucken.


    Wegen dem "schnellen Abbauen", unter welchen Umständen tritt das denn genau auf? Ist das im Singleplayer oder Multiplayer?

  • Bei mir stand es auf 2 und ich konnte den genannten Effekt reproduzieren.

    Als ich die Zahl auf 3 und dann zurück auf 2 gesetzt habe konnte ich das nicht mehr.


    Das schnelle abbauen ist bei mir im single player so. Allerdings spiele ich mit play with friends option.

  • Das schnelle abbauen ist bei mir im single player so. Allerdings spiele ich mit play with friends option.

    Also im Multiplayer? Bzw. bei der "Play with Friends" Option wird immer ein Multiplayer-Spiel gestartet (P2P), selbst wenn man anschließend alleine spielt ^^


    Im Multiplayer kollidieren diese Einstellungen leider ein wenig mit dem Permission-System... nichtsdestotrotz sollten die Singleplayer-Einstellungen zumindest bei P2P Spielen für den Host gelten, das jetzige Verhalten ist also ungewollt und müssen wir auf jeden Fall noch ändern!


    Falls du momentan aber überwiegend alleine spielst, könntest du zB stattdessen ein reguläres Singleplayer-Spiel starten (das ist i.d.R. auch etwas weniger resourcenintensiv, da der ganze Netzwerkkram wegfällt). Dort sollten die Einstellungen wie "schnelles Abbauen" auch erwartungsgemäß funktionieren ^^

  • Was ist das schnelle Abbauen überhaupt und wo finde ich diese Option?

    Ich spiele generell mit gm 1.

    In den Einstellungen unter Verschiedenes -> Einzelspieler (ganz oben) -> "Schnelles Abbauen". Damit wird im Survival-Modus Terrain mit einem Schlag und Bauelemente mit zwei Schlägen abgebaut (wie im Creative-Modus).

    Zusätzlich (das ist aber eher eine temporäre Lösung) hat das auch Auswirkungen auf den Creative-Modus, denn wenn diese Einstellung aktiv ist, werden Bauelemente dann mit einem einzigen Schlag abgebaut (statt wie standardmäßig mit zwei Schlägen).

  • In den Einstellungen unter Verschiedenes -> Einzelspieler (ganz oben) -> "Schnelles Abbauen". Damit wird im Survival-Modus Terrain mit einem Schlag und Bauelemente mit zwei Schlägen abgebaut (wie im Creative-Modus).

    Zusätzlich (das ist aber eher eine temporäre Lösung) hat das auch Auswirkungen auf den Creative-Modus, denn wenn diese Einstellung aktiv ist, werden Bauelemente dann mit einem einzigen Schlag abgebaut (statt wie standardmäßig mit zwei Schlägen).

    Danke. Dann habe ich das sicherlich schon eingestellt. Einmal draufschlagen reicht mir. ^^

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!