Mac OS unity version doesn't start up

  • I have been playing the Windows version on my Bootcamped mac. It works OK. Today just as a test I downloaded the latest Unity version and tried to start that. No go. After hitting "Play" from steam, I get a red screen. It doesn't recover or start the game. I am running Catalina 10.15.7 on a macbook pro, maxed out ram and adequate graphics card. When I tried to run the demo about 6 months ago, it did run, but was super laggy and unplayable.

    Possibly it doesn't like that version of OSX. I'm not updating yet.

    Not a big deal for me as I can play on the Win side, but I wonder if the Mac version is running yet? Thx.

  • Hmm... what sort of red screen do you get exactly? Do you get an error message? Does it work if you try to run the game from the folder (i.e. not from Steam)?

    We've tested the new version on our Mac (mini) and it worked, but of course there is a chance that it doesn't work on other OS versions or hardware configurations... if the game doesn't even start (i.e. no game window, error message etc), it's likely an engine bug - unfortunately this type of error is out of our control in most cases... Unitys support for Mac and Linux is horrible (although it's even worse for Linux), which is a pity :(

  • This sounds like a native issue :thinking: Maybe have a look if there is a log file available called "Player.log" in ~/Library/Application Support/com.JIW-Games.RisingWorld/ or alternatively in ~/Library/Logs/JIW-Games/Rising World/. If there is such a file, please upload it here :)

  • Thanks for the log! Unfortunately it doesn't contain any information about what went wrong, but it looks like it gets stuck when initializing the Steam API (that's when you run into the "red screen") :thinking:

    One thing you could maybe try is to launch the new version directly (from the game directory, i.e. not from the Steam library). Does that work?

  • I wasn't able to start the game outside of the steam app, it just would no let me. However, I did update the game and try again through steam and it does start up and run. However, it is supper laggy. (Frame rates are equally bad on both platforms, but that doesn't seem to be much of an issue for just building stuff.) I have not changed the graphics settings on the Mac, but the new clouds (I believe) are having an effect on the distance rendering. (On mac, not on PC) See the lines on the mountain in this screen shot. Color gamut actually looks better to me on the Mac side, but I don't know how to change the gamut on PC. Otherwise it just seems to run a little better on the PC side, so I will continue to play there. So interesting that it's the same hardware but runs different on the bootcamped PC. Must be DirectX? I've had other troubles with other games on Mac and Metal, which I think is the counterpart to DirectX??

  • Yes, Metal is the graphics API on Mac (it's a pity that Apple decided to create their own graphics API, instead of just using Vulkan), while the Windows-specific counterpart is DirectX.

    You could try to improve the framerate by reducing the graphics settings... either try out the "Medium" or "Low" graphics preset, or alternatively enable/disable individual features (most settings show a tooltip if you move the cursor over them, indicating the estimated performance impact).

    The lines are strange though, this seems to be a Metal-specific issue :wat: We couldn't reproduce this issue on our Mac, so maybe this only happens with certain graphics cards or certain MacOS versions... we'll take a closer look at this issue!

    About the color gamut, unfortunately we have no direct setting for that, but you could try to change the "Saturation" or "Contrast" in the "View adjustment" menu in the graphics settings, maybe that helps :)

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!