java.net.Socket.Exception: Connection reset

  • ich habe einen verdacht aber da ich leider kein it speziallist bin weiß ich leider auch nicht ob das zusammenhängt
    Java benutzt das IPv4 verbindungs protocoll und die meisten leute die bei kabel anbietern sind bekommen nur ne IPv6 addresse wo das vernünftige Port forwarding nicht mehr funktioniert
    ich bin frisch umgezogen und habe jetzt Uniti Media 60Mb/s leitung und habe auch schon den support gefragt bei UM da ich auch keinen ts server mehr hosten kann
    man müsste sich ne Buissnes leitung kaufen damit man noch ipv4 bekommen kann das ist wirklich nervtötend :(


    falls das zusammenhängt weiß hier ja vielleicht jemand einen Rat wie man das beheben kann

  • @terranerx1: Grundsätzlich ist es schwer zu sagen, wo die Ursache liegt. Es kann durchaus damit zusammenhängen, dass Kabelkunden i.d.R. keine richtige IPv4 Adresse erhalten (da aber der meiste Internetverkehr noch über IPv4 läuft, wird sowas durch Techniken wie DS Lite "gelöst" - da kann es passieren, dass eine IPv4 Adresse mehreren Kunden zugewiesen ist usw). Portforwarding funktioniert unter diesen Umständen normalerweise nicht mehr, das sollte das Problem aber eigentlich nicht verursachen.
    Der größte Verdacht besteht darin, dass es mit der Internetroute zusammenhängt, die deine Pakete zurücklegen. Da wird ein Knotenpunkt sein, der den Ärger verursacht und die Verbindung schließt - die Gründe dafür sind unbekannt. Offenbar hilft dabei die Verwendung eines VPN (da deine Pakete dabei eine andere Route verwenden).
    Das Problem betrifft derzeit scheinbar nur deutsche User (oder zumindest User aus dem deutschsprachigen Raum) die Kabelinternet haben (aber nicht alle). Aus anderen Ländern ist dieses Problem noch nicht bekannt, auch tritt es mit DSL nicht auf.

  • Hab mir grad den Thread durchgelesen, ein paar Empfehlungen:
    1.) DNS wechseln(z.B. 8.8.8.8 für Google-DNS oder sucht euch einen komplett freien DNS wie 208.67.222.222 ), nicht den von euren Kabelanbieter nutzen, teilweise sind diese so langsam das es immer wieder zu entsprechenden Problemen und auch Abbrüchen führen kann.
    2.) im Router IPV6 ausstellen, auch in Windows (ist nicht bei jeden Anbieter möglich)
    3.) Euren PC per Live-System booten, dort RW installieren und schauen ob es zu gleichen Problemen kommt. Sollte es dort nicht zu den Problemen kommen, liegt es mit großer Wahrscheinlichkeit an eurer Win-Installation, Treiber etc.


    So muss erst einmal los, bis heute Abend.

  • hi leutz nochmal also bei mir hab ich den Fehler gefunden habe eben mit meinem Anbieter (Unity Media) gesprochen ich habe bei mir ABSOLUT keine Möglichkeit mehr irgendwelche Ports freizugeben(im router steht zwar port forwarding aber mit portcheck sind trotzdem alle zu) da ich auf DS-lite Leitung laufe auch sogenannte tunnel Programme helfen leider nicht die 10 Minuten Abbrüche sind immer noch da ;(


    @Lichti dns wechseln is auch bei ds-lite nicht möglich da mein Router(Technicolor Tc7200) sowas nicht unterstützt und wenn ich das in Windows mache kappt er einfach die Leitung


    meine einzige Möglichkeit ist leider doch die Business Pakete zu buchen denn nur da soll es angeblich möglich sein noch ne alte IPv4 zu bekommen
    ich verzweifel langsam denn ich habe keine Ahnung mehr was ich noch machen kann.ich bin voll gezwungen entweder alles so hinzunehmen oder mehr Geld auszugeben ?(

  • Hi leutz habe es ENDLICH geschafft hab mein it speziallisten angerufen der sagte mir nehm das programm Cyberghost und zack es funktioniert wirklich denn das programm unterdrückt die IPv6 addresse ich habe es auch getestet ich spiele jetzt schon über 35 Minuten und immer noch kein abbruch JUHUUU

  • Hi leutz habe es ENDLICH geschafft hab mein it speziallisten angerufen der sagte mir nehm das programm Cyberghost und zack es funktioniert wirklich denn das programm unterdrückt die IPv6 addresse ich habe es auch getestet ich spiele jetzt schon über 35 Minuten und immer noch kein abbruch JUHUUU


    Vielen Dank für das Feedback, freut uns zu hören, dass es jetzt funktioniert! :) Grundsätzlich ist die Nutzung eines VPN die einzige Möglichkeit momentan, da i.d.R. deine Pakete dann eine andere Route nehmen. Es ist offenbar immer nur ein einziger Knotenpunkt, der den Ärger verursacht, und die Chance, dass dieser durch das VPN umgangen wird, ist sehr hoch.
    An IPv6 sollte es eigentlich nicht direkt liegen, denn der 10-Min Disconnect tritt scheinbar auch auf reinen IPv6 Servern auf (sprich Server und Client connecten komplett via IPv6).

  • Hi! Ich habe mir gerade alles hier zu durchgelesen. Es scheint das ich das gleiche problem habe. Alle 10min fliege ich vom Server.
    den einzigen lösungsvorschlag den ich noch machen könnte wäre über einen Drittserver ins internet zu gehen. Jedoch wäre mir eine andere möglichkeit lieber.

  • Moin habe mir jetzt nach langer zeit Rising World wieder installiert und hatte gehofft das das Problem jetzt langsam mal behoben wurde.
    Leider ist das Problem immer noch da :( ich habe in der vergangen Zeit viele spiele ausprobiert das Problem gibt es nur hier.
    Ist es nicht langsam Zeit das mal zu beseitigen ansonsten hat sich ja viel getan in dem knapen Jahr sieht echt gut aus wie es sich entwickelt hat besonders das mit dem Wasser gefällt mir.


    Gruß Lichti

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!