Probleme unter Linux mit dem Steamclienten

  • Probleme unter Linux mit dem Steamclienten

    Hallo @red51

    Ich benutze LinuxMint 1.83, ich werde mal schaun was ich für Libs Steam bei mir benutzt, sollte aber eigentlich aktuell sein, da diese eigentlich normal bei jedem Start aktualisiert werden, jedenfalls sollte es sein. Im Spiel selbst hab ich soweit keine Probleme, erst wenn ich auf den Desktop wechsele geht der PC in die Knie und der RAM / CPU schiessen hoch. Maus lässt sich kaum bewegen.
    Könnte natürlich auch an den GrafikTreiber liegen, obwohl die von Nvidia meist immer gut performiert ist. Werde mir das ganze nochmal am WE mir ansehen ;D
  • Achso, d.h. also dass diese Probleme lediglich beim Wechsel auf den Desktop auftreten und nicht im normalen Spielbetrieb? In dem Fall könntest du evtl. einmal in die config.properties Datei im Spielverzeichnis (Rechtsklick auf RW in Steam -> Eigenschaften -> Lokale Dateien -> Lokale Dateien durchsuchen) schauen was bei game_pause_on_lost_focus gesetzt ist ;) Wenn es auf true steht, ändere es bitte auf false, ansonsten wenns schon auf false ist, ändere es bitte auf true. Im Zweifelsfall könntest du ansonsten auch bei der Standalone in die config schauen, welcher Wert dort eingestellt ist. Speichere dann die Änderungen, und starte das Spiel erneut. Tritt das Problem weiterhin auf?
  • ja stimmt, das Problem hatte ich ja auich bei der Standalone .. ok werde ich mal schaun ;D

    danke dir ;D

    Nachtrag: Da ich in einem anderen Thread was von RW und kleines Team las. Ich bin bei RW dabei, seit es auf Steam erschienen ist. Bin per Zufall entdeckt, das RW von einen sehr kleinen Team entwickelt wird, finde ich persönlich gar nicht so schlimm. Das eine oder andere hab ich schon mal geflucht über die langen Pausen zwischen den Updates. Trotzdem ist mir das Game ans Herz gewachsen, muss ich echt so sagen, es gibt kein Game, vielleicht ausser Minecraft, was ich immer wieder gerne spiele. Und der Content ist gar nicht so wenig, nur man muss sich RW annehmen, sonst wird es nichts.

    Es gibt halt Spiele, da kann die Entwicklung jahre dauern, da ist es einem eigentlich egal wie lange es dauert. Auch so ein Spiel ist übrigens auch 7Days to Die, das auch einige Jahre entwickelt wird. Ich kenne es seit der Alpha 5 oder 6.

    So mehr wollte ich gar nicht dazu schreiben und möchte hier auch kein Diskussion anregen.
  • Eigentlich sind immer noch dieselben Probleme wie oben beschrieben, das ausschalten des Focus hat leider nichts gebracht. FPS ist auch gut im Spiel, nur halt wenn ich auf dem Desktop wechsel, dann bekomme ich probleme. Die CPU Last geht nach oben und wenn ich es richtig gesehen hab auch der RAM läuft sich voll, aber das muss ich nochmal genauer nachschaun. Kann natürlich auch an Steam selbst liegen, da haben sie ja vor paar Tagen einen neue Version von ihrem Clienten rausgehauen, nur ob das was unter Linux bringt weiss ich nicht, weil unter Windows habe ich da keine Probleme.
  • red51 schrieb:

    Mit der Standalone treten diese Probleme nicht auf? Probiere am besten mal folgendes: Kopiere die config.properties aus dem Standalone-Verzeichnis einfach mal in das Steam Verzeichnis des Spiels, und starte anschließend das Spiel :) Treten die Probleme weiterhin auf?Ich
    ich hab die Datei mal kopiert, scheinbar sind die Probleme nun verschwunden, hab die Dateien mal verglichen, da sind wohl in der Standalone einige Grafikfunktionen ausgeschaltet, vielleicht kamen deshalb die Probleme. Na jedenfalls ist dieses problem gelöst ;D

    Danke für dein Support ;D

    Nachtrag: Zu früh gefreut, ich bin im Game und wechsel auf den Desktop und es bricht wieder alles zusammen, kann kaum die Maus bewegen und music im hintergrund fängt auch an stottern. Ich weiss ist bisschen seltsam vielleicht, aber könnte es mit dem FMod zusammenhängen ? Weil als ich die Audioeinstellungen vorgenommen hab, da gabs erst wieder probleme. Davor war alles gut, da stand bei Soundkarte auf interne Soundkarte.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Bogus ()

  • Ich denke nicht, dass es mit FMod zusammenhängt, auszuschließen sind solche Sachen aber besonders unter Linux natürlich nicht. Du könntest ggf. einmal die "config.properties" Datei der Steamversion einmal hier hochladen (und ggf. auch die der Standalone). Spielst du im Vollbildmodus, oder ist die "Rahmenlos" Option aktiv? Falls du im Vollbildmodus spielst, könntest du ggf. einmal probieren, den Vollbild zu deaktivieren, die Auflösung an die Desktop Auflösung anzupassen, und ein Häkchen bei "Rahmenlos" zu setzen. Wenn das nicht hilft, das Problem aber nur unter Steam auftritt, könnte es evtl. auch helfen, das Steam Overlay auszuschalten (Rechtsklick auf RW in Steam -> Eigenschaften)
  • Ok, hab mal auf Fenstermodus gemacht, konnte aber die Fenstergrösse nicht verändern, hatte auch auf Rahmenlos gesetzt. Ich lad mal die beiden Configs hoch, vielleicht findest du ja was ;D

    config.properties <--- Standalone

    config.properties <---- steam

    Das mit dem Overlay hat auch nichts genützt

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Bogus ()

  • Hallo ;D

    Ja soweit läuft alles gut, da ich aber mein Linux neu installiert hab, muss ich alles neu einstellen. So richtig testen, werde ich es erst am WE können, da werde ich meinen kleinen Server updaten ;D

    Welches Linux nutzt du denn ? Bisschen seltsam das du das Game nicht in der Auswahl hast. Ich hab übrigens die Beta von dem Steamclienten laufen, da soll angeblich dieses Proton drin enthalten sein, womit man auch Windows Spiele unter Linux spielen kann.

    @red51
    So hab grade nochmal das Game angespielt, hab dasselbe Problem wie bei letzten mal. Auch wieder, wenn ich auf den Desktop wechsel, dann kann ich die Maus fast gar nicht bewegen. Das dieses game_pause_on_lost_focus steht auf false. Und ich hab laag picks, wenn ich durch die gegend gehe. Also ab und zu bleibt das Bild stehen.

    Dazu kommt, das der SteamClient bei mir auf englisch ist und das Game ebenso, obwohl ich es in Steam bei Rising World unter Einstellungen auf Deursch gesetzt hab. Muss dazu sagen, das ich die Beta von dem Steam Clienten benutz, vielleicht liegt es ja daran, das die Sprache nicht geändert wird.

    Könnte es mit den JavaVersionen zutun haben ? Ich hab nämlich in Minecraft ähnliche Probleme, da hab ich auch laag picks. Hab nämlich Java von Oracle und das OpenJDK installiert. Das letzte wurde seltsamerweise von dem Minecraft installier mitinstalliert.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Bogus ()

  • Proton bringt dir hier nichts. RW ist, wie die Engine auch, in Java geschrieben.

    Ich kenne mich mit den Stellschrauben der Engine auch nicht weiter aus (scheinbar haben die ne Doku aber auf der Webseite selbst liegt sie nicht rum *hmpf*). Deine systemweite Java Installation ist allerdings egal. RW liefert die Runtime mit aus und nutzt diese dann auch:

    Quellcode

    1. RisingWorld/java/bin ./java -version
    2. java version "1.8.0_131"
    3. Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
    4. Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

    Wichtig ist dass dein Grafikkartentreiber am Start ist und auch die Grafikkarte genutzt wird, und nicht etwa die integrierte der CPU. Ich meine 0.9.4 zeigt das in den Settings inzwischen an.

    Ich bin beeindruckt was hier aus Java raus geholt wird, aber so richtig performant wird das nie werden. Deine Ruckler kommen aber vermutlich woanders her. Da kann ich auch nur raten. Sowas geht von CPU Speed Stepping über Festplatten IO bis hin zu einfachen Swapping. Klappt es im "Rahmenlosen Fenstermodus" besser? Kann gut sein dass im Vollbild beim _Desktop_ hier irgendwo auf Pause liegt und dann mal kurz gesammelte ToDos runterklopft. Das ist aber alles Stochern im Nebel, ohne dass ich mir das direkt anschauen kann.

    Was hast du denn da genau am Start? Ich spiele seit über nem Dutzend Jahre exklusiv auf Linux und bin halt gewohnt schlechte Optimierung und/oder Emulation mit Leistung zu erschlagen :whistling:

    Quellcode

    1. model name : Intel(R) Core(TM) i5-8600K CPU @ 3.60GHz
    2. 01:00.0 VGA compatible controller: NVIDIA Corporation GM200 [GeForce GTX TITAN X] (rev a1)
    3. Mem: 15897
    Achso.. und im Moment Fedora Linux. Davor auch ein paar Jahre Mint. Das ist für RW allerdings relativ egal :rolleyes:
  • Das mit dem Proton, das war nur als Erwähnung gedacht, das mir das da nichts bringt, ist mir schon klar ;D Bin ja kein Anfänger unter Linux ;D

    Aber das mit dem Overlay, das werde ich mal testen, glaube aber nicht das das sein könnte ;D

    Nee also die Grafikkarte ist es auch nicht, da hab ich ne Gforce 660er mit 2 GB. Ich hatte da ja unter der Standalone nie probleme gehabt. Als Treiber nutze ich die aktuelle GK treiber, den es von nvidia, müsste Version nachschaun.

    Ich tippe auf die Java Version ... aber morgen ist ja Freitag, dann ist WE ;D
  • Uh.. keine Ahnung ob die 660er bereits sinnvolles liefert. Check mal nvidia-smi. Das liefert dir Auslastung zur Karte. Daran erkennt man auch ganz gut ob "GPU Starvation" vor liegt. Mit osd_cat oder ähnlichem kannst du das auch als Overlay "über alles" realisieren.

    2G sind allerdings verdammt wenig heute. Und RW ist "auch" gewachsen.

    Ich habe übrigens immer einen Micro-Ruckler wenn eine OSD Meldung über den Gnome Notify Service rein kommt.