Possible Disconnect Fix or Temp Fix!

  • Do you get that annoying disconnect bug in the game? Do you wish you could fix it...
    Well this might help you...below this may or may not work for everyone. I just know it
    seems to help me alot I can stay on for hours now and get stuff made.


    To enable Ports in your Windows Firewall do the following...

    • Click on start menu
    • Click on Control Panel
    • Click on System and Security
    • Click on Windows Firewall
    • Click on Advanced Setting -Located on the left menu
    • Click on Inbound Rules -Located on the left menu
    • Locate Java(TM) Platform SE binary -Make sure those ports are enabled
    • To enable Rick Click and choose Enable Rule


    Give your computer a few mins to settle the ports then try out the game.
    This worked on my end if it doesnt work on yours I am not sure what is
    causing this error at this time. Below are images of the step by step
    setup for Windows Firewall Ports.


    Image Link:
    http://imgur.com/IAXhOaO


    If you need this translated please ask someone to do so I am not a good translator :D .

  • Not a problem. Lots of people have this disconnect error for online play. Doesn't happen if you are the host only to others. It kept saying it was a client side error so I just dug into my firewall see what is going on.

  • The disconnects are mainly occurring when the connection is blocked or restricted (by firewalls, antivirus programs [mostly those with an integrated firewall] etc.), or when the connection is unstable. It can also happen when a client- or serverside error occurs (if it's clientside, there will be an errorlog in your game directory).


    We have plans to rework some of the network code to deal with unstable connections ;)

  • I'm playing single player but have noticed on a few occasions after exiting and restarting RW that I get an error message saying RW can't start because ports are in use. I've just checked Windows Firewall and Java appears to be set correctly:-
    Java
    Profile - Private
    Enabled - Yes
    Action - Allow
    Override - No
    Local Address - No


    I also have the same settings set for Rising World.


    Not sure if anything there is causing the ports not being released on closure.

  • Well I know the game is coded in Java mostly that's why I thought client side the ports were not open for the game to use java. like I said this is not a 100% fix I just know it worked for me and I rarely disconnect so far I have not disconnected since I did all these patches or fixes. I just have all my stuff on the game set to default and ports opened up for the game including servers for the game. Everything seems to be working 100% hopefully it stays this way. I would get disconnected every hour but so far its looking like its not the case anymore.

  • Thanks red. I've checked the game directory, no error logs. Haven't played RW in a few days. I've never had any issues with other games, even Minecraft which also uses java. I'm with what is probably the most stable internet in my area. Still need to test while the garbage antivirus I currently have is disabled. I'll post here what I find.

  • On an advanced note if you see 4 ports for Java(TM) Platform SE binary delete 2 you only need to have 2 enabled. This may cause the conflict also...


    Inbound Rule:

    Code
    Java(TM) Platform SE binary TCP ALL PORTS
    Java(TM) Platform SE binary UDP ALL PORTS


    There should be one for TCP with all ports open and one for UDP with all ports open. Also you should have the Programs and Services Tab with the following folder/file added.
    Make sure you have the bubble This program checked to place the file.


    Programs and Services Tab:

    Code
    C:\program files (x86)\java\jre1.8.0_31\bin\java.exe
  • I just kept the ones using Java that worked for me. It may be different for others I am not sure. But some reason I kept getting a crash now I am not when I use just the default java ports not the rising world.

  • Just added command line column to my task manager processes tab. Nothing is running java currently and this is pretty fresh restart of windows. Just firefox, vlc and explorer open... weird. Still have to test if it's my antivirus or comodo firewall. Testing now.


    Edit: well it's not antivirus... :S

  • Like i mentioned in another post the only other option I did was turn my nVidia Graphic Card fan up to 50% just in case it was getting to hot to play the game. I did get a memory issue I pasted that on pastebin but it was only for an hour lol. Shouldn't have memory issues because im running 16gigs of ram and 2gigs of ram in my card. Try turning up your fan speed in your graphic card if you have that option most cards should have a system tools on their website if its not all ready installed. I would not turn it all the way up maybe 50% max just to be safe so you don't blow out your fan.

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!