Terrainartefakte und sehr langsames Laden

A status update and another preview video of the new version are now available!
  • Steam oder Standalone?
    Steam
    Fehlermeldung?
    No
    Betriebssystem
    Windows

    Ich habe etwas Terrainbearbeitung betrieben, aber ich bekomme die Terrainüberreste außer durch Neustart nicht mehr weg. Spitzhacke, Rechen, F5 funktioniert nicht.


    Desweiteren habe ich seit neuestem das Gps-Plugin und noch ein anderes Plugin aufgespielt. Seitdem schläft mein Spiel beim Laden ein. Es dauert ewig und bleibt bei

    10% hängen und dann kann ich mich gemütlich zurücklehnen und abwarten :(. Kann ich das irgendwie beschleunigen, außer Plugin wieder rauszuwerfen? Das möchte

    ich eigentlich vermeiden.

  • Ich habe etwas Terrainbearbeitung betrieben, aber ich bekomme die Terrainüberreste außer durch Neustart nicht mehr weg. Spitzhacke, Rechen, F5 funktioniert nicht.


    Desweiteren habe ich seit neuestem das Gps-Plugin und noch ein anderes Plugin aufgespielt. Seitdem schläft mein Spiel beim Laden ein. Es dauert ewig und bleibt bei

    10% hängen und dann kann ich mich gemütlich zurücklehnen und abwarten :(. Kann ich das irgendwie beschleunigen, außer Plugin wieder rauszuwerfen? Das möchte

    ich eigentlich vermeiden.

    Hi. Was genau hast du unter F5 probiert? Bei mir verschwinden solche Stellen, indem ich dort im Kreativemodus irgendein Material (z. B. Erde) platziere und dann wieder lösche ;)

  • Die Überteste sind ja nach dem Relog wieder verschwunden und wenn ich in der Luft noch Erde hlnzufüge, muss ich diese auch wieder entfernen. Es kann sein, dass das Spiel überlastet ist. Blöcke habe ich nicht probiert, müsste diese dann auch vom Boden aus hochbauen, da das Platzieren in der Luft in dieser Version nicht funktioniert.

  • Um was für Überreste handelt es sich genau (also die, die sich nicht entfernen lassen)? Nur um Grashalme (wie auf dem Bild), oder auch um Terrain? Es gibt in der alten Version leider einen Bug, wodurch in manchen Fällen Grashalme zurückbleiben können - das passiert meist nur im Creative-Modus wenn großflächig Terrain bearbeitet wird. Das lässt sich bis dato nur beheben, indem man entweder einmal weit wegfliegt und wieder zurückkehrt (sodass der Chunk neu geladen wird), oder einmal die Welt neu lädt.


    Desweiteren habe ich seit neuestem das Gps-Plugin und noch ein anderes Plugin aufgespielt. Seitdem schläft mein Spiel beim Laden ein. Es dauert ewig und bleibt bei

    10% hängen und dann kann ich mich gemütlich zurücklehnen und abwarten

    Tritt das nur mit den Plugins auf? Wenn du die Plugins testweise entfernst (es reicht, temporär den "plugins" Ordner einfach kurz umzubenennen, zB zu "_plugins"), ist das Laden dann schneller? Um welches Plugin handelt es sich bei dem 2. Plugin? Ansonsten könntest du ggf. einmal einen Log hier posten (oder mir via PN senden) ;)

  • Die Terrainreste traten vermehrt nach den Pluglns auf, zuvor auch, aber eher selten und nur kleine Reste. Es war auch eine großflächige Terrainbearbeitung. Das mit dem Chunkwechsel wäre eine Idee, das hatte ich im Singleplayer aufgrund fehlender Teleports vermieden. Ich verwende Gps Plugin und den Staticloader.


    Ich werde den Ordner umbenennen, ich hoffe nur dass die Teleports nicht verschwinden.

  • Ich verwende Gps Plugin und den Staticloader.

    Hast du evtl. besonders viele oder extrem detailreiche Modelle platziert? Diese müssen beim Spielstart erst geladen werden (2x, einmal von der Plugin API, dann vom Spiel selbst), was allerdings den Ladevorgang anhält. Das ist normalerweise kein Problem, aber bei sehr vielen oder extrem detailreichen Modellen (wenn sie zB aus Millionen von Polygonen bestehen) kann das besonders lange dauern.


    Was passiert dann mit meinen Modellen, sind die dann weg? Das Setzen hat einiges an Zeit gekostet.

    Die Modelle sowie ihre Positionen werden im entsprechenden Plugin Ordner gespeichert. Wenn du das Plugin bzw. den Plugin-Ordner nicht löschst, sondern nur testweise umbenennst, kannst du ihn hinterher wieder zurück benennen und deine Modelle sind wieder vorhanden :)

  • Hi,


    Same problem ... small grass clumps refusing to be removed till I reload the map.


    I get that when doing extensive terrain changes (roads, rivers, lakes, snow melt dams and such). I just ignore it till I need to reload the map, which happens frequently when editing large areas due to steadily increasing jerky loading. I have settings turned way up with many constructions, and large areas are very far from map center, so some of this jerky performance is to be expected.


    I also get very large dark "spikes" which are sometimes caused by a small bits of water left over after doing a terrain edit. Reloading map doesn't help. Once I locate the bit of water, usually high in the air above the "spike", and remove it, these type go away.


    Other "spikes" - though they look similar - are still a puzzle at the moment, as nothing seems to remove them. Till I figure out what the issue is (perhaps a shadow caused by something else left high up after terrain editing?) For now I just build something over the "spikes" so they are hidden from view.


    That aside, RW is the most awesome & addictive open world software that I've experienced, with a dev who responds promptly and efficiently when problems arise. : thumbup:

    My only regret is that I didn't get in on the ground floor when RW was first made available. Hopefully I can get in on testing the new version. :)


    (using stand alone version & win10)

  • Same problem ... small grass clumps refusing to be removed till I reload the map.

    Yes, unfortunately this happens sometimes, especially when doing lots of terrain modifications (using the creative mode terrain tools). Apparently this happens more frequently when using a large brush size and getting close to the border of the "detail view distance" (from where on the game only renders the LOD chunks). This issue should be fixed in the new version, at least we were unable to reproduce it there ^^


    Other "spikes" - though they look similar - are still a puzzle at the moment, as nothing seems to remove them. Till I figure out what the issue is (perhaps a shadow caused by something else left high up after terrain editing?)

    Do you see the same "spikes" like in this topic?


    That aside, RW is the most awesome & addictive open world software that I've experienced, with a dev who responds promptly and efficiently when problems arise. : thumbup:

    Thanks a lot for your kind words ^^ I'm glad to hear you like the game so far!

  • Hi red51,


    Yup, those are the "spikes". Thanks for the info, that's pretty much what I've been doing. Once narrowed down, I mark the area and build something ... usually a pyramid as they are easy, quick, and look good.


    Now I know why there are so many pyramids scattered around the real world: to hide the "spikes". : D


    I tried F7, but not sure if I tried F5. When I get back into one of my "spiky" areas I'll give it a try.


    Thank you :)

    • :)
    • ;)
    • :(
    • :P
    • ^^
    • :D
    • :verysad:
    • ;(
    • X(
    • :*
    • :|
    • :crazy:
    • :lol:
    • :dizzy:
    • =O
    • <X
    • ||
    • :thinking:
    • :wacko:
    • :/
    • 8)
    • :wat:
    • :huh:
    • :silenced:
    • :wow:
    • 8|
    • :angry:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :hushed:
    • :nerd:
    • :saint:
    • :drooling:
    • :love:
    • :monocle:
    • :poo:
    • :party:
    • :drunk:
    • <3
    • :!:
    • :?:
    The maximum number of attachments: 10
    Maximum File Size: 1 MB
    Allowed extensions: 7z, avi, bmp, dds, gif, jpeg, jpg, log, lua, mp3, mp4, ogg, pdf, permissions, png, properties, rar, txt, xml, zip

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!