[SCRIPT] Zcript (Admin tools)

A new Update is now available for the new version!
  • just a note line 608 should be


    database:queryupdate("CREATE TABLE IF NOT EXISTS 'group' (ID INTEGER PRIMARY KEY NOT NULL, name VARCHAR NOT NULL, adminID INTEGER NOT NULL);");




    Change group to 'group'

  • ok guys i did a edit and think i changed everything that needs to be changed but it did not work :-(

  • ok heres the now tested one and it works yay



    just copy this file over to your Zcript by Zabka folder don't rename it there is no need

    Files

    • zcript.lua

      (21.34 kB, downloaded 331 times, last: )

    Yahgiggle Steam Signature, real name Deon Hamilton :thumbsup: Rising Cities @ ip 52.53.149.132:4255 ServerName (Rising Cities) Unity :thumbsup:

    If you want to run a server how about using my AutoServerInstallers go here to download >>>RWAutoServerInstaller for Unity And Java<<<

    If at first your code does not work call it version 0.1 with the odd bug :thinking:




    31245-logo-png

    Edited once, last by yahgiggle ().

  • Ok, here it's morning time, maybe too early for me ... ;)


    But, the script is not running on my server.
    I keep the existing zcript, download your zcript.lua onto the server.
    Then i delete the original script.lua, rename your zcript.lua (-> script.lua) and move it into the /scripts/zscript folder ...


    During the start of the server, everything looks good. But when i try to join the server, there is an error ...



  • the file zcript.lua just needs to be copied over the top of your old zcript.lua file and it will work if you rename it script.lua it wont work because thats not used no renaming needed


    the link to download the new edited working file is here Link

  • I don't have a zcript.lua file ...


    At the moment, I'm using the zcript from guthub.


    Link


    redownload it from here then https://www.mediafire.com/?bnntuswxsbqcd4q then just copy my file over the top

  • Nope, not working.
    Never mind, I will run the server without the script ...


  • ok i have redone all files and uploaded it to my own server heres the link http://www.risingworld.org/ind…ttach;topic=18.0;attach=1

  • :thumbsup:
    Thx, now it's running without any problem !!!


    I appreciate your work!


    no problem happy its now working for you

  • Download link updated (thanks to yahgiggle for the updated version ! :D ). Also, the project won't be hosted on my GitHub any more (at least, it won't be updated there), since he's now on the LordFoobar's RisingWorld Repository ( here : https://github.com/RisingWorld ).


    I'll keep working on it, maybe (I hope :D) with some help from others, so we could do something perfect for you guys :D


    Stay tuned ;)

  • Download link updated (thanks to yahgiggle for the updated version ! :D ). Also, the project won't be hosted on my GitHub any more (at least, it won't be updated there), since he's now on the LordFoobar's RisingWorld Repository ( here : https://github.com/RisingWorld ).


    I'll keep working on it, maybe (I hope :D) with some help from others, so we could do something perfect for you guys :D


    Stay tuned ;)


    No problem :-D

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!