Problem beim modularen bauen

  • Problem beim modularen bauen

    Probleme beim bauen mit dem Raster und dem Magneten ( Enter-Taste ).Hier wird gezeigt, dass man immoment mit dem Magneten Nicht genau arbeiten kann und wenn man zuvor einen Holzbalken frei und nicht im Raster setzt, auch dieses dann nicht mehr für diesen gilt.



    ==Hessenstrolche==

    Teamspeak 3: 185.239.238.125:9987 / Rising World Server:185.239.238.125:4255
    Homepage / Discord / FB-Gruppe

    The post was edited 3 times, last by lenko ().

  • Ich hab das selbe exakt die Tage auch gemerkt als ich eine Wand mit dem Magneten gebaut habe. Der Magnet funktioniert nicht richtig. Ich kann auch mit +/- den Abstand nicht ändern.

    Ein Fehler hab ich aber in deinem Video gefunden. Wenn du einen holz-block ohne Raster setzt und dann versuchst mit Raster genau dran zu kommen geht das logischerweise nicht weil das Raster immer an der Welt und nicht an dem frei gesetzten Objekt ausgerichtet ist. Das passt dann auch an der Seite nicht wo du sagtest das passt, denn da geht der block einfach in den anderen hinein.

    Bis der Magnet akkurat funktioniert werde ich versuchen nur mit Raster oder "setp 1" zu arbeiten, ist ärgerlich wenn man sich was errechnet hat und am Ende was nicht passt...
    Gamer aus Leidenschaft
    (Web) Entwickler aus Leidenschaft
    <3 Vater aus Leidenschaft <3
    (prio in aufsteigender Sortierung ;) )

    ~~~~~~~~~~~~~~~~~
    1. Entweder man macht etwas richtig oder lässt es bleiben!
    2. Egal wie lange etwas dauert, Hauptsache es wird fertig (irgendwann)
    ------------------------
    Discord: Devidian#1334
  • Um eine solche Ungenauigkeit zu vermeiden, baue ich seit Jahren immer mit Raster. Nach Lenkos Video habe ich mir das auch probiert. Jetzt verschiebt sich das Rasterandocken oder Magnetandocken bereits nach kurzer Zeit, d. h. es entstehen Berechnungsfehler.
    Bei meinem Bild ist das zweitkleinste Raster verwendet worden, mal mit Magnet + Raster, mal mit Magnet ohne Raster und auch ohne Magnet mit Raster. Diese Ungenauigkeiten kenne ich so nicht. Dass bei einem Holzbungalow durch mehrmals blaupausen und neusetzen oder durch Updates Risse entstehen, ist ja bekannt, allerdings bei 0,5m Blöcken in diesem Maße nicht.
    Files
  • Danke für das Video und die Infos! Ich werde mir das mal genauer ansehen. Ich denke das Problem mit dem Ungenauigkeiten lässt sich wohl nur beheben, wenn wir die Genauigkeit erhöhen (klingt irgendwie banal, ist aber nicht ganz so trivial): Momentan wird nicht die exakte Position des Bauelements gespeichert, sondern stattdessen werden die Koordinaten umgerechnet. Auf diese Weise können wir pro Element immerhin 18 Bytes an Daten sparen, was zwar nach nicht ganz so viel klingt, bei extrem vielen Bauelementen aber durchaus nennenswerte Datenmengen einsparen kann. Ich denke aber, dass das für diese verschiedenen Szenarien von Ungenauigkeiten verantwortlich ist.

    Das Bausystem muss ohnehin einmal überarbeitet werden, bei der Gelegenheit werden wir diese Probleme auf jeden Fall ausmerzen ;)