Posts by Gwenwhyfar

A new status update as well as a first preview video of the new version are now available!

    Diese Fehlermeldung kommt im Singleplayer aber auch gelegentlich vor. Ich kann mich erinnern, dass ich die schon hatte, als ich mit RW vor kA wie viel Jahren angefangen hab.Gelegentlich tauchte sie auch, Neustart vom Spiel ließ sie verschwinden.

    Zu den Schildern weiß ich nichts.


    Aber das Bauen mit der Entertaste und dem Problem, dass es manchmal eben nicht andockt, kenn ich zur Genüge. Das hängt, so wie es ausschaut, meistens mit dem Übergang zwischen zwei Chunks zusammen. Befindet sich der Balken in dem einen und du in dem anderen Chunk, funktioniert das Andocken nicht. Da musst dann halt nen bisschen rumfliegen.
    Aber: Bis VOR dem Update war es eben auch so, dass es eben NICHT immer am Chunk lag, sondern scheinbar auch andere "unsichtbare" Hindernisse dafür sorgen können, dass das andocken einfach nicht geht, bis man irgendwann den einen Punkt gefunden hat, an dem es eben doch geht. Dabei spielt es keine Rolle, ob der Balken/das Brett/der Stamm mit Size verändert wurde oder nicht, in welcher Neigung er sich befindet oder sonstiges.
    Ich habe das Problem bisher sehr oft gehabt beim Bau unseres Großprojektes, aber bis dato noch keine Übereinstimmung gefunden, warum es nicht geht.

    Aber nur ab und zu, nicht bei jedem Auswerfen. Oder ist das nur bei mir so? :huh:

    Im Survival hab ich das noch nicht getestet. Im Creativ verhält es sich so, dass jedes Mal ein neuer Wurm genommen wird, wenn man das Angeln unterbricht. Sprich: Ich halte die Angel, werfe sie 2mal aus und öffne dann das Inventar. Nach dem ich es geschlossen habe und die Angel erneut auswerfe, verbraucht er wieder einen Wurm. Das ist zumindest das, was ich bisher beobachtet habe. Ob er nach so und so vielen Angelauswürfen einen neuen Wurm nimmt, habe ich noch nicht gezählt. Das müsste man dann halt mal im Survival testen :) Im Creativ kann man es halt nicht beobachten, da du da im Grunde keine Würmer brauchst, sie sich aber eben trotzdem verbrauchen, wenn du welche hast.

    Und wenn ich ein Ruderboot zerschlage, verschwindet es aber nach einer Weile/einem Serverneustart/ausloggen, oder?

    Ja, das ist leider wirklich ein Problem... ich überlege, ob es da eine vernünftige Lösung gibt... das ist weniger ein programmatisches, als ein pragmatisches Problem. Tatsächlich ist es aber generell unschön, dass Gegenstände durch Wände hindurch aufhebbar oder benutzbar waren. Noch unschöner ist, dass dieses Verhalten so lange Zeit im Spiel existierte...
    Von dieser Umsetzung wollen wir uns eigentlich nicht wieder abwenden, aber vielleicht wäre es ein Ansatz, ein spezielles, technisches "Kisten-Objekt" einzubauen, welches nicht gecrafted werden kann, aber welches auch nicht diesen neu eingeführten Limitierungen unterliegt. Das würde zwar bedeuten, dass alle bestehenden Möbel überarbeitet werden müssen (die darin versteckten Kisten müssten gegen diese Spezialkiste ausgetauscht werden), aber so könnte man das Problem zumindest umgehen

    Was mich aber wundert, ist, dass man doch zum Beispiel die Truhen nur von vorn öffnen konnte. Also man musste davor stehen, um sie benutzen zu können. Dann wäre es ja eigentlich auch gar nicht möglich, durch eine Wand hindurch auf eine Truhe zugreifen zu können, es sei denn, sie steht verkehrt herum gegen die Wand oder die gegenüberliegende Wand ist nah genug.
    Bei den Kisten weiß ich, dass man sie von allen Seiten öffnen kann. Könnte man das nicht genauso wie bei den Truhen machen? Und dann auch angeben, wie nah jemand an der Truhe sein muss, damit er sie öffnen kann?
    Wenn man in 1 Block Abstand zur Kiste und definitiv davor stehen muss, damit man sie überhaupt öffnen kann, hätte sich das mit dem Zugriff durch Wände komplett erledigt und du bräuchtest auch keine Alternative, damit man Schränke weiterhin benutzen könnte.


    Edit sagt: Übrigens betrifft das auch Mülleimer, aus denen man ja keine Items herausholen kann aber sehr wohl welche wegwerfen kann. Das versteh ich wiederum nicht :D Den Mülleimer unter meiner Spüle kann ich nimmer benutzen. Aber auch da könnte man das wie mit den Kisten lösen. Definieren, wo vorne ist und den Abstand, den man braucht um darauf zugreifen zu können, auf 1 Block verringern.

    Kleine Frage, weils gerade in nem Blueprintpost aufkam:


    Selbstgebaute Schränke, die auch Kisten beinhalten, damit diese Schränke auch nutzbar sind, sind ja nun ziemlich nutzlos, abgesehen davon, dass sie hübsch aussehen. Gibt es eine Möglichkeit, da irgendwie eine andere Lösung zu finden?
    Mit erschrecken stelle ich gerade fest, dass absolut jeder Schrank, jede Küchenzeile und jeder Bettkasten, den ich gebaut hab, nutzlos geworden ist und darüber bin ich tatsächlich nicht erfreut.


    Ich verstehe den Grund dafür, dass es nicht mehr möglich sein soll auf Grund dessen, dass man ja dann auch Inhalte der Kisten durch Mauern "klauen" kann, aber so ist es irgendwie auch blöd, da ich nu nimmer an meine Sachen drann komme...

    Also die Tab-Taste hab ich nur mit dem Inventar belegt und Spielerliste auf eine andere Taste gelegt, trotzdem öffnet sich im Mehrspieler-Modus (sprich aufm Server) die Taste nicht.
    Vorher wars halt so, dass durchs einmalige drücken der Tab-Taste das Inventar aufging, wenn ich sie länger gedrückt gehalten hab, ging zwar auch das Inventar auf aber im Hintergrund auch die Spielerliste.

    Der Sound ist einfach so ne Weile vorher schon weg gewesen (komplett) und als der Error auftauchte, war ich gerade auf dem Desctop und habe auf FB einen Beitrag kommentiert :D


    Error occurred during application-update (25)
    java.lang.NullPointerException
    at content.audio.a$a.a(SourceFile:252)
    at content.audio.a$a.a(SourceFile:243)
    at content.audio.a$a.a(SourceFile:239)
    at D.u.controlUpdate(SourceFile:328)
    at com.jme3.scene.control.AbstractControl.update(AbstractControl.java:128)
    at com.jme3.scene.Spatial.runControlUpdate(Spatial.java:778)
    at com.jme3.scene.Spatial.updateLogicalState(Spatial.java:921)
    at com.jme3.scene.Node.updateLogicalState(Node.java:228)
    at com.jme3.scene.Node.updateLogicalState(Node.java:239)
    at commons.JIWApplication.update(SourceFile:345)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:151)
    at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:198)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:232)
    at java.lang.Thread.run(Unknown Source)

    Doch mit "editc texture x" in der Konsole kann die ID seit diesem Update bei Blöcken auch im Nachhinein verändert werden.Das funktioniert allerdings nur im Kreativmode.

    So sollte es sein, Deirdre und hättest du meine Konversation mit @AbtRS6R verfolgt, wüßtest du das auch. Und nein, dem Block in deiner Hand kannst du deswegen trotzdem keine andere ID verpassen. Und den Befehl gibt es schon seit dem letzten Update, wo es tatsächlich auch möglich war, gesetzte Blöcke in der ID zu ändern.


    Aber @red51, da gibt es nun wohl einen Fehler.
    Ich habe gerade Steinblöcke mit der Textur 21 gesetzt. Mehrere übereinander und auch nebeneinander.
    Wenn ich folgendes eingebe: "editc textur 22" (Rechtschreibfehler: Es muss "texture" heißen) spuckt er mir folgende Fehlermeldung aus: "No construction element found in line of sight". Sprich: Bei dem Rechtschreibfehler findet er kein Bauelement.
    Wenn ich den Befehl richtig eingebe und aus dem Block mit der Textur 21 einen Block mit der Textur 61 machen will mit folgendem (diesmal richtig geschriebenen) Befehl "editc texture 61" passiert nichts. Er ändert die Textur des Steinblockes nicht und ich bekomme auch keine Meldung in der Console. Auch mit der ID 22 gings nicht, andere hab ich noch nicht getestet, nehme aber mal an, dass da genau so wenig passiert.


    Das Selbe habe ich mit einem Holzblock gemacht, da konnte ich einen Holzblock mit der Textur 61 in einen Holzblock mit der Textur 22 ändern.
    Auch einen Balken konnte ich so erfolgreich ändern.


    Getestet im Singleplayer.

    hm, das mit der Texture funktioniert bei bereits gesetzen Blöcken. Ist aber ziemlich aufwendig da es nur mit jeweils einem Block geht und sich nicht auf die Blöcke im Inventar umsetzen lässt. Schade.


    Und die Rotation das ich die Blöcke in 1 Gradschritten setzen kann funktioniert nicht. Bin wohl zu doof. Naja

    Blöcke kann man aktuell nur in 90° Schritten rotieren lassen. Kippen geht auch noch nicht.
    Ansonsten kannst du die ID eines Blockes nicht verändern. Das geht bisher nur bei Brättern und Balken.

    In diesem Fall müsstest du also folgendes tun: Das anschauen, was du in der Textur (deine Aktion) ändern willst und anschließend das eingeben, was dort steht:
    editconstruction texture 148
    Das, was in Klammern aufgeführt ist, sind die Aktionen (action) die du mit dem Befehl editconstruction ändern kannst. value muss dann eben die entsprechende Zahl sein, je nachdem, was du ändern willst.

    Hallo Red.


    Ich kanns dir leider noch nicht zeigen auf Grund der Probleme, die es gerade bei uns aufm Server gibt. Aber zu den Schlossgräben passt das Ruderboot super, die Frage ist nur: Wäre es möglich, das auch als Zweisitzer zu machen und nachträglich noch einzureichen? Denn was wäre romantischer als eine Fahrt zu zweit durch unseren Schlosspark im Ruderboot? <3


    Ps: Im Multiplayer scheint es so zu sein, dass ich die Tab-Taste nicht mehr mit dem Inventar belegen kann, wie es vorher ging. Im Singleplayer geht das noch (die I-Taste mag ich nicht), im Multiplayer streikt er einfach und versucht bei einmaligem drücken der Tab-Taste die Mitspielerübersicht zu öffnen. Ist das so gewollt?

    Mega cooles Update! Das Ruderboot ist super cute! Ich bin schwer begeistert weil es so absolut genial zu dem Schlosspark passt. Perfekt!
    Cool fand ich, wie man das Boot zusammenbaut und dann ins Wasser bringt. Sehr sehr gut gemacht!


    Aber das Schlauchboot mag nicht fahren und den Motor kann man auch nicht abstellen, oder? Maybe bin ich auch einfach zu blöd zu.


    Das zumindest im Singleplayer. Und auch im Singleplayer: Wenn man eine Wasserfläche über F5 anlegen wollte, konnte man die Maus auf die Wasseroberfläche halten und mit Enter sich dann das Raster holen um die selbe Wasserhöhe zu bekommen. Das geht nicht mehr. Er sieht die Wasseroberfläche nicht als Oberfläche an sondern nimmt die Erde am Grund eines Sees zB.

    Ich drück ganz fest die Daumen, dass das bald alles wieder läuft. Bei mir wirds langsam etwas ruhiger um mein anderes "Hobby" (ist mehr in Arbeit denn Hobby ausgeartet) und somit freu ich mich drauf, bald wieder öfters RW spielen zu können.