Black Screen

  • Steam or Standalone?
    Singleplayer or multiplayer?
    Error message?
    Operating system

    Was building a building when my screen went Black

    I logged out and in several times.

    after first attempt produced a report

    put settings on default

    Updated steam on the server.

    Restarted computer.

    Uninstalled/Reinstalled RW.

    I can interact with the ` key (report to follow)

    I can see the Blueprints, Map, Inventory and upper right corner (current inventory item)

    The x never leaves the center of the screen

    in gm1 I can select the function keys with the correct menus in the upper left

    in gm 0 the display for food and drink is visible, I was low on water. was able to move watermelon to active invetory and eat it. The confirmation was the number of watermelon slices going down 1 and the fluids turning green.

    Life is full

    Otherwise I just have a black screen.

    Please help


  • Sounds like a video driver issue. I inspected your log, and on your laptop uses the NVIDIA Geforce RTX 3060 laptop GPU and it's using old driver "461.66" latest driver is up to "466.63"

    Your laptop actually has two GPUs (low powered Intel UHD for battery saving for non gaming tasks, and the GTX 3060 GPU for gaming). Your laptop will automatically use the correct GPU depending if you are gaming or not, BUT this is controlled by the driver, which is why I suggest upgrading to the latest available driver for your GTX 3060 GPU found below, I suspect it may be using the wrong GPU which may be causing your issue.

    Try using the latest laptop video driver for your Alienware laptop here instead of what Alienware supplies:…Results.aspx/175870/en-us

    "The past is history, the future a mystery, but today is a gift, which is why we call it the Present."

  • Did as you suggested Juffernaut.

    I still have a black screen

    I was in the middle of laying some blocks when the screen initially went black.

    Have made sure the cache is cleaned, Computer updated and made sure I had the nvidia video driver updated.

    Still a black screen.

    Hope there are more suggestions available.

  • to Kluge60...That is what I get to look at when I log in.

    I can change game to creative

    There In the upper left I can see which F key I have active

    I can eat, walk everything works except seeing anything that is happening.

    I was placing blocks when the screen went black.

    . I am playing the original version. Not sure if this matters but I am no longer offered the preview of the Unity game. I will try the reinstall of the server files.

    Avanar... Thank you I will give that a try before I reinstall the server files.

    Thank you all for your suggestions. I will let you know if they work.

  • Das ist es, was ich mir anschauen muss, wenn ich mich einlogge.

    So wie es aussieht spielst du im Fenster Modus, kann das sein.? Wenn ja dann stelle doch mal in den Einstellungen auf Vollbild im Fenster. Vllt. ändert sich was, probiere es mal.

    Hast du eventuell sonst noch irgendwas in den Einstellungen verstellt. Probiere auch mal Reset.

  • You will be able to play the new Unity version when you click on play (in steam) if by any chance you are not seeing this then "right-click" on your Rising World / Properties / Betas / then select the new Unity version once you have downloaded that you will have the option to play the original or Unity version.

  • Have you tried going into creative mode? to do that press the tilde key (left to the 1 key) and type in gm 1 (you will now be in creative) now if you press the "L" key this is a light source if by any chance you see something (fingers x) just press and hold the space key until you see something.

    To return the game back to normal again press the tilde key but this time type gm 0.

  • I had the unity version. When screen went black I eventually left the game. When I tried to reenter, unity was no longer a choice given to me.

    regarding gm 1 or gm 0 I switch between them daily. I was in gm 1 when the screen went black.

    That picture was taken in window mode. I have tried full screen, windowed, changed all settings and reset them.

    I was not in a cave...turning on the light did nothing to change the darkness.

    All of you are wonderful for looking at this. Thank you so very much. Alas I have given up and purchased a new game so. I could get on with my game.

    Since I also changed computers, I will go back to the old computer and take another look.

    Hey Avanar, your eyes must be much better than mine as I do not see my hand holding the melon. My only thought since you said that is I went way underground. I will see if I have time to dig out my old computer and try flying out of the ground! If that turns out to be it I will put this game on hold and go back to my original game)

    Thanks again everyone for all the help and suggestions. Greatly appreciated.

  • Maybe after all it was really something about your settings or hardware. Sounds like at least as this isn´t a known issue to this game (at least i didn´t hear of it before).

    My eyes are not that good actually but if you open the screenshot on a big monitor you can see the hand and mellon

  • There is indeed a hand and melon visible on the screenshot, it's just extremely dark - so it really seems like you're either in a dark area, or the brightness settings of the game are on a very low value. It could be also a low brightness or gamma setting in the graphics driver.

    Maybe you could upload another screenshot with debug information enabled (to enable them, press F3 so the debug texts show up on the screen)?

    Alternatively please try to increase the brightness in the graphics settings (load a world, then go to the graphics settings and hit the "view adjustment" button - this brings up a screen where you can change the brightness).

    To run the Unity version btw you have to launch it from the Steam library (as mentioned by Groovaholic ), otherwise Steam does not bring up the dialog. Also make sure there is a small "[unity]" suffix behind "Rising World" in your Steam library.

    • :)
    • ;)
    • :(
    • :P
    • ^^
    • :D
    • :verysad:
    • ;(
    • X(
    • :*
    • :|
    • :crazy:
    • :lol:
    • :dizzy:
    • =O
    • <X
    • ||
    • :thinking:
    • :wacko:
    • :/
    • 8)
    • :wat:
    • :huh:
    • :silenced:
    • :wow:
    • 8|
    • :angry:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :hushed:
    • :nerd:
    • :saint:
    • :drooling:
    • :love:
    • :monocle:
    • :poo:
    • :party:
    • :drunk:
    • <3
    • :!:
    • :?:
    The maximum number of attachments: 10
    Maximum File Size: 1 MB
    Allowed extensions: 7z, avi, bmp, dds, gif, jpeg, jpg, json, log, lua, mp3, mp4, ogg, pdf, permissions, png, properties, rar, txt, xml, zip

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!