Update 0.4.8: Vegetation, Ackerbau und volumetrische Wolken

A new Update is now available for the new version!
  • Du könntest zB Navicat ausprobieren (das verwende ich), oder DB Browser: https://sqlitebrowser.org/


    Die relevante Tastenbelegung dafür in den Einstellungen ist "Kontextmenü (Bauen)". Es ist wichtig, die Taste gedrückt zu halten, um das Radialmenü zu öffnen.

    1) Muss ich mir mal wieder ansehen. Danke.


    2) Ich habe die ganze Zeit probiert, habe meinen obigen Beitrag geändert. Aber du warst schneller. ^^ Mir ist nicht aufgefallen, dass ich dazu eine Pflanze in der Hand halten muss.


    Wäre es möglich, dass das Drehen von Pflanzen auch mit der Konsole funktioniert.

    Die Konsole geht schneller, wenn man sie gewohnt ist. ^^


    Wenn aus der Entfernung in meine Stadt fliege, flackern die Lichter etwas stroboskopmäßig. Der Effekt vergeht nach kurzer Zeit zwar wieder, aber meiner Meinung nach war es vor dem Update nicht so.

  • red51 Zu der Java Textdatei: wenn ich eine Raute vor den Text setze wird diese Zeile nicht verwendet oder? So dass man im Bedarfsfall einfach eine Zeile ändern kann und die Standardzeile mit einer Raute versieht?


    Und die Navicut Lite Version öffnet die gewünschen Datenbank Infos nicht, die andere Möglichkeit hingegen schon. ^^


    Könnte ich theoretisch mit zwei Rising World Accounts und zwei Steam Accounts gleichzeitig die Java-Version und die Unity-Version zum Laufen bringen? Auf einem Pc und einem Windows.

  • Hi red51 ,

    in dem (ich sag es jetzt mal so) Nicht-Steam-Spiel, ist bei mir die Sprache immer noch auf Englisch. Nur bei Steam ist es normal.

    Wäre es denn nicht schlecht, wenn man in den Einstellungen auch eine manuelle Spracheinstellung hätte. Dann könnte ich auch die Sprache manuell umstellen.

    Ich habe zwar mit Englisch kein Problem. Aber da ich weiß, dass das Spiel auch in Deutsch gibt, wäre es mir sehr recht, wenn ich auch in Deutsch spielen kann.

  • Wäre es möglich, dass das Drehen von Pflanzen auch mit der Konsole funktioniert.

    Die Konsole geht schneller, wenn man sie gewohnt ist. ^^

    Oh, eigentlich hätte das mit dem rotation Befehl funktionieren sollen, ich stelle aber gerade fest, dass der bei Pflanzen nicht funktioniert :wat: Das wird mit dem nächsten Hotfix behoben ;)


    Wenn aus der Entfernung in meine Stadt fliege, flackern die Lichter etwas stroboskopmäßig. Der Effekt vergeht nach kurzer Zeit zwar wieder, aber meiner Meinung nach war es vor dem Update nicht so.

    Hmm... das müssen wir uns unbedingt nochmal genauer anschauen. Passiert das auch, wenn du die Anzahl der maximalen Lichter in den Einstellungen hochsetzt (also "Maximale Lichter" in den Grafikeinstellungen)?


    red51 Zu der Java Textdatei: wenn ich eine Raute vor den Text setze wird diese Zeile nicht verwendet oder? So dass man im Bedarfsfall einfach eine Zeile ändern kann und die Standardzeile mit einer Raute versieht?

    Ja genau, wenn du eine # an den Anfang der Zeile setzt, dann wird diese Zeile nicht verwendet ;)


    Und die Navicut Lite Version öffnet die gewünschen Datenbank Infos nicht, die andere Möglichkeit hingegen schon. ^^

    Oh, eigentlich müsste Navicat Lite mit SQLite umgehen können :thinking: Ich habe es aber zugegebenermaßen länger nicht verwendet (ich verwende die kostenpflichtige Version, alleine schon da die Lite Version eh nicht kommerziell eingesetzt werden darf)^^


    Könnte ich theoretisch mit zwei Rising World Accounts und zwei Steam Accounts gleichzeitig die Java-Version und die Unity-Version zum Laufen bringen? Auf einem Pc und einem Windows.

    Theoretisch geht das auch mit einem einzigen Account: Dazu kannst du bspw. die Java Version über Steam starten, und die neue Version direkt aus dem Spielverzeichnis heraus (also die "Rising World.exe" im "_New Version" Unterordner). Das einzige, was nicht klappen könnte, wäre der Multiplayer - hier wären dann tatsächlich zwei Accounts nötig.


    in dem (ich sag es jetzt mal so) Nicht-Steam-Spiel, ist bei mir die Sprache immer noch auf Englisch. Nur bei Steam ist es normal.

    Ich konnte das Problem leider bisher bei mir nicht reproduzieren... standardmäßig sollte die Standalone die vom Betriebssystem mitgeteilte Sprache nutzen :monocle:


    Du könntest aber die "config.properties" Datei im Spielverzeichnis öffnen und bei "Game_Language" german eintragen - dann sollte das Spiel beim nächsten Spielstart auf Deutsch sein ;)

  • Ich habe dir versucht einen Report zu senden, da kommt aber eine Fehlermeldung.

    Ich habe einen Screenshot gemacht. Da sieht man auch, das es auf Englisch ist...

    Das mit dem Report ist leider ein Bug, der sich ins letzte Update geschlichen hat :( Das wird mit dem nächsten Hotfix korrigiert (voraussichtlich heute Abend)!


    Ist das Spiel immernoch auf Englisch, obwohl du in der config Deutsch eingetragen hast? :wat:

  • Hmm... das müssen wir uns unbedingt nochmal genauer anschauen. Passiert das auch, wenn du die Anzahl der maximalen Lichter in den Einstellungen hochsetzt (also "Maximale Lichter" in den Grafikeinstellungen)?

    Ich habe die Lichteinstellung auf Maximum gehabt und nicht geändert.

    Was mich dazu noch etwas stört, ist die Reichweite der Lichter, da die Beleuchtung für eine Aufnahme im Dunkeln zu gering ist. Beleuchtete Häuser sieht man in der Entfernung als dunkel an, obwohl die Häuser mit Lampen bestückt sind. Ich finde das sehr schade, denn das nimmt die ganze Stimmung. ;(


    Ja genau, wenn du eine # an den Anfang der Zeile setzt, dann wird diese Zeile nicht verwendet ;)

    Danke. ^^


    Ich habe zwar schon mal gefragt, aber ich finde die Panoramabilder einfach nicht. :(


    Theoretisch geht das auch mit einem einzigen Account: Dazu kannst du bspw. die Java Version über Steam starten, und die neue Version direkt aus dem Spielverzeichnis heraus (also die "Rising World.exe" im "_New Version" Unterordner). Das einzige, was nicht klappen könnte, wäre der Multiplayer - hier wären dann tatsächlich zwei Accounts nötig.

    Das wäre toll, schon um sich die Java-Texturen dann gleich in der Unity-Version ansehen zu können.

    (Das einzige was Steam danach versuchen könnte, ist die eine Version auf die andere zu synchronisieren bzw. die Cloud zu aktualisieren, auch wenn diese ausgeschaltet ist und dass das zu einem Fortschrittverlust kommen kann.

    Das hängt glaube ich mit nur einer Windows-Version auf dem Pc zu sammen. Am besten ist eine Sicherung, leider dauert das wie bei mir mit 49 GB etwas länger und ist umständlich.)


    Wie stelle ich die Abstände beim Ziehen wieder auf 0?

  • Beleuchtete Häuser sieht man in der Entfernung als dunkel an, obwohl die Häuser mit Lampen bestückt sind. Ich finde das sehr schade, denn das nimmt die ganze Stimmung

    Das Problem ist, dass Lampen als "Objekte" behandelt werden und diese in der Ferne - anders als Bauwerke - nicht mehr angezeigt werden. Um das zu ändern könntest du entweder die "Detail-Sichtweite" höher stellen, oder alternativ in der config.properties Datei den Wert Graphic_ObjectsInLODChunks auf True ändern - dann werden Objekte auch in LOD Chunks generiert und angezeigt. Das wird sich aber vmtl. negativ auf die Performance auswirken...


    Ich habe zwar schon mal gefragt, aber ich finde die Panoramabilder einfach nicht. :(

    Nachdem du den panorama Befehl eingegeben hast, wird das Panorama-Bild im Spielverzeichnis im "Screenshots" Ordner in einem Unterordner "Panorama" angelegt ;)


    Wie stelle ich die Abstände beim Ziehen wieder auf 0?

    Beim Ziehen können die Abstände wieder mit der - Taste reduziert werden.

  • Das Problem ist, dass Lampen als "Objekte" behandelt werden und diese in der Ferne - anders als Bauwerke - nicht mehr angezeigt werden. Um das zu ändern könntest du entweder die "Detail-Sichtweite" höher stellen, oder alternativ in der config.properties Datei den Wert Graphic_ObjectsInLODChunks auf True ändern - dann werden Objekte auch in LOD Chunks generiert und angezeigt. Das wird sich aber vmtl. negativ auf die Performance auswirken...

    Das würde bedeuten dass man in der Config die Sichtweite auf 60 Chunks erhöhen kann, längerfristig?


    Ich habe erst einmal die Graphic Objects auf true gestellt. Meine Fps-Zahl war relativ niedrig. Nachdem ich die Option wieder auf false gestellt hatte,

    ist der FPS-Wert aber nicht angestiegen. Eine FPS von 49 ist für meinen PC und meine Graka definitiv zu wenig.


    Nachdem du den panorama Befehl eingegeben hast, wird das Panorama-Bild im Spielverzeichnis im "Screenshots" Ordner in einem Unterordner "Panorama" angelegt ;)

    Ich habe die Panorams endlich gefunden. ^^ Allerdings finde ich auch Screenshots. Mir genügen die gespeicherten Bilder auf Steam, die ja auch auf der Festplatte gespeiert werden eigentlich. Vorschaubilder generieren habe ich aus.

    Beim Ziehen können die Abstände wieder mit der - Taste reduziert werden.

    Das weiß ich.^^ Gibt es keine Möglichkeit das Minuszeichen-drücken zu entgehen und gleich auf den Standardwert, also keine Lücke, zu kommen?

    Bei Blöcken hat man keine großen Lücken, aber bei Zaunpfählen dauert das Reduzieren der Gaps sehr lange. Auch ein Neustart setzt den Abstand leider nicht auf Null.


    Beim Nähern flackern diese Gitter. Ich habe dort keine Lichter aufgestellt.

  • Das würde bedeuten dass man in der Config die Sichtweite auf 60 Chunks erhöhen kann, längerfristig?

    Das geht auch jetzt bereits: Wenn du zB mit dem viewdistance Befehl die Sichtweite erhöhst, dürftest du diesen Wert auch in den Grafikeinstellungen wählen können.


    Ich würde aber empfehlen, nur die normale Sichtweite höherzustellen. Wenn du die Detail-Sichtweite höher stellst, dann hat das einen massiven Einfluss auf die Performance.


    Ich habe erst einmal die Graphic Objects auf true gestellt. Meine Fps-Zahl war relativ niedrig. Nachdem ich die Option wieder auf false gestellt hatte,

    ist der FPS-Wert aber nicht angestiegen. Eine FPS von 49 ist für meinen PC und meine Graka definitiv zu wenig.

    Wenn du die Option wieder ausschaltest, dann musst du das Spiel dafür neustarten.


    Was die FPS angeht, das kommt einzig auf die Einstellungen drauf an. Auf maximalen Einstellungen hat die neue Version sehr hohe Hardwareanforderungen. Was besonders teuer ist sind viele Lichter, eine hohe "Detail-Sichtweite" (die ist ein Vielfaches so teuer wie die normale Sichtweiteneinstellung), und generell alles, wo man als Qualität "Sehr hoch" oder "Ultra" auswählen kann.


    Ich habe die Panorams endlich gefunden. ^^ Allerdings finde ich auch Screenshots. Mir genügen die gespeicherten Bilder auf Steam, die ja auch auf der Festplatte gespeiert werden eigentlich. Vorschaubilder generieren habe ich aus.

    Ja, das müssen wir noch ändern, sodass wenn Bilder in der Steam Library gespeichert werden sollen, sie nicht zusätzlich auf der Festplatte liegen :thinking:


    Gibt es keine Möglichkeit das Minuszeichen-drücken zu entgehen und gleich auf den Standardwert, also keine Lücke, zu kommen?

    Leider gibt es da derzeit keine Möglichkeit :silenced: Du kannst aber die - Taste gedrückt halten. Alternativ könntest du kurzzeitig die Präzision beim Bewegen umstellen (also der "setp" Befehl oder über das Radial Menü) und dort einen hohen Wert wählen (zB 2) - das beeinflusst ja auch, in welchen Schritten der Abstand vergrößert/verkleinert wird.


    Beim Nähern flackern diese Gitter. Ich habe dort keine Lichter aufgestellt.

    Könntest du davon evtl. ein Video posten? :wat: Evtl. wäre dafür aber ein separater Thread sinnvoll ;)

  • Ein weiterer Hotfix ist nun verfügbar! Er bringt ein paar Änderungen und behebt einige Fehler ;)

    Für Multiplayer-Server ist dieses Update optional.


    Hotfix 25.06.2022:

    • [Geändert] Der "hud" Befehl blendet nicht länger die schwarzen Filmbalken aus (falls aktiv)
    • [Geändert] Größe bzw. Kachelung der Ackerboden-Textur angepasst
    • [Geändert] Befehle "rotation", "setp", "setl" und "setr" funktionieren nun auch beim Platzieren von Pflanzen
    • [Geändert] Wenn die Pflanzenwachstums-Dauer in den Einstellungen auf 0 gesetzt ist, wachsen Setzlinge nun innerhalb von 10 Sekunden
    • [Behoben] Fehlende Seiten an Blöcken in bestimmten Situationen behoben
    • [Behoben] Konsolenbefehl "skyrotation" behoben
    • [Behoben] Falsche Schrittgeräusche auf Ackerboden korrigiert
    • [Behoben] Problem behoben, wodurch Setzlinge manchmal nicht auf Ackerboden platziert werden konnten
    • [Behoben] Behoben, dass die Einstellung zur Tiefenunschärfe nicht funktioniert hat
    • [Behoben] Falsche Brennstoff-Kapazität von Schmelzöfen behoben
    • [Behoben] HTTP Fehler beim Senden von Reports behoben
  • Hi Red,

    seit dem Update ist bei mir folgendes Problem aufgetreten:

    Mein Fadenkreuz verschwindet immer, nachdem ich damit auf ein Item gehe, mit dem man interagieren kann, z.B. eine Türe oder auch der Mülleimer etc.

    Dieses kann man dann auch in den Einstellungen nicht mehr anwählen. Und die Blaupausen funktionieren nicht mehr.


    Edit: Jetzt verschwindet das Fadenkreuz scheinbar willkürlich.

    Es grüßt der

    VoodooPanz

  • Mein Fadenkreuz verschwindet immer, nachdem ich damit auf ein Item gehe, mit dem man interagieren kann, z.B. eine Türe oder auch der Mülleimer etc.

    Das ist aber eigenartig :wat: Ich konnte das bei mir leider nicht reproduzieren... tritt das vll i.V.m. einem bestimmten Item auf, welches du in der Hand hälst?


    Und die Blaupausen funktionieren nicht mehr.

    Das ist auch merkwürdig :thinking: Was genau funktioniert denn nicht? Kannst du keine mehr herstellen, oder funktioniert das Platzieren nicht? Falls Letzteres, was genau klappt nicht - fehlt bereits die Vorschau, oder kannst du die Blaupause zwar platzieren, aber sie taucht danach nicht auf?


    Evtl. könntest du sonst einmal einen Report senden. Dazu am besten nachdem dieses Phänomen auftritt die Konsole öffnen und dort "report" eingeben, ggf. noch einen kleinen Hinweis hinzufügen (à la "Blaupausen funktionieren nicht" o.ä) ;)

  • Das ist aber eigenartig :wat: Ich konnte das bei mir leider nicht reproduzieren... tritt das vll i.V.m. einem bestimmten Item auf, welches du in der Hand hälst?


    Das ist auch merkwürdig :thinking: Was genau funktioniert denn nicht? Kannst du keine mehr herstellen, oder funktioniert das Platzieren nicht? Falls Letzteres, was genau klappt nicht - fehlt bereits die Vorschau, oder kannst du die Blaupause zwar platzieren, aber sie taucht danach nicht auf?


    Evtl. könntest du sonst einmal einen Report senden. Dazu am besten nachdem dieses Phänomen auftritt die Konsole öffnen und dort "report" eingeben, ggf. noch einen kleinen Hinweis hinzufügen (à la "Blaupausen funktionieren nicht" o.ä) ;)

    Wenn ich z.B. eine Türe öffne, wechselt das Fadenkreuz ja zum Symbol für die Türe. Ist die Interaktion abgeschlossen, habe ich kein Fadenkreuz mehr und kann es auch nicht in den Einstellungen wieder aktivieren. Ganz im Gegenteil, sogar die Symbole, wie Kreis, Punkt oder eben Fadenkreuz werden mir nicht mehr angezeigt. Auch der Wechsel ins Hauptmenue, um die Map neu zu starten, nützt nur Zeitweise etwas. Was hingegen immer hilft, wenn ich kurz meine zweite Map starte, um dann wieder zur anderen Map zu wechseln. Das funktioniert immer. Oder eben ein kompletter Neustart. Mittlerweile ist es aber leider so. dass mein Fadenkreuz auch mal willkürlich verschwindet. Habe auch schon getestet, ob es an bestimmten Werkzeugen liegen kann, oder wenn ich beim Bauen eine bestimmte Einstellung benutze. Aber es scheint kein System dahinter zu stecken.


    Was die Blaupausen angeht, kann ich diese Herstellen und alles bis zum Speichern so machen, wie es sein soll. Nur nach dem Speichern ist die Blaupause leer. Dieses Problem habe ich erst seit dem Update. Vorher funktionierte es tadellos. Ich werde auf jeden Fall Deinen Rat mit dem Reporten beherzigen. Ich hoffe nur, dass sich nicht herausstellt, dass ich zu dämlich für irgendwas bin:lol:

  • Wenn ich z.B. eine Türe öffne, wechselt das Fadenkreuz ja zum Symbol für die Türe. Ist die Interaktion abgeschlossen, habe ich kein Fadenkreuz mehr und kann es auch nicht in den Einstellungen wieder aktivieren.

    Vielen Dank für die Reports! Das Problem ist, dass scheinbar tatsächlich das letzte Fadenkreuz (welches ja ein bewusst unsichtbares Fadenkreuz ist) ausgewählt ist - daher ist es in dem Fall tatsächlich gewollt, dass das Fadenkreuz nur bei Interaktionen auftaucht und danach wieder verschwindet.


    Dass du es nicht umstellen kannst ist allerdings Seitens des Spiels etwas doof gemacht :saint: Denn am Ende der Fadenkreuzliste fängt er nicht (wie man vll erwarten würde) wieder von Vorne an (das werden wir auf jeden Fall ändern)...

    Du kannst aber mit einem Rechtsklick in die andere Richtung durchblättern, damit solltest du wieder ein normales Fadenkreuz auswählen können :)


    Was die Blaupausen angeht, kann ich diese Herstellen und alles bis zum Speichern so machen, wie es sein soll. Nur nach dem Speichern ist die Blaupause leer. Dieses Problem habe ich erst seit dem Update. Vorher funktionierte es tadellos. Ich werde auf jeden Fall Deinen Rat mit dem Reporten beherzigen. Ich hoffe nur, dass sich nicht herausstellt, dass ich zu dämlich für irgendwas bin :lol:

    Ich fürchte, das ist ein kleines Missverständnis: Die leere Blaupause bleibt bewusst leer nach dem Speichern eines Gebäudes, stattdessen wandert das gespeicherte Gebäude in den Blaupausentisch (dort kannst du es dann erstellen und solltest dann eine richtige Blaupause erhalten). Die leere Blaupause ist also in erster Linie nur zum Speichern da ^^


    Ich gebe aber auch hier zu, dass es durchaus ungünstig ist, dass die leere Blaupause nach dem Speichern nicht verschwindet - das erweckt tatsächlich den Eindruck, dass es nicht funktionieren würde. Auch wäre ein Hinweistext vom Spiel durchaus angebracht. Das werden wir ändern :D

  • Ich gebe aber auch hier zu, dass es durchaus ungünstig ist, dass die leere Blaupause nach dem Speichern nicht verschwindet - das erweckt tatsächlich den Eindruck, dass es nicht funktionieren würde. Auch wäre ein Hinweistext vom Spiel durchaus angebracht. Das werden wir ändern :D

    Ich hab die leere Blaupause germe im Inventar. Finde ich praktischer als mir jedesmal eine neue holen zu müssen. ^^

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!