Changelog 12.03.2019: Neue NPCs, bessere KI, gemoddete Items

  • Meine Spieler haben nach dem Update Probleme auf dem Server, ist das bei euch auch so?


    Quote from Rocky

    moin, hab mal eine frage.Mir ist grade aufgefallen als ich mal wieder in der Stadt war das meine FPS ziemlich in den Keller ging, habe alles runtergeschraubt etc, hat nichts geholfen.Dann fiel mir auf das die Erdblöcke komplett buggen, sie flackern bei mir und zieht die FPS ziemlich runter, habt ihr das Problem auch?Danke im Voraus

    Quote from Blau

    Das mit den flackernden Erdblöcken kann ich bestätigen, fällt am Erdboden neben dem Gewächshaus recht deutlich auf. FPS hatte ich nicht überprüft.


    Man achte bitte unten rechts auf die FPS Anzeige





    Spieler sagt das das die alte Position vom Ofen war und der neue keine Erze drin hat.

  • Ich möchte ebenfalls berichten das insbesondere mit den Texturen der Erdblöcke etwas nicht stimmt. Die Flackern auch auf unserem: Hessenstrolche, so komisch, vor allem wenn man sich bewegt.
    Das ganze sieht so aus als würden sich zwei Texturen überlappen, z.b. wenn man mit Holz baut und man aus versehen z.b. zwei Holzbalken ineinander verschiebt, dann Flackert die Textur der Holzbalken so ähnlich.


    Ich habe dann zuerst versucht die zu entfernen und dann neu zu setzen, und bemerkt das da an einigen Stellen noch Gras zu finden war, also die Pflanzen nicht die Bodentextur: Gras. Ich habe alles nochmal aufgerissen das Gras entfernt, die Löcher aufgefüllt die noch finden waren, ohne Ergebnis. Das flackern der Erdblöcke ist immer noch da. Flackern bei anderen natürlichen Blöcken habe ich bisher noch nicht bemerkt, weil ich die noch teilweise bisher nicht gesetzt habe.


    Auf die FPS hab ich noch gar nicht geachtet, hab das damit jetzt nicht in Verbindung gebracht, dachte aber ich berichte ebenfalls mal über dieses Problem.


    Grüße Andi

  • Kann ich so bestätigen

  • Ein gewisses Flackern/Zittern habe ich beobachtet, als ich weit gereist bin, um einen See zu finden. Ich habe keine Ahnung, ob das schon länger besteht oder mit dem Update zu tun hat, sorry falls ich falsch zuordne. Ich spiele derzeit Singleplayer.


    Als ich endlich einen Salzsee gefunden hatte, ist mir aufgefallen, dass meine Hand mit der Spitzhacke zittert und die Hand sich mit dem Stiel der Spitzhacke vermischt, regelrecht ineinander flackert. Dann habe ich bemerkt, dass auch andere Gegenstände und sogar der Boden zittert. Es hatte definitiv nichts mit Kälteeinfluss zu tun, darauf habe ich geachtet.


    Mit einer Blaupause habe ich mir dann eine kleine Hütte gesetzt, die ebenfalls dauergezittert hat. Ich habe extra darin geschlafen, um den Spawn neu zu setzen und vielleicht so Abhilfe zu schaffen, das Zittern blieb. Auch Ausloggen und neu einloggen hat am Zittern nichts geändert.


    Zum Ursprungsort zurückzuteleportieren (goto 0 0 0) hat dann geholfen, das Zittern war weg.


    Ist das nur ein Entfernungsproblem, d.h. die Welt ist gar nicht unendlich weit spielbar?

  • Dann muss Red das halt fixen, was anderes bleibt da nicht. Dabei bin ich noch nicht mal soooo weit weg vom Spawn ;). Tja da hilft dann nur Geduld, denke ich, es wäre schade wenn ich komplett umziehen müsste, weswegen ich das erst einmal sein lasse. Ich denke wenn Red das hier liest, macht er sich an die Arbeit, oder ist schon dabei. Mit irgend einem Patch oder einem Update wird sich das Problem geben.


    Aber ich werde mal das gleich versuchen was du gemacht hast, um zu sehen, wie weit man vom Spawn entfernt sein darf, damit das Problem nicht auftaucht.


    Grüße Andi

  • Spieler sagt das das die alte Position vom Ofen war und der neue keine Erze drin hat.

    Oh, das ist eigenartig =O Das schaue ich mir nochmal genauer an!


    Ich möchte ebenfalls berichten das insbesondere mit den Texturen der Erdblöcke etwas nicht stimmt. Die Flackern auch auf unserem: Hessenstrolche, so komisch, vor allem wenn man sich bewegt.

    Das stimmt, das ist leider ein Bug, der das "schwarze Flackern" bei den Erdblöcken verursacht. Man wird das Geflackere los, indem man in der config "graphic_blocktexture_grain" ausschaltet, aber ich werde das Problem so bald wie möglich beheben ;)


    Ein gewisses Flackern/Zittern habe ich beobachtet, als ich weit gereist bin, um einen See zu finden

    Das ist leider noch ein anderes Phänomen: Tatsächlich ist die Welt nicht wirklich unendlich groß, stattdessen ist zwar die Welt-Generierung nicht begrenzt (d.h. es werden immer neue Chunks generiert, je weiter man reist), doch man wird früher oder später mit Rundungsfehlern (oder genau genommen mit Gleitkommaungenauigkeiten) konfrontiert - was sich in erster Linie durch "Z-Fighting" bemerkbar macht (zB Flackern von sich überlappenden Bauteilen) sowie durch "Zittern" des Items in der Hand. Die Probleme treten meist auf, wenn man sich mehr als 10.000 Blöcke vom Weltursprung (Koordinate 0 0 0) entfernt hat, und werden ab dem Punkt immer schlimmer (d.h. der halbwegs vernünftig bespielbare Bereich ist max. 10-20k Blöcke vom Weltursprung entfernt, in alle Richtungen).


    Eine "wirklich unendlich große Welt" zu haben ist zwar geplant, leider kann ich noch nicht sagen, wann genau das umgesetzt wird ;)

    • Du kannst auf einem Multiplayerserver davon ausgehen, wenn es überhaupt erlaubt ist, dass sich die Spieler entweder wie am Strand Handtuch an Handtuch, am besten noch übereinander ausbreiten, oder sie ziehen weitab vom Schuss um ihre Ruhe zu haben. Das Flackern war früher ab 8k Entfernung gegeben und auch weitaus schimmer als heute, so dass jedes Poster wie wild geflackert hatte. Wenn das jetzt wieder so ist, ist dann irgendeine Einstellung zurückgeändert worden? Ich gehe von goto 10.000 0 10.000 aus, ka ob das 10.000 Blöcken entspricht. Ich habe seit damals die Einstellung "graphic logarith buffer = true", die mir und anderen Spielern sehr geholfen hat. Mittlerweile flackert es wieder mehr, aber vielleicht hilft die Einstellung einigen Spielern bis zum Bugfix. Ich denke allerdings nicht, dass das bei Erdblöcken hilft. Ich kann nur von Gebäuden usw. sprechen, beim Terrain ist das bisher nicht aufgefallen.
    • Anscheinend fehlt der Seismograph um die Erschütterung genau zu messen. :D
    • Ich habe seit damals die Einstellung "graphic logarith buffer = true", die mir und anderen Spielern sehr geholfen hat. Mittlerweile flackert es wieder mehr, aber vielleicht hilft die Einstellung einigen Spielern bis zum Bugfix.

    Danke, Deirdre, für diesen Tipp :thumbsup: Das Zittern ist noch vorhanden, aber die Hand "vermischt" sich nicht mehr mit dem Stiel der Geräte, daher auf jeden Fall eine Verbesserung! <3


    Ich werde eine andere Himmelsrichtung versuchen, vielleicht habe ich da ja mehr Glück :D

  • komisch schon. Ich finde das es nach den Hotfixes etwas besser geworden ist.
    Was ich habe ist das er beim joinen generell bei 98% erstmal stehen bleibt bis ich dann auf der Welt bin. Nur wenn ich länger fliege muss ich auch mal eine kurze Pause machen damit alles nachgeladen werden kann aber das hatte ich vorher auch schon. Ist schon komisch wie sich das alles so unterschiedlich äußert.
    Die Frage die sich dann immer stellt, liegt es nun am PC oder am Server oder ist es die Leitung

  • Das ist die Frage. Serverinfomemory war im grünen Bereich und der Hauptserver auch. Ich habe 50k Leitung, zwar nicht mehr den neuesten Pc, aber bei anderen Spielen habe ich keine Probleme.
    Das Problem tritt nur nach dem Teleportieren auf und neuerdings erscheint ab und zu auch die Meldung "Server sollte neugestartet werden" . Das gab es früher auch nicht

  • also eine Meldung das der Server neu gestartet werden solle ist mir neu. Aber wir haben auch 4 Neustarts pro Tag. Könnte daran liegen.


    Denke nicht das man es mit anderen spielen vergleichen kann. Wenn dann sollte man ähnliche Spiele nehmen die auch die gleiche Engine zb benutzen. alles andere wäre glaube ich etwas unfair, dann einfach zu sagen anderes läuft ja auch. Aber das an der Performence noch was nachgebessert werden sollte stimme ich auch zu.


    Hier mal eine aufzählung von Spielen mit der gleichen Enigen

  • nehmen wir meine megabauten und den dom. ich konnte immer mit meiner pc leistung (auch mit meinem alten pc noch) ganz normal um die gebäude kreisen
    und auch hinein gehen. egal wieviel verbaut wurde. andere dagegen die einen sehr schwachen pc haben bekommen schon in der nähe der bauten probleme und fliegen sogar aus dem spiel.
    ich wollte nun da es ja nun wieder möglich ist die blueprints neu zu setzen und auch zu löschen die halle des volkes weiter bauen. aber wie gesagt. es laggt unerträglich und stoppt sogar
    zum nachladen das spiel (friert ein) für einige sekunden und ich befinde mich dann auch in einer ganz anderen stellung.

  • Der Text wegen neu starten taucht nur auf wenn der Server länger wie 24 Std läuft und kann nur von Admins gesehen werden.

    das erklärt warum ich das nie sehe. Da der Server ja mehrmals neu gestartet wird.
    @Deirdre dann mal am besten schauen, was bei euch die Neustarts machen.

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!