Changelog 2017-04-20: Ingame map, dungeon, new content

  • Hello,
    Since the update my server is not coming back. Below is the error log. Then it stops the server. please advise


    Rising World - 0.8.2.2 - Dedicated ServerLinux 4.10.0-20-generic Java 1.8.0_121 (amd64) Memory: 28631 MB2017/04/29 04:53 AM Start context...Items initialized!Plants initialized!NPCs initialized!Initialize Static Classes...Constructions initialized!Objects initialized!Picking initialized!Food-Definitions initialized!Crafting-Definitions initialized!Record-Definitions initialized!read bytes from resource: 354read bytes from resource: 11417read bytes from resource: 7342read bytes from resource: 5351read bytes from resource: 32120Initializing world (sqlite)LOAD WORLD DAY [ONE]DATABASE TYPE: SQLite/1466/Worlds/DAY [ONE]:::DAY [ONE]CREATE WORLD STRUCTURE - DONE!2017/04/29 04:53 AM x.aINFO: DatabaseTaskManager started with ThreadPoolSize 1WORLDINFO Gamemode: SurvivalGametype set to SurvivalWORLDINFO Seed: 1464316058742WORLDINFO Caves: trueWORLDINFO Vegetations: trueWORLDINFO OreAmount: 3WORLDINFO DisabledNPCs: WORLDINFO DisabledDungeons: WORLDINFO DisabledWaterSources: WORLDINFO Worldtype: NormalWORLDINFOS seed: 1464316058742 type: Normal caves: true vegetations: true oreamount: 3 disablednpc: [] disableddungeons: [] disabledwatersources: []WORLDINFO Time: 18.6.32 7:47:0.83410245set game time from string: 18.6.32 7:47:0.83410245WORLDINFO Creationdate: 1464316058742WORLDINFO Version: 0.8.2.1_34TRIGGER UPDATEWorldconverter: Updating (34) to version (35) 0.8.2.2 ...Creating world backup...FAILED!Worldpart generating...Biomepart generating...Loaded Biomepart from cache: 0 - 0 (3ms)Loaded Worldpart (v2) from cache: 0 - 0 (241ms)Convert to 35...Deleting old cache files...Delete all cache files...Cache files deleted!read bytes from resource: 11417read bytes from resource: 7342read bytes from resource: 5351read bytes from resource: 32120Worldpart_v32 generating...Biomepart generating...Biomepart (2) generated: 0 - 0 (1ms)

  • Since the update my server is not coming back. Below is the error log. Then it stops the server. please advise

    Maybe create a new topic and post a full serverlog there (can be found in the "Logs" subfolder in your server directory). According to the log snipped you posted, the server was still converting the world.


    A quick test confirmed that all the rotation modes now work as expected.

    Thanks for the feedback :)


    It indeed appears that the dungeons in our "old world" are fixed!

    Thanks for letting me know, glad to hear they're fixed now :thumbup:

  • Just started up today on 0.8.2.2_35. The flickering of the plank element is gone, though now there are some seams visible when you look at them from different positions. That's OK, way better! The posters also are much improved. They don't flicker much only a few flickers when moving around but it's 95% better! So GREAT! Massive improvement there—and I didn't have change anything.


    Rotation control key glitch also fixed perfectly! Thanks!!!! :thumbsup:

  • I've noticed that this occurs when there is a collision of a corner of an object that is being rotated with an object that is already fixed on the map. The collision moves the object (beam or plank) repelling the other to a zone without contact between the objects, something like "2 bodies do not occupy the same place".


    It's strange, it looks like a retarded movement repelling only when we press the ctrl to fit the next beam.


    It's still happening in my game.

  • The flickering of the plank element is gone, though now there are some seams visible when you look at them from different positions [...] The posters also are much improved. They don't flicker much only a few flickers when moving around but it's 95% better!

    Thanks for the feedback! :) We still have to adjust the rendering order, since the current behaviour apparently leads to situations where it acts strangely (planks hidden behind terrain etc). Probably there will be another hotfix tomorrow (or on Monday), please let me know if the situation either improves or worsens (since this adjustment requires a lot of finetuning to find the right balance between "reduce flickering" and "render correctly")^^


    It's still happening in my game.

    Hmm... so you still encounter the rotation issues? =O Does it make a difference if you change the rotation mode (local, world, legacy)? Can you maybe post a screenshot or a video of this issue (that would be very helpful)?

  • @WalterDasTrevas: Thanks for the video :thumbup: However, I'm still not sure what you mean exactly 8| Currently construction elements have a "bounding check", so if they intersect with a wall (while placing), the construction element will be pushed away from the wall (only the preview of course). Do you mean that?

    0:19 and 0:34 - Those movements were automatic, I did not spin the beam to the right, but I had to correct rotating to the left.
    The movement was soft, did not change much the position of the beam, but I believe that when the rotate velocity is bigger, the involuntary movement becomes larger, and the player needs to rotate to the left to correct.


    But it's only happening in legacy mode. As I moved to the "local rotation", I'm no longer having a problem. :)

  • @WalterDasTrevas: Thanks for the video! Seems to be related to some other issues (saloondoors etc), still looking into this issue, but I think this will only be fixed with the next regular update.


    -------------------


    A new hotfix is now available (0.8.2.3) which is supposed to finally fix the world generation issues. Server admins have to update their servers accordingly.
    This hotfix also fixes some bugs and introduces some changes. If you still experience any issues, please let us know.



    Changelog 2017-05-01:

    • [New] Added white wood texture
    • [New] Added new music track
    • [Change] Adjusted alignment of some textures
    • [Change] Slightly changed appearance of underground dungeon room
    • [Change] Updated "aggro" range of some animals
    • [Change] Rabbits, foxes, penguins and deers escape from the player again
    • [Change] Removed some unnecessary debug output
    • [Bugfix] Fixed messed up worlds since latest hotfix (0.8.2.2)
    • [Bugfix] Fixed "undoblueprint" command not always removing all blocks
    • [Bugfix] Fixed map rendering issue (missing blocks/planks which are placed slightly above terrain)
    • [Bugfix] Fixed rendering issue of planks ("invisible circle")
    • [Bugfix] Fixed some API events
  • A quick test confirmed that all the rotation modes now work as expected.
    Thanks @red51!

    What are the rotation modes? how you change them? Is there any doco on it?


    I find hard to find a place where all the documentation is: there are forum posts on server.permissions, for instance, but it is all over the place.


    Perhaps a top level pinned post with links to the several post where all the commands, settings, etc are would be a good start :)

  • What are the rotation modes? how you change them? Is there any doco on it?
    I find hard to find a place where all the documentation is: there are forum posts on server.permissions, for instance, but it is all over the place.


    Perhaps a top level pinned post with links to the several post where all the commands, settings, etc are would be a good start :)

    Greetings!
    You need to open the console and type "setr 1" and "setp 1", "p" = position and "r" = rotation. All without quotes!


    The higher the number, the higher the speed and the lower the accuracy.


    The default is "setr 15" and "setp 15".
    ________________________________________________________________________________________________________________________________________________


    To move the beams, logs and planks accurately, you first choose the angle by using the "arrows", "page up" and "page down", then you fix the beam temporarily using the "right ctrl" and use the arrows and "page up" and "page down" to choose the position.


    Shift + arrows changes width and length.


    May seem a bit confusing at first, but you will realize that creative freedom becomes almost infinite with such options. Together, I recommend these plugins:


    https://forum.rising-world.net/thread/5618-plug-in-planks-n-beams-with-any-built-in-texture/


    https://forum.rising-world.net/index.php/Thread/2498-Script-World-edit
    _______________________________________________________________________________________________________________________________________________________________________


    In the future, everything will probably be simpler, but for now you have to master those options, but I guarantee it's worth it if you're creative and like to build.


    I built this abandoned cabin using only beams on the structure and planks on the roof.:

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!