Hilfe, komme nicht mehr auf den Server

We've posted a status update with some first screenshots of the new terrain generation. There is also a new update available for the Java version!

  • Hilfe, komme nicht mehr auf den Server

    Ich komme nicht mehr auf den Deutschland Spielt 2 Server, bei anderen Servern habe ich keine Probleme.
    Ich hänge fest, habe Windows Ladekringel, ab und zu kommt mal kein "Rising World reagiert" nicht, aber kann keinen Chateingabe machen,
    keine Konsole öffnen, einfach gar nichts mehr.


    Der 2. Log ist der mit dem Rasentrimmer. Dieser funktioniert 1 x, dann nicht mehr, auf Spitzhacke gewechselt, dann geht es wieder
    nur 1 x, beim 3. x Wechseln funktionierte der Trimmer überhaupt nicht mehr.
    Files
    • 1552492541.log

      (121.2 kB, downloaded 6 times, last: )
    • 1552493548.log

      (25.76 kB, downloaded 4 times, last: )
  • Danke für die Logs! Darin ist auf dem ersten Blick eigentlich nichts Ungewöhnliches festzustellen ?( Allerdings scheint es so, dass es extrem viele Tiere gibt. Wenn ich das richtig sehe, sind es um die 100.000 Tiere =O Diese müssen beim Spawn erstmal übertragen werden, was den Ladevorgang teilweise spürbar verlangsamen kann. Und auch die allgemeine Serverperformance leidet ein wenig darunter. Es wäre ggf. eine Überlegung wert, einmal alle Tiere zu löschen - seit dem Update werden die Tiere dann ja eh wieder neu spawnen. Ärgerlicher wäre das nur bei speziellen Tieren oder Dummys, die an bestimmten Stellen gespawnt wurden, dann die wären leider auch futsch...

    Ansonsten könntest du ggf. auch probieren, einmal die Sichtweite zu reduzieren bzw. vor allem die Detail Sichtweite. Setze das am besten einmal aufs Minimum und versuche zu connecten. Falls du dann drauf kommst, kannst du die Sichtweite wieder hoch stellen.

    Was den Rasentrimmer angeht: Was genau funktioniert denn nicht? Hörst du keinen sound, spielt die Animation nicht mehr ab, oder mäht er nur kein Gras? Ist es denn immer so, dass er nach 1x Benutzen nicht mehr funktioniert? Spielt es denn eine Rolle, wie lange du ihn verwendest hast? Oder ist auch eine ganz Kurze Benutzung schon ausreichend dass er nicht mehr geht? Funktioniert denn der Minenbohrer noch? Der ist vom eng verwandt mit dem Trimmer. Wichtig ist, dass du nach der Verwendung des Trimmers und der erneuten Versuchs die Maustaste etwas gedrückt hälst (manchmal dauert es 1-2 Sekunden, bis er "anläuft").
  • Ich habe nicht gesagt, dass andere Leute den Server nicht betreten können. :)


    Wir waren zum Testen zu zweit in meinem Gebiet und wir konnten uns beide nicht mehr bewegen. Die andere Person konnte noch mit Hängen und Würgen den
    Chat benutzen, bei mir ging gar nichts mehr.

    Ich war heute Morgen auch auf dem Server, in einem anderen Gebiet, hatte dabei keine Schwierigkeiten, habe mich dann zum besagten Teleport teleportiert und dann war Ende. Das ging vor dem Update einwandfrei, zwar mit einigen Lags wegen den vielen Einzelteilen aber ein Joinen bzw. Teleportieren zu diesem tp war möglich.



    red51 wrote:

    Danke für die Logs! Darin ist auf dem ersten Blick eigentlich nichts Ungewöhnliches festzustellen Allerdings scheint es so, dass es extrem viele Tiere gibt. Wenn ich das richtig sehe, sind es um die 100.000 Tiere Diese müssen beim Spawn erstmal übertragen werden, was den Ladevorgang teilweise spürbar verlangsamen kann. Und auch die allgemeine Serverperformance leidet ein wenig darunter. Es wäre ggf. eine Überlegung wert, einmal alle Tiere zu löschen - seit dem Update werden die Tiere dann ja eh wieder neu spawnen. Ärgerlicher wäre das nur bei speziellen Tieren oder Dummys, die an bestimmten Stellen gespawnt wurden, dann die wären leider auch futsch...


    Wie würde ich diese Tiere denn generell löschen? Ich habe ein paar Minipets, ein paar Schweine, Pferde, Hühner und 2 oder 3 Esel. Meine Tiere sind noch zählbar. Ich habe auch nicht überall in der Welt Tiere spawnen lassen. Wo diese riesige Zahl von Tieren herkommt, ist mir ein Rätsel.

    Ich habe einige NPC's aber 100.000 habe ich ganz sicher nicht. ^^




    Ansonsten könntest du ggf. auch probieren, einmal die Sichtweite zu reduzieren bzw. vor allem die Detail Sichtweite. Setze das am besten einmal aufs Minimum und versuche zu connecten. Falls du dann drauf kommst, kannst du die Sichtweite wieder hoch stellen.


    Mit Detailsichtweite 3 kam ich innerhalb kurzer Zeit auf den Server. Allerdings fangen die Mukken schon bei Detailsichtweite 15 an.
    Ich kann dann gar nichts nichts mehr machen.
    Wurde die Performancevoraussetzungen jetzt dermaßen angehoben? Ich sende nochmal die Logdatei. Es steht dabei Rising World Launcher reagiert nicht mehr, also Spiel über Taskmanager beenden.


    An anderer Stelle kann ich mit maximaler Detailsichtweite herumlaufen, verstehe nicht, warum das plötzlich nicht mehr geht. Ich habe dort nichts gebaut und auch nichts verändert.




    Was den Rasentrimmer angeht: Was genau funktioniert denn nicht? Hörst du keinen sound, spielt die Animation nicht mehr ab, oder mäht er nur kein Gras? Ist es denn immer so, dass er nach 1x Benutzen nicht mehr funktioniert? Spielt es denn eine Rolle, wie lange du ihn verwendest hast? Oder ist auch eine ganz Kurze Benutzung schon ausreichend dass er nicht mehr geht? Funktioniert denn der Minenbohrer noch? Der ist vom eng verwandt mit dem Trimmer. Wichtig ist, dass du nach der Verwendung des Trimmers und der erneuten Versuchs die Maustaste etwas gedrückt hälst (manchmal dauert es 1-2 Sekunden, bis er "anläuft").


    Er reagiert vielleicht etwas zögerlich.
    Was mir am Trimmer aufgefallen war, ist, dass ich am Anfang sofort ein großes Rasenstück abmähen konnte, was danach nicht mehr möglich war.
    Wahrscheinlich muss man sich auf eine sehr lange Zeit zum Trimmen einstellen. :)
    Der Minenbohrer funktioniert einwandfrei.
    Files
    • 1552513242.log

      (85.19 kB, downloaded 2 times, last: )
  • hab das selbe problem, kann meine städte nicht mehr betreten, FPS fallen auf 0 - mit einer detailsichtweite von 5 gehts, (macht aber keinen spass). kein unterschied zwischen sp u. server

    wie der screenshot zeigt - weder cpu, ram noch gpu sind überfordert.

    hab noch etwas interessantes entdeckt - beams&planks in tieren verbaut führen zu 0 fps - (vielleicht stecken bei uns ja noch irgendwo tiere in den wänden oder sonstwo die diese massiven FPS einbrüche verursachen?
    an den beiden screenshots mit dem esel kann man gut sehen wie die fps droppen bzw wieder hochgehen wenn man zu nahe kommt bzw. sich wieder etwas entfernt.

    werde jetzt mal alle npcs in der welt löschen und schauen was dann passiert.

    filehosting.at/file/details/776388/RWpublic.rar - hab hier meine welt hochgeladen, inc. poster u. teleportstationen falls das vielleicht hilft
    Files

    The post was edited 1 time, last by dagoline ().

  • @dagoline: Danke für die Tests und Infos! Das Problem scheint tatsächlich mit NPCs zusammenzuhängen, vor allem in Gegenden, in denen viel gebaut wurde. Das liegt wohl daran, dass das NPC Verhalten (sowie Kollisionserkennung etc) nun wesentlich komplexer ist als vor dem Update (daher gabs vorher keine Probleme in der Richtung)... ich arbeite an einer Lösung dafür, ich hoffe, sie wird heute Abend noch fertig sein, ansonsten spätestens morgen! :)
  • red51 wrote:

    Ich baue im nächsten Hotfix einen Command dafür ein Alternativ kann in der Welt-Datenbank die Tabelle "Npc" manuell gelöscht werden (der Server sollte dafür aber nicht laufen). //edit: Da war dagoline wohl schneller als ich
    oh man, da hätte ich auch selber drauf kommen können :saint:

    ==Hessenstrolche==

    Teamspeak 3: 185.239.238.125:9987 / Rising World Server:185.239.238.125:4255
    Homepage / Discord / FB-Gruppe
  • lenko wrote:

    Das erklärt dann auch meine niedrige FPS

    Wie bitte kann ich auf einer Map alle Tiere und NPS töten ?
    ich würde mit dem löschen aber noch warten, gib @red51 etwas zeit für ein hotfix, wenns nicht klappt kann man immer noch löschen ;)

    ich weis ja nicht wieviel npcs ihr auf eurem server verbaut habt - bei mir sind pferde und esel im geschirr eingespannt, dummys halten körbe, angeln usw. ich möchte die npcs nur ungern löschen da das sehr viel arbeit verursachen würde und f7 beim entfernen der herrenlosen körbe geschirre, usw. wohl mehr schaden als nutzen bringen würde.
  • ich teste das jetzt alles. die Map mal in den Einzelplayer und 50000 NPC´s löschen 8|

    Also alle NPC´s gelöscht und oh wunder es läuft , kaum werden in einem Bereich 30 Hühner gesetzt FPS wieder im Keller

    ==Hessenstrolche==

    Teamspeak 3: 185.239.238.125:9987 / Rising World Server:185.239.238.125:4255
    Homepage / Discord / FB-Gruppe

    The post was edited 1 time, last by lenko ().

  • Der neueste Hotfix (0.9.5.3) sollte die Performanceprobleme im Zusammenhang mit NPCs jetzt eigentlich beheben ;) Natürlich haben NPCs weiterhin einen Einfluss auf die Performance (wenn also irgendwo 100 NPCs sind ist die Performance spürbar schlechter als wenn niemand da ist), aber zuvor waren die Performanceprobleme ja teilweise sehr massiv - tatsächlich bis in Richtung 0 FPS. Das sollte jetzt eigentlich nicht mehr der Fall sein. Falls es doch Probleme gibt, lasst es mich bitte wissen :)

    Zusätzlich gibts nun übrigens auch den Befehl deleteallnpcs, womit sämtliche NPCs gelöscht werden können. Auf manchen sehr alten Welten tummeln sich manchmal extrem viele Tiere, teilweise stecken diese im Boden, fliegen in der Luft oder leben irgendwo tief unter der Erde (weil sie damals mal irgendwann durch den Boden fielen). Wenn man eine sehr alte Welt hat und auf die bestehenden NPCs verzichten kann, könnte man mit dem Befehl etwas den Client (und Server im MP) entlasten. Durch die Respawn-Mechanik sollte sich die Tierpopulation dann wieder von alleine erholen ^^