Update 0.4: Crafting, Schmelzen und viele neue Items

A big new update is now available, introducing biomes, caves and much more!
Latest hotfix: 0.7.0.3 (2024-02-21)
  • Steine finde ich gut. ^^. Ich fände es nur etwas unpraktisch einen Berg abzufragen und die Überreste dann nochmal manuell zu entfernen. Möglicherweise habe ich noch Horrorvisionen von damals, als ich einen riesigen See vergrößert habe und danach überall Pflanzen in der Luft hlngen und es keine Möglichkeit zum Entfernen gab. Ich glaube ich habe bis zum heutigen Tag nicht alle entfernt. :D

    Das Extrem ein Gebirge komplett abzufragen, werden die wenigsten nutzen, aber Terrainmodellisten gibt es sicherlich auch. ^^ Im Multiplayer muss ein Spieler das ihm zugewiesene Gebiet akzeptieren, aber nicht immer ist es für ihn gleich perfekt und er hätte gerne Änderungen. Ich persönlich habe Stunden mit dem Verschönern von Spielergebieten verbracht und je mehr Luxus an Werkzeugen dafür zur Verfügung steht, desto besser.


    Also um solche massiven Änderungen vorzunehmen kannst du ja das Terraintool nutzen. Steine oder Erze die in der Luft hängen fallen nach unten (wie auch Bäume) und gehen kaputt. Und alles was evtl doch hängen bleibt, warum auch immer, kannst du ziemlich easy mit dem Löschwerkzeug entfernen. Aber ich glaub nicht das da was übrig bleibt.

  • Windows 10 (10.0.22000) 64bit (Desktop) Direct3D 11.0 [level 11.1]

    AMD Ryzen 7 3700X 8-Core Processor , 16 Cores, 3593 MHz

    System Product Name (System manufacturer) 16294 MB RAM

    NVIDIA GeForce RTX 3060, 12138 MB VRAM, 2021-11-09, 30.0.14.967

    Commit: 4646ed012429e6b6dfd755946082dbdaeb590243

    Branch: master JobID: 6446

    ------------------------------------------------------------------------------------------

    UnauthorizedAccessException - Access to the path "D:/Program Files/Rising World/RisingWorld-NewVersion/config.properties" is denied.

    at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share, System.Int32 bufferSize, System.Boolean anonymous, System.IO.FileOptions options) [0x00000] in <00000000000000000000000000000000>:0

    at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share, System.Int32 bufferSize, System.IO.FileOptions options) [0x00000] in <00000000000000000000000000000000>:0

    at System.IO.StreamWriter..ctor (System.String path, System.Boolean append, System.Text.Encoding encoding, System.Int32 bufferSize) [0x00000] in <00000000000000000000000000000000>:0

    at System.IO.File.WriteAllText (System.String path, System.String contents) [0x00000] in <00000000000000000000000000000000>:0

    at RisingWorld.Common.Properties.SaveAllOptions (System.Boolean includeComments, System.String name, System.String propertiesFile) [0x00000] in <00000000000000000000000000000000>:0

    at RisingWorld.Content.Game.InitDefaultSettings () [0x00000] in <00000000000000000000000000000000>:0

    at RisingWorld.Content.Game.OnInitialize () [0x00000] in <00000000000000000000000000000000>:0

    at RisingWorld.Common.JIWApplication.Update () [0x00000] in <00000000000000000000000000000000>:0

  • Mir ist ein kleiner Fehler aufgefallen, der seit dem Crafting-Update dazu gekommen zu sein scheint, da es davor noch funktionierte.


    Ich kann ja in den Einstellungen bestimmen, ob die Kategorien beim Crafting von sich aus alle eingeklappt sind, oder halt nicht - Momentan ist es egal, was ich da auswähle, es ist immer alles ausgeklappt (Egal, welche Werkbank, ob Crafting-Menü am rechten Bildschirmrand im Invenrar, oder über Shortcut "E" - Und wenn ich die Kategorien einklappe und das Craftingfenster schließe, ist beim nächsten Öffnen des Craftingfensters auch wieder alles ausgeklappt.

  • Ich kann ja in den Einstellungen bestimmen, ob die Kategorien beim Crafting von sich aus alle eingeklappt sind, oder halt nicht - Momentan ist es egal, was ich da auswähle, es ist immer alles ausgeklappt (Egal, welche Werkbank, ob Crafting-Menü am rechten Bildschirmrand im Invenrar, oder über Shortcut "E" - Und wenn ich die Kategorien einklappe und das Craftingfenster schließe, ist beim nächsten Öffnen des Craftingfensters auch wieder alles ausgeklappt.

    Wurde schon von red beantwortet, siehe hier: Bugs in 0.4

  • Möglicherweise habe ich noch Horrorvisionen von damals, als ich einen riesigen See vergrößert habe und danach überall Pflanzen in der Luft hlngen und es keine Möglichkeit zum Entfernen gab. Ich glaube ich habe bis zum heutigen Tag nicht alle entfernt.

    Ja, das war damals tatsächlich ein großes (und auch nerviges) Problem... :/ Dafür ist es in der neuen Version ja so, dass Pflanzen, die keinen Kontakt mehr zum Boden haben, *eigentlich* automatisch umfallen bzw. verschwinden sollten. Dafür muss in den Einstellungen unter Verschiedenes "Pflanzen von Schwerkraft beeinflussen" aktiviert sein (sollte standardmäßig aktiv sein).


    Ich vermisse Schilder. Wann kann man damit rechnen dass diese ins Spiel kommen.

    Ich kann leider noch keinen genauen Zeitpunkt dafür nennen... möglicherweise werden Schilder wohl erst nach dem Welt-Generierungs-Update kommen :silenced:


    UnauthorizedAccessException - Access to the path "D:/Program Files/Rising World/RisingWorld-NewVersion/config.properties" is denied.

    Hmm... das sieht auf dem ersten Blick so aus, als würde irgendwas das Spiel daran hindern, auf die config.properties Datei zuzugreifen :thinking: Tritt das bei jedem Spielstart auf? Was für ein Antiviren-Programm verwendest du?

  • Mit welchen Commands kann ich die Texturskalierung verändern? Ich nutze das Radialmenü nur für diese Funktion, würde das aber lieber über die Konsole machen.

    Bei gesetzten Steinen mit dem Mauszeiger drauf zielen und mit dem Command


    edit texturescale 1


    1 ist die Standartgröße


    Ich meine aber, wenn Du den Block noch in der Hand hast, dann müsste der Befehl einfach nur


    texturescale 1


    heißen - Zur Not versuchen - Hilfsvorschläge macht das Spiel ja automatisch

  • Hmm... das sieht auf dem ersten Blick so aus, als würde irgendwas das Spiel daran hindern, auf die config.properties Datei zuzugreifen :thinking: Tritt das bei jedem Spielstart auf? Was für ein Antiviren-Programm verwendest du?

    Ich verwende AVG. Dieses Problem kommt immer. Ich habe es aber jetzt so Einstellt, dass es immer mit Adminrechte starten soll. Dann funktioniert es.

  • Hallo red51 ,


    Virenscanner habe ich nun testweise deaktiviert, kommt aber die selbe Fehler raus.

    Wenn ich das Spiel als Admin starte, startet das Spiel, aber alles ist in Englisch.


    Leider hat er das Problem, immer auf die Config zuzugreifen. Ich nutze Win11 und habe sowohl die Steam-Version als auch die Standalone.

    Ich empfehle, für die Standalone eine Setup.exe zu machen, damit das Spiel als "vertrauenswürdiges registriertes Programm" installiert wird.

    Sonst bekommt das Standalone Probleme mit den Windows-Berechtigungen.


    EDIT: Probleme mit der Sprache tritt nicht auf, wenn man das Spiel ohne Launcher startet ( + Adminrechte).

    Also nicht: Rising World Launcher.exe

    Sondern: Rising World.exe

  • Wenn ich das Spiel als Admin starte, startet das Spiel, aber alles ist in Englisch.

    Ist in der config.properties Datei evtl. neben Game_Language "english" oder "en" oder so eingetragen? Standardmäßig sollte das Feld leer sein, dann sollte die Standalone eigentlich die Systemsprache verwenden :thinking:


    Leider hat er das Problem, immer auf die Config zuzugreifen. Ich nutze Win11 und habe sowohl die Steam-Version als auch die Standalone.

    Ich empfehle, für die Standalone eine Setup.exe zu machen, damit das Spiel als "vertrauenswürdiges registriertes Programm" installiert wird.

    Sonst bekommt das Standalone Probleme mit den Windows-Berechtigungen.

    Ich habe mal testweise Windows 11 installiert, aber leider konnte ich das Problem bei mir nicht reproduzieren :wat: Unter welchem Pfad ist das Spiel denn abgelegt? Falls es entweder unter "Programme" oder auf dem Desktop liegt, dann könnte es evtl. daran liegen, weil Windows für diese Ordner schon immer spezielle Berechtigungen erwartet...


    Ein Setup zumindest für den Launcher könnten wir anbieten, aber ich weiß nicht, ob Windows es dadurch bereits als "vertrauenswürdig" einstuft... vielmehr würde hier wohl eine Signierung der exe helfen, das ist aber mit laufenden Kosten verbunden (also jährliche Zahlungen, die wir für das Zertifikat leisten müssten)... ||


    Gibt man im Multiplayer Suchfeld den Servernamen oder die IP ein, ist diese schwarz, d. h. fast nicht mehr lesbar.

    Das ist leider durch ein Update der Unity Version (genauer genommen von "UI Toolkit", also deren neues UI Framework) zustandegekommen (genau wie ein paar andere unerwartete Änderungen)... das werden wir mit dem nächsten Update beheben ;)


    Es wäre gut, wenn bei HUD-Einstellung das Raster auch unsichtbar wäre. ^^

    *Eigentlich* etwas irreführend, da das Raster ja nichts mit dem HUD zutun hat, aber natürlich kann ich schon verstehen, warum das Sinn machen würde... ich packe das mal auf die Liste ^^

  • Ich habe mal testweise Windows 11 installiert, aber leider konnte ich das Problem bei mir nicht reproduzieren :wat: Unter welchem Pfad ist das Spiel denn abgelegt?

    Es war unter D:\Programme\Rising World.

    Hab des nun in D:\Rising World verschoben. Es funktioniert jetzt normal.


    :!:An alles Windows-Benutzer mit Standalone: Das Spiel nicht in den "Programme"-Ordner installieren. Dort funktioniert das Spiel nicht.

  • Es war unter D:\Programme\Rising World.

    Hab des nun in D:\Rising World verschoben. Es funktioniert jetzt normal.


    :!:An alles Windows-Benutzer mit Standalone: Das Spiel nicht in den "Programme"-Ordner installieren. Dort funktioniert das Spiel nicht.

    Ich habe keine Standalone, aber D ist normalerweise nicht die Standard Festplatte, sondern C. Es könnte ja auch daran liegen.

    Ich habe nämlich auch Programme, die auf anderen Festplatten, außer C, Probleme machen.

  • wie geht es mit Blueprint-Update voran? Gibt es bereits Neuigkeiten dazu? :saint:

    Grundsätzlich funktionieren die Blaupausen schon recht gut ;) Es fehlt noch Feinschliff sowie diverse Optionen um Blaupausen zB nachträglich umzubenennen usw. Was aber recht zeitaufwändig ist ist das Herstellen der Kompatibilität mit Java Blaupausen... vor allem auch passende Ersatztexturen für alte Java Blaupausen zu finden. Das ist leider auch noch nicht ganz abgeschlossen... wir können mittlerweile zwar Java-Blaupausen laden, aber die Texturen fehlen noch :drunk:

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!