Changelog 2018-09-26: Fishing, boats and more!

  • Red one bug I have found with motorboat. I can get it to crash to desktop (the client). While in water mostly partially on land at waters edge, hop out of boat, then try to access engine while swimming to ride again. I find I can reproduce it more often if I fly. many times it will crash my client with the following java report: Error occurred during application-update (25)
    java.lang.NullPointerException
    at D.A.b(SourceFile:919)
    at D.A.a(SourceFile:911)
    at aD.n.a(SourceFile:196)
    at w.g.update(SourceFile:289)
    at com.jme3.app.state.AppStateManager.update(AppStateManager.java:287)
    at commons.JIWApplication.update(SourceFile:342)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:151)
    at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:198)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:232)
    at java.lang.Thread.run(Unknown Source)


    THEN when I log back in, the engine won't start. I can hop in the drivers seat, but engine wont start nor will boat move. Making a new boat works fine. Boat I crashed on will not.


    Also a suggestion: render distance of boats is minimal, could you increase that a bit? You need to be close to them for it to render.

    "The past is history, the future a mystery, but today is a gift, which is why we call it the Present."

    Edited 3 times, last by Juggernaut ().

  • Red one bug I have found with motorboat. I can get it to crash to desktop (the client)

    Hmm... can you maybe send me the full errorlog, either via PM or via mail?


    THEN when I log back in, the engine won't start. I can hop in the drivers seat, but engine wont start nor will boat move. Making a new boat works fine. Boat I crashed on will not.

    That's strange... did it happen in singleplayer or multiplayer? oO


    Also a suggestion: render distance of boats is minimal, could you increase that a bit? You need to be close to them for it to render.

    Yeah that's true, this will be changed :)

  • I had so much fun with this update that I'm honestly glad I streamed this on Twitch. I had fun finding out Red51 made boats the Wurm Unlimited way that it made me happy seeing that. I love that it feels weighted like that with anything easier would have cheapened the experience. Love both the boats, love the fishing rod (surprised to find out we could fish), while also amused by Red51 having his fun with the fish bones, rubber duck, and old boot.


    - QUACK!
    https://clips.twitch.tv/EvilAstuteKimchiBCouch


    - One of my pouches turned into Plaice, or even disappeared altogether.
    https://clips.twitch.tv/CoyZealousMinkRickroll


    I couldn't figure out how to make a medkit until Avanar pointed out it was in the tier II bench, something I looked at yet couldn't find the first few times. Not sure how I missed it. I love this update that I was genuinely a child on christmas waiting for the present to be unwrapped when I wanted to load it up that it took 10 minutes to download, update, and load in. I had Twitch & Streamlabs on standby waiting to play. Rising World is shaping up to be an awesome game that there's lots of fun to be had <3


    Great solid update with surprise fishing. :thumbup:

  • Quote from Red51

    That's strange... did it happen in singleplayer or multiplayer? oO

    Multiplayer. One regular players it happened to them. I find that it is more commonly triggered because im admin, and flying and using commands and such. Can't find the exact repro, but trying. Happens quite frequent if im flying, doing commands then attempt to jump back in and drive boat. Happened a bunch tonight. Here's the latest log errorlog_1538022285228.log

    "The past is history, the future a mystery, but today is a gift, which is why we call it the Present."

  • Can't remove paper from the press.

    Hmm... yeah this seems to happen mostly for small items which are laying very close to an object (which is true for paper on the press)... this issue will be sorted out very soon ;)


    I love this update that I was genuinely a child on christmas waiting for the present to be unwrapped when I wanted to load it up that it took 10 minutes to download, update, and load in

    Hehe, glad to hear you like it :)


    - QUACK!

    :thumbsup:


    - One of my pouches turned into Plaice, or even disappeared altogether.

    Oh, that's interesting... it looks like the pouch hasn't been added to the inventory at all 8| It's anyway strange that it took so long until the pouch showed up (actually the item is supposed to show up as soon as the rod starts to move)... please let me know if this happens again :)


    Multiplayer. One regular players it happened to them. I find that it is more commonly triggered because im admin, and flying and using commands and such

    Does it only happen if the game crashes?

  • I posted the log above. Game only crashes when getting into boat, but seems intermittent. Check my prior post. If java crashes, then I relog back in, im able to jump back in boat but motor will no longer work (the boat it crashed on). Other boats will work fine. The crash seems tied to getting into a boat, happens more if boat is close to shore, and I have been flying, using commands and such. Also confirmed, once the motor is broken, other players can't drive it either. The problem happened to one player only once all night. Happened to me consistently.

    "The past is history, the future a mystery, but today is a gift, which is why we call it the Present."

  • When shutting down the server with rcon there is a null pointer.


  • When shutting down the server with rcon there is a null pointer.

    Thanks for letting us know! Basically this bug has no impact on the server shutdown procedure, but of course it will be fixed with the next update :)


    Another one, I've added "rib" for the rib boat to the deny crafting list - but it still seems craft-able.

    You have to deny the underlying item instead. For the rowboat, you have to put "rowboatkit1" on the list, for the RIB, it's "ribkit1" accordingly ;)

  • I went in on a world and placed some water in creative mode, server side console appeared to get stuck in a loop (turns out it wan't an infinite loop - it just took a very long time ^^ )


    That said though, there is a lot of system println commands with format:


    Code
    START INT INT INT
    STEP BACK
    ===========LOCKED

    I know it's for debugging but my concern is the impact this may have on log file sizes?




    (The NullPointerException on de.kiw.gui.core.Screen.destroy line 244 also seems to stop you using the rp command)

  • Oh, that's interesting... it looks like the pouch hasn't been added to the inventory at all It's anyway strange that it took so long until the pouch showed up (actually the item is supposed to show up as soon as the rod starts to move)... please let me know if this happens again

    yeah i spawned a pouch and tried to open it and every time i've tried it has disappeared and not opened any interface






    keep up the good work
    :thumbup:

  • Before anything else i want to thank Red51 and all the crew for making Rising World what it is today. You guys managed to create a woderful community. Thank you for all your effort. The new updates look great and i'm very excited to start working with it.


    My issue is I am an admin and it seems I been having issues into Log in to any server, and most of the times there is no servers on the list, then after a few trials my server comes on but when i log in, everything is white and it doesnt load almost anything exept a few areas and stays that way. And also is there a way for admins dont be affected by the temperatures? I have tried gm 1 and i still suffer the effects of cold or heat.
    I used to be able to press TAB and walk or run while looking at the distance of someone i want to meet, but now when i open tab I cant walk or run which is a downgrade for me. Very boring have to stop every single time i want to see the details on TAB.
    I plan to become more active on the forum and share anything of importance here. Thank you

  • Thanks for this update :thumbup::thumbup:


    Some impressions on the first hours testing it :


    - fishing looks good (but it would be a must to do that in the boat or on chairs. but I guess we will need to wait until the mounted combat system ?). A rustic fishing rod would be nice for players who want to stick withe medieval themes.
    - boats are very nice and looks great. A question : as we can't pick it up, do they work like mounts (owned by the crafter) ? and only the crafter can mount them ?
    - The hot/cold : nice addition ! but we have not so much info except the icon in bottom right. Did the clothes makes difference ? (leather is warmer than coton or iron armor). A status showing in the preview model would be great or what you did for hunger and water (now they have numbers on it when you open your inventory), so we know if we are in good way or in bad way.
    - the crowbar remove poster : OH YEAH
    - Nice rework on the menu. the controls keys are more lisible
    - for the new rifle, I have the same « problem » with the repeater : we don't know exactly how many bullets we have in a magazine.perharps it's the right behavior and IRL you cant know how many you have too, but it seems to me more fair to know when you have to reload.


    That's for now. Thank's for your great work !

  • @Skillsmatter looks like you are either not at the same patch level as the server, or you need a reboot. A hotfix came out last night, and Steam sometimes needs to be restarted to get the new updates released. Steam doesn't auto patch very well. The connecting client needs to be be at same patch level as server, and usually you will get an error stating you have a different version.



    Quote from Red51

    Thanks for the log, this issue will be fixed with the next update (probably available in 1-2 days) Still looking for the broken motor issue though...

    Anytime Red, if you need help testing anything feel free to send me a PM anytime. The broken motor issue is tied to that error, only happens if I crash while trying to get in. It's definitely related to the crash I reported. I am wondering if it may be a plugin conflict issue. I do know ABM isn;t working right sinc the update and needs to be updated apparently. (nametag of animals no longer show up, haven't fully tested yet but others are reporting problems with ABM also). Thanks again for your game and updates. We have got our money's worth that is for sure. :) I'll let you know if I discover more info in regard to the issue, will do more poking around today.

    "The past is history, the future a mystery, but today is a gift, which is why we call it the Present."

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!