Update 0.5: World generation

A big new update is now available, introducing biomes, caves and much more!
Latest hotfix: 0.7.0.3 (2024-02-21)
  • I too use this all the time, both for blocks and objects :thumbup: collision toggle.

    Thanks for your feedback! It's good to know that this setting is actually used, so we'll definitely keep it :D


    Probably some objects (like ladders) should have more lightweight collapse conditions

    We've done some changes for the ladder in this regard, so with the next hotfix, they shouldn't break so quickly ^^


    There is a weird bug (related to modern workbench) - it will work only if you will stand really close to it. And the distance changes on game reloading/world travelling. Probably the area of interaction with bench is not calculated correctly or get an offset/rotations

    Thanks for letting me know! I guess this could be related to the chest that's placed in the workbench :wat: We'll fix that with one of the next updates (unfortunately the fix won't make it into the next hotfix)!

  • Another hotfix is now available btw. It introduces a new item - a standing torch which could be placed anywhere - and fixes some of the remaining bugs.

    This update needs to be installed on multiplayer servers as well btw.


    If there are no more major issues, we'll now focus on the NPC update :)


    Hotfix 0.5.0.3 2022-11-11:

    • [New] Added new object: standing torch
    • [Change] A single tree log now yields 4 lumber (instead of 2)
    • [Change] Player made caves close to the surface are now darker
    • [Change] Spinning wheel works faster now
    • [Change] Superflat worlds now have a grass surface (can be changed in config via "Game_NewFlatWorldTerrainID")
    • [Change] It no longer takes longer to dismantle loam blocks with a sledgehammer now compared to stone blocks
    • [Change] If the debug console is active, it's now moved to background automatically
    • [Change] Icons in inventory for walltorch and brazier are now brighter
    • [Bugfix] Fixed sickle not working properly if equipped from inventory (instead of hotbar)
    • [Bugfix] Fixed wrong wind and rain sounds inside buildings
    • [Bugfix] Fixed wrong view direction on chairs and benches
    • [Bugfix] Fixed undo command sometimes creating holes in terrain
    • [Bugfix] Fixed wrong climb direction on ladders in certain cases
    • [Bugfix] Fixed wrong day length if set to 24 hours
  • [New] Added new object: standing torch
    [Change] A single tree log now yields 4 lumber (instead of 2)

    Thanks for the standing torches, they're very handy. Shall be crafting and using them as much as I can from here on out.


    Thanks for the lumber, I've been having lumber issues so this effects me also. Thanks for the boost. :wow:



    [Change] Spinning wheel works faster now

    Helpful QoL fixes are my favourite. I'll soon be using the spinning wheel more often so this helps out a lot.

    [Bugfix] Fixed sickle not working properly if equipped from inventory (instead of hotbar)

    Nice! I saw the damages done and the complaints relating to it.


    ----


    Thanks for the update. It's a very handy update. While Microsoft Flight Sim updates with its 20 gigs I'll be playing Rising World on my Steam Deck. Transfering the save files is awesome. I wish I knew where it backed up the save files though. I need to know, I put mine up on Google Drive now. :monocle:

  • Thanks for your feedback! :)


    I wish I knew where it backed up the save files though. I need to know, I put mine up on Google Drive now.

    They're in the ".backup" folder in the "Worlds" directory :) If you open the world dir from the game (by rightclicking on the world), just go up one level to the parent directory, there you should see the ".backup" folder ^^


    Maybe we could add a "Backups" button to the singleplayer menu which brings you right to the backup folder :)

  • They're in the ".backup" folder in the "Worlds" directory :) If you open the world dir from the game (by rightclicking on the world), just go up one level to the parent directory, there you should see the ".backup" folder ^^


    Maybe we could add a "Backups" button to the singleplayer menu which brings you right to the backup folder :)

    I accidentally stumbled across it on my Steam Deck last night when I spent my time mining away at the terrain while Flight Sim downloaded its 22 gig patch.


    Thanks Red51. If there is a way I can have a smoother upload onto G-Drive that be handy, or Steam Save. Either way, I'm genuinely loving how accessible Rising World is, hence why I'm here. If my PC whines I can at least play it on my Steam Deck, if with a few limitations. I'd have to probably play desktop mode on Steam Deck, something I'll have to try eventually.


    You gave me a solution to stop the hanging on the exit, I'll keep that noted until next time. It hung on the Steam Deck again. Now, time to finish my builds, spam more standing torches. Time for more progress. I need to start spamming beds and other stuff around. :monocle:

  • Thanks to rеd51, it has become really darker in the caves, but the sun's rays and the shadow from the trees are still visible.

    Yeah, unfortunately this is still an issue which happens at certain elevations :thinking: It's on our to-do list :saint:


    Tiny bug, the help text for the 'right click to reset construction colour' is in German in the English version.

    Oh, thanks for letting me know! :wat: I will fix that immediately :D


    I get this error when trying to update the game in the standalone launcher, what do I need to do? It didn't happen before.

    We were just uploading an update, unfortunately downloads don't work during that time.. maybe we should show a more appropriate message there :D However, it should work now :)

  • Another minor update is available btw, which fixes a small annoying sound issue and also increases the spawn rate for lettuce ;) This update is optional for multiplayer servers.


    Hotfix 2022-11-13:

    • [Change] Increased spawn rate for lettuce
    • [Bugfix] Fixed wrong language in crafting menu tooltip
    • [Bugfix] Fixed random water "pop" sound that was heard sporadically for no apparent reason
  • Yeah, unfortunately this is still an issue which happens at certain elevations :thinking: It's on our to-do list :saint:


    Oh, thanks for letting me know! :wat: I will fix that immediately :D


    We were just uploading an update, unfortunately downloads don't work during that time.. maybe we should show a more appropriate message there :D However, it should work now :)

    Thanks!

    Also there is another thing I wanted to point out. I don't know if this bug was fixed yet, but sometimes when I mine, certain areas(or faces) of the terrain mesh don't get deformed no matter how much I dig.

  • Also there is another thing I wanted to point out. I don't know if this bug was fixed yet, but sometimes when I mine, certain areas(or faces) of the terrain mesh don't get deformed no matter how much I dig.

    This is unfortunately a bigger issue :/ We will definitely fix it, but unfortunately it requires a world conversion for existing worlds... this issue happens when mining in forest areas, but otherwise it should work a lot better... it's an annoying issue, and we will fix it ASAP!

  • This is unfortunately a bigger issue :/ We will definitely fix it, but unfortunately it requires a world conversion for existing worlds... this issue happens when mining in forest areas, but otherwise it should work a lot better... it's an annoying issue, and we will fix it ASAP!

    To be honest, this is happening to me underground in a high mountainarea as well. But i assumed its (like in Java) a matter of a tiny lack. Sometimes when i hit the rock with my pickaxe its making the correct sound but the rock is not changing shape or gone, no matter how often or how long i hit it. Neither do i get any material. But when i change the direction im looking at a tiny bit its working and when im going back to the original direction also the "resistant" rock can be pickaxed as well.


    As i have activated the fast harvesting (schnelles Abbauen) option i though its a lack that occurs when mining too fast. Next time its happening ill send a report

  • To be honest, this is happening to me underground in a high mountainarea as well. But i assumed its (like in Java) a matter of a tiny lack. Sometimes when i hit the rock with my pickaxe its making the correct sound but the rock is not changing shape or gone, no matter how often or how long i hit it. Neither do i get any material. But when i change the direction im looking at a tiny bit its working and when im going back to the original direction also the "resistant" rock can be pickaxed as well.


    As i have activated the fast harvesting (schnelles Abbauen) option i though its a lack that occurs when mining too fast. Next time its happening ill send a report

    I experienced this sometimes, too, but forgot to mention it.

Participate now!

Don’t have an account yet? Create a new account now and be part of our community!